Jump to content
Poweramp
PeteSapai

Problems with Crossfade, Fade and Gapless

Recommended Posts

1. Fade-in on auto-advance:
When auto-advancing, the "Play/Pause/Stop Fade Lenght" is used, even when "Fade Play/Pause/Stop" is turned off.
With FPPS off, I set PPSFL to 50 and then to 1000ms and it obviously uses this setting on auto-track change. There is the same fade-in on auto-advance as manual-advance. There is, however, no fade when resetting a track.
Suggestion/request: turn auto-advance fading off completely (seriously, who uses that?) or add a separate option for auto-advance fading (like PA 2 used)

2. "Seek Fade Length" seems to be set to 50ms; there does not seem to be a noticable difference when changing this to 500ms. Also, turning "Fade on Seek" off will still use the 50ms fade.
 
3. Crossfade/fade-in problem (I don't use this, but noticed it when testing problem 1):
The option "auto-advance Fading: crossfade on all songs" makes music crossfade when *manually* changing tracks and *not* on auto-change.

All of this tested with build 816 on a BQ Aquaris M5 vs 2.0.10 (where everything works as intended) on a Galaxy S4

E.g. with settings as in attached screenshot, there was a short seek fade and a long fade on auto-advance.

 

poweramp.png

Share this post


Link to post
Share on other sites

I think I found my problem and solution to #1 and 3: it only seems to happen with folders that contain a cue file (why are there cue files, you ask? To alter the info read by Foobar on pc, without editing the id3 tags and thereby changing the mp3 and its crc - but that's not really important or relevant). Solution: delete the cue files.

Also, when browsing Folders Hierarchy, a cue file is treated like a folder while the audio files in that same folder are ignored. E.g. if I have folder with 00-a.cue, 01-track1.mp3, 02-track2.mp3, etc., Poweramp will show 00-a.cue with a folder icon and the number of tracks on the right and nothing else. Don't know if this is a bug or working as intended.

Anyway, I don't intend to use cue files, but others might (they're popular with single-file-for-entire-album FLACs).

#2 is still bugged, though (to me) that's not 1/10th as important or annoying as #1 was.

Share this post


Link to post
Share on other sites

I have also noticed that the fade-in settings are not honored in v3. I have a post about that here: 

 

This was present in the Alpha:

 

And it was present in v2:

 

Best I can tell, little has been done to fix the issues with fade-in. Personally, I can't think of a reason why anyone would want fade-in at the beginning of a track.

 

Share this post


Link to post
Share on other sites

@danhashimage.gif.fea05ba43aa0898376fadda51373c80d.gifimage.gif.fea05ba43aa0898376fadda51373c80d.gif: I am having gapless issues (see my reply in another post about it), but after after reading your post I am beginning to wonder if this "fade-in issue" is actually causing or contributing to it...?

Share this post


Link to post
Share on other sites
On 1/28/2019 at 10:49 PM, danhash said:

Best I can tell, little has been done to fix the issues with fade-in. Personally, I can't think of a reason why anyone would want fade-in at the beginning of a track.

Weird, 'cause (as I said) the issues are only a problem for me when using cue files. I use Folder Hierarchy and no files (mp3 and ogg) have the fade-in problem. But yeah, I also can't imagine anyone wanting fade-in at beginning of tracks.

Fade on seek still doesn't work correctly, though.

Share this post


Link to post
Share on other sites
Just now, PeteSapai said:

Weird, 'cause (as I said) the issues are only a problem for me when using cue files. I use Folder Hierarchy and no files (mp3 and ogg) have the fade-in problem. But yeah, I also can't imagine anyone wanting fade-in at beginning of tracks.

Fade on seek still doesn't work correctly, though.

There are known issues with crossfading, e.g. stop playing before the end of the last song in a list :

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...