Jump to content
Poweramp
Sign in to follow this  
Epicdemic

200 out of 3000 songs not getting their tags read

Recommended Posts

Posted (edited)

Got a new phone recently and installed the full version on it. Tried scanning around 3000 songs and around 200 of them turned out to empty tags and are put under "Unknown Artist". The 200ish songs have no discernible difference from the rest of the 3000 and I'm quite stumped on why their tags aren't being read at all. Even funnier is that on my old phone, the same songs have their artist/album tags read just fine. Please help!

UPDATE: Found out why (or at least partially why). I transferred the music files through Airdroid app and for some reason, this breaks the tag recognition in Poweramp. When I do it through good ol USB transfer, the tags show up perfectly. Weird.

Edited by Epicdemic

Share this post


Link to post
Share on other sites

Very strange! If you compare one of the Airdroid-copied files to a traditionally USB-copied version of the same file, does there seem to be any differences in the resulting file? Or the containing folder? (What happens if you USB-copy a file into a folder that Airdroid created?)

 Andre

Share this post


Link to post
Share on other sites

I had roughly 20 out of 6500 tracks "corrupted" when I took my new phone into use and I don't believe PA caused it. My method of data transfer is to launch the built in ftp server on the Mi Max, and then ftp the files to the device. I assume the data copy to the device did something silly to the files as all meta data where gone for the 20 files.

What I did to resolve the problem was that I did go into the unknown folder, deleted all the files in there and re-synchronized the deleted files back to the phone.

Share this post


Link to post
Share on other sites
15 hours ago, andrewilley said:

Very strange! If you compare one of the Airdroid-copied files to a traditionally USB-copied version of the same file, does there seem to be any differences in the resulting file? Or the containing folder? (What happens if you USB-copy a file into a folder that Airdroid created?)

 Andre

The only difference is that one of them has all the metadata intact and the Airdroid transferred file doesn't, as far as I can tell. No size difference whatsoever.

USB copy into Airdroid app doesn't really make sense since I only use Airdroid to send files over WiFi between my PC and the new phone. The song file could be located on a harddrive or USB stick or SSD and it wouldn't make a difference.

I also tried using Airdroid to copy the song into either my phone's internal storage or the microSD card, same thing, no tags showing.

Share this post


Link to post
Share on other sites

Have you checked a resulting Airdroid-generated file in a tag editor (by copying the new file back over to your PC via USB, and running it through something like TagScanner)? Or even doing a binary file comparison to see if it's mangling the file in any way?

Andre 

Share this post


Link to post
Share on other sites

Tag data doesn't necessarily affect file size as there is a reserved space for tag data in the files. Could you check the md5 sum on the original file and the file on your phone, that will show if the files are identical.

What format are the problematic files in?

You could also try to install https://play.google.com/store/apps/details?id=net.mediaarea.mediainfo on your device, and see if MediaInfo is able to read the tags from your files.

Share this post


Link to post
Share on other sites
17 hours ago, 6b6561 said:

Tag data doesn't necessarily affect file size as there is a reserved space for tag data in the files. Could you check the md5 sum on the original file and the file on your phone, that will show if the files are identical.

What format are the problematic files in?

You could also try to install https://play.google.com/store/apps/details?id=net.mediaarea.mediainfo on your device, and see if MediaInfo is able to read the tags from your files.

So I tried this app out and to my surprise, the app DOES detect the tag data perfectly on the song that I'm trying to transfer over. But when Poweramp scans it in, all tag data is lost. Oh and all the songs are in MP3 format.

Also I have tried to copy the Airdroid-copied file back into my PC and the tag data are all still intact. Looks like Airdroid isn't even the issue here though, since MediaInfo still reads it just fine.

Share this post


Link to post
Share on other sites

Did Poweramp read the tags properly on your old device? Did you have the same version of PA on the old device? Could you share one of the problematic files?

Share this post


Link to post
Share on other sites

It's not folder/directory related is it? Are there other files in the same location as the problem ones which scan correctly?

Andre

Share this post


Link to post
Share on other sites

So I have the same problem.

I recently updated to Android Pie and did a factory reset, after reinstalling Poweramp (I previously also used the newest version), part of my library shows as Unknown artist - Unknown title - Unknown album. Funny thing is, the tags themselves are fine - when I go "Check Info/Tags", everything displays properly.

My phone is Xiaomi Mi A1, playing music from SD card.

Also on some songs only the Artist is missing and the rest of the info is displayed ok - but again, checking the tags, the Artist tag itself is correct.

Songs affected are .flac (none of the data showing) and mp3 (missing artist).

Share this post


Link to post
Share on other sites

Sorry about the late reply, here are some updates:

1. I used the latest version of PA on the old device and the same songs were read no problem.

2. The files with missing metadata are mixed in the same folder with files that are properly read. The folder is not the issue here. I also tried separating the problem files in its own folder, same issue.

3. Here's the weird part: after using MediaInfo app to check the metadata on one of the songs, the rest of the songs in PA that had problems were all magically fixed. It's as if their metadata needed to be read by another app for them to be "activated" in PA. That's just my crazy conjecture though.

Share this post


Link to post
Share on other sites

Please share one or two of such tracks via PM - I'll try to test them and investigate what's wrong (usually some broken tags, huge album art). Thanks!

Share this post


Link to post
Share on other sites
On 1/14/2019 at 4:39 PM, maxmp said:

Please share one or two of such tracks via PM - I'll try to test them and investigate what's wrong (usually some broken tags, huge album art). Thanks!

PM'd.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...