Jump to content
Vedant_1525

Gapless not working smoothly in the recent builds

Recommended Posts

I don't know if this is a bug or I'm missing something here, but I found that Gapless is not functioning smoothly in the recent V-3 builds (800+). 

When playing the last song in the list (when repeat turned off meaning the playback is supposed to stop after the current song ends), last 5-6 seconds are skipped and the audio stops without playing the last song till end. 

This happens to all the files being played last in the list and not with a particular track. I tried tweaking all the possible options in Gapless and Crossfade settings, but nothing worked. Even when "No Crossfade" is selected in Auto-advance Fading, same thing happens.

I could not reproduce this in V-2 with same files. So, I believe this is something with V-3' new Gapless algorithm.

I hope Max fix this in upcoming releases, cuz this is really annoying.

Share this post


Link to post
Share on other sites
3 hours ago, andrewilley said:

Have you tried build 816, as that includes some improvements to gapless performance.

Andre

2

Yes, I have tried 816 and still, I can produce the same bug. As far as I know, there were some Gapless improvements in the build 815 and not in 816 (Changelog!). But none of those seem to fix the problem.

The playback stops 5-6 seconds before the end time, like stops at 4:04 in a track which is 4:10 long and a pop-up appears which reads "List Finished".

Can you reproduce the same? This happens to me when the last track in the list is about to finish and the repeat is turned off completely. I expect the playback to stop under the same conditions but only after the last track is played to its last second and not skipping last 5-6 seconds of the final track.

Share this post


Link to post
Share on other sites
3 hours ago, Vedant_1525 said:

Can you reproduce the same? T

No, all the tests I did all allowed the audio to play right to the end of the track, nothing got truncated.

However the current-position counter does not always seem to show a completely accurate result at the end of a file though. I have one track for example which during playback displayed a total running time of 2:20:15, but during testing it finished playing correctly at the end of the audio, but with the current-position counter showing as 2:20:42. Other files showed a counter value a couple of seconds short of the total running time (even though the audio had played out to the end). Perhaps this is what you are noticing? Does the audio actually cut out early, or is it that just the counter shows a slightly off value? Regardless, neither are an issue with gapless playback as such.

Andre

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Perhaps this is what you are noticing? Does the audio actually cut out early, or is it that just the counter shows a slightly off value? 

No, the audio really cuts out early and the timer seems to stop 5 seconds before the total duration and this is the exact position from where the audio cuts out (no misbehaviour in timer noticed in my case).

Okay, I tried restoring default settings in Crossfade and Gapless settings, and turns out that it fixed the problem but at the same time I lost the gapless feature completely in my playback. But if I again change only the first option i.e. "Auto-advance Fading" set to "Crossfade all songs" same thing happens again. I never had such issue in V-2 as I have imported all of my V-2 settings in V-3. In V-2, even with "Crossfade all songs" the audio plays till the very last second of the final track in the list before stopping. That's what I expect in V3 (especially when same V2 settings are used in V3).

According to me, V3 cuts out the audio at the very moment when we expect to crossfade the next track ( last 5 seconds of the current track fades out and the next track fades in) but the problem is when there is no next track, meaning the audio is supposed to stop after the current track ends; however V3 fails to identify that there is no next track and at the moment of crossfade it ends up cutting the last 5 seconds of audio.

Can you please test the conditions mentioned below? (as I just did it)

Restore default settings in Crossfade menu, then change the 1st option i.e. Auto-advance fading to "Crossfade all songs". Play any list and turn off the repeat (which means audio should stop after the last song is played out) and jump to the last song (also notice the track counter as it should say for e g 15/15) and see whether V3 skips last 5 seconds of the last track before stopping or not? *This what exactly happens with me.*

For @maxmp, Device:- Xperia C-4 dual.

Stock ROM, Android version- 6.0

 

 

Share this post


Link to post
Share on other sites

Sorry, I have all crossfade options turned off, I should have asked you about that as there is a fade-out on Stop option. Gapless playback should happen anyway though, there is no option to specifically turn it off in v3 as far as I know, it is just how the player works unless you choose to crossfade instead.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

there is a fade-out on Stop option.

I believe this only applies to manual play/pause/stop since it didn't make any difference having it turned off or on in my case.

Yeah, I meant the CROSSFADE and not the GAPLESS in the previous post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...