Jump to content
Poweramp
ethan417

...I am so Frustrated with the 3.0 Interface

Recommended Posts

Hi

I have been a Poweramp user for 3 years.

I love Poweramp.

Until recently, it was a seamless and easy to use app to play the over 4,000 mp3's on my phone.

3.0 changed everything.

I can no longer select an album and expect Poweramp to play the entire album from beginning to end or repeat.

I can no longer select a playlist and expect Poweramp to play the entire album from beginning to end or repeat.

No matter what I do, Poweramp quickly wanders off course and just starts randomly playing songs.

Believe me I know how to use Poweramp - this is not a user error.

If I need instructions after 3 years - well - it just doesn't make sense.

I know a lot of research and time was put into developing 3.0.

I can't imagine that I am the only person who feels this way.

I know you  offer a backward path to 2.0. I'm aware of the conditions and am seriously considering going backward.

Don't know what else to say except, I no longer love Poweramp.

 

 

 

Share this post


Link to post
Share on other sites
55 minutes ago, ethan417 said:

I can no longer select an album and expect Poweramp to play the entire album from beginning to end or repeat.

I can no longer select a playlist and expect Poweramp to play the entire album from beginning to end or repeat.

Both of those things are standard features of PA, in both v2 and v3.

First, please ensure that you have Shuffle mode in the player interface turned OFF (tap on the icon on the right-hand side under the cover artwork). Then go into the Library view and find the particular Playlist or Album that you want to hear, and just tap on the first song that you want to listen to (or you can use the Play icon at the top of the list, which will start playback at the beginning of the album/playlist). The playback order is governed by  what you have chosen in the Menu > List Options screen in the songs view. The repeat options are up to you depending on whether you want to continue on to the next album/list afterwards, repeat, or stop (the icon next to Shuffle in the player screen controls repeat functions).

Andre

Share this post


Link to post
Share on other sites
10 hours ago, ethan417 said:

No matter what I do, Poweramp quickly wanders off course and just starts randomly playing songs.

Believe me I know how to use Poweramp - this is not a user error.

Generally this all works well, there are no grave bugs hindering playing. If it's clear how to operate the app, and still not working, the library might have been compromised by the migration to V3. You could try a full rescan.

 

032019114738.jpg

Share this post


Link to post
Share on other sites

Thank you for your suggestions.

I did a rescan prior to your post. 

Nothing has changed.

Please consider that I used Poweramp every day for 3 years and never had a problem. You might consider a YouTube tutorial to help familiarize users with the changes to the UI.

I am still having trouble getting Poweramp to do simple things as mentioned in my previous post. 

Thank you 

Share this post


Link to post
Share on other sites
1 hour ago, ethan417 said:

Nothing has changed.

That was rather my point, PA v3  should work in exactly the same way as v2 in terms of what you are asking. Go into the library view,  choose an album (or a playlist) and simply tap on the first song to start playback. What happens for you when you do that, as by default the whole album (or playlist) should play? (Assuming Shuffle mode is turned off) 

Andre

Share this post


Link to post
Share on other sites

#ethan417 - I've used PA for 6 years and I gotta agree with the above. I'm pretty limited in my expertise but the basic functionality when it comes to playing and shuffling and repeating seem to be no different. Have you just tried deleting and reinstalling? Maybe something is corrupted.

Share this post


Link to post
Share on other sites

 

Here's more information to help you diagnose the problem

FYI - I deleted and then reinstalled the app - the issues remain.

When I select an album to play, I get the  screen with the list of songs. In the upper left corner there is a shuffle button. I cannot change the shuffle options.
 
When I select the first song in the album to play I get the single song screen (fyi - it's pretty busy) it has shuffle controls as well. When I select play list and repeat  - PA switches to a new album after the first song. 
 
Not sure what's going on. 
Thank you.
 

Screenshot_20190103-100641_Poweramp.jpg

Screenshot_20190103-100606_Poweramp.jpg

Share this post


Link to post
Share on other sites

You didn't mention shuffling in any of your previous posts, just that you expected Poweramp to play the entire album from beginning to end or repeat.

The Shuffle icon in the list screen will shuffle the current category (which could be an album, folder, playlist, etc depending on what you are currently viewing) and then it will move on to the next similar category (i.e. next album next folder, etc).

However from the above it look like you have pressed the Play icon (or tapped on a song manually) and you have Shuffle off and Repeat set to Repeat List. That should make the current list play all the way through, and then repeat. If you tap on the metadata line near the bottom of the player screen it will show you more info, such as what category type that is in use and track# of how many tracks, the next planned song, etc.

Just a thought, but you don't have any songs in the queue do you, as that is designed to interrupt regular playback and play the queue once the current song is finished. That would not cause problems after a re-install though as that would wipe anything queued.

Andre 

Share this post


Link to post
Share on other sites

Andre

Thanks for your help.

I'm wondering, have you read the entire thread.

PA is shuffling - no matter what I do.

I have owned PA for 3 years and use it every day. I have never had this issue before.

My screenshot was intended to help me explain what is going on.

The shuffle icon that appears on the album screen cannot be changed - why is that.

I totally know how to use v2 - but v3 - is awkward and I have not been able to perform the simple task of selecting an album or playlist and having PA play the entire album and repeat.

Go figure.

 

Share this post


Link to post
Share on other sites
12 minutes ago, ethan417 said:

The shuffle icon that appears on the album screen cannot be changed - why is that.

The shuffle icon on the Album screen (i.e. the songs list for an album) has never been an adjustable mode, even back in v2 when you only got to it by long-pressing on an album name and choosing Shuffle from the popup list. You can however change it later in the player screen, are you saying that you cannot adjust it from there either by tapping on the icon during playback (your screenshots show it greyed out, i.e. turned off)?

What happened when you tapped on the metadata line near the bottom of the player screen like I suggested, what mode is PA playing in and what is shown as the upcoming next track?

Andre 

Share this post


Link to post
Share on other sites

I have the same type of problem on my Sony phone (Android version 8.0.0) but not on my Samsung tab S2 (Android version 7.1). Both have build 820.

I have organized all my music in folders. When I start playing on my Sony, the first track plays fine. The shuffle icon is 'do not mix' (crossed arrows - grey)

But then Poweramp shuffles to a different folder. I go back to the original folder and selects the second track. Them I press the shuffle icon until 'do not mix' and from then on everything works fine. It is anoying to do that every time I start Poweramp.

I have tried to press the shuffle icon during the first track, but to no avail. Poweramp shuffles anyway. 

I have compared settings on the two versions. No difference. I have tried to reinstall the Sony app. No change. 

Share this post


Link to post
Share on other sites

Thank you for sharing your experiences.

Despite all the help I received - see above, nothing worked.

Believe me - I know how to use PA. 

The moment I reverted to V2 all issues vanished.

I am once again totally pleased with PA V2.

 

Share this post


Link to post
Share on other sites

I rmb encountering the same issue with build 709 or 792.

I wasn't sure what solved it.

might be old app data or reformat of sd card is required.

 

Never encounter such issue on v3 tho.

Share this post


Link to post
Share on other sites

Could someone who has this problem upload a short video showing what happens (set the meta data line to show the path details)? What do you have the List Options sorting order set to in the library view for Folders, and for songs within folders? Are you launching your songs from within Folders or Folders Hierarchy mode (although that should not make a difference). Have you tried doing a clear-data or re-install on PA, and/or a Full Rescan?

Andre

Share this post


Link to post
Share on other sites

I cannot find any options for folders within settings. But under lists I have "do not mix" in folder hierarchy. and "do not mix" in kategories. I am launching songs from within folders. I cannot find folder Hierarchy mode. I have reinstalled PA twice. Same result.  

I have a film (30 sec), but it is 140 MB. How do I send this. My film editing sw is not capable of reducing size.

Share this post


Link to post
Share on other sites
17 minutes ago, Jhorlyck said:

I cannot find folder Hierarchy mode.

Access the library via the button in the lower left corner.

A list with what Poweramp call "categories" comes up, "albums", "artist", etc

If this list includes "Folders Hierachy", choose it.

If not, press the Button with the 3 dots in the upper right corner, choose "List Options", then a list of possible categories appears.

Activate "Folders Hierachy", close the list, and it should appear in the libary.

Share this post


Link to post
Share on other sites

I have found it.  But I have no folders in hierachy. All music is in separate folders - one level. So I have disabled folder hierarchy again. 

Share this post


Link to post
Share on other sites
2 hours ago, Jhorlyck said:

I have found it.  But I have no folders in hierachy. All music is in separate folders - one level. So I have disabled folder hierarchy again. 

Sorry, are you saying that you don't have any nested subfolders physically on your device - such as songs inside album folders, which are inside artist folders? Or that you have all your folders set up in one level?

Poweramp can display either version anyway. "Folders Hierarchy" allows you to drill down from the top through to various levels of subfolder, whereas the basic "Folders" mode presents a long list of all folders (but still sorted in the same order as on the storage). Oh, and in Hierarchy mode you can tell it whether you want to start showing a single root folder (for example showing just "Music", which is a bit pointless) or the first level where there are choices (i.e. starting inside the "Music" folder).

Andre

Share this post


Link to post
Share on other sites

But I still have the original problem: no matter how I play from a folder, PA jumps to a different folder after first track. I have a film to show that

Share this post


Link to post
Share on other sites
6 minutes ago, Jhorlyck said:

 I have a film to show that

Can you upload that please, share via Dropbox of Google Drive for example. Although 130MB for 30 seconds is a bit excessive! :)

Andre

Share this post


Link to post
Share on other sites
3 hours ago, Jhorlyck said:

Looks like you have got unplayed items that you placed in the Queue, which will start playing after the end of any current track until your queued songs are finished. There is even a popup toast message visible in the video telling you that. The metadata line (which I asked you to tap on and show in the video) would have confirmed that too.

Go to the top Library categories view, tap on Queue and you'll see a list of all the songs you've placed there. If you no longer wish to listen to any of them, tap on the three-dots icon and select 'Clear Queue'.

Andre

Share this post


Link to post
Share on other sites

Thank you. I did not know I had a queue. Nor how these track ended up there. But that explains that my tablet version never behaved like that.

Jens

Share this post


Link to post
Share on other sites
1 hour ago, Jhorlyck said:

Thank you. I did not know I had a queue. Nor how these track ended up there. But that explains that my tablet version never behaved like that.

The queue has been around since the early days of Poweramp. It's there to allow you to break away from your regular (e.g. Folder) playback and listen to some specific songs, and your regular playback will resume after the queue is done. It would eventually have finished, but depending on how many tracks you had added it could have taken a while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×