Jump to content
Poweramp
maxmp

Poweramp Build 816

Recommended Posts

1 hour ago, sztsam said:

I remember that Poweramp v2 had a seekbar on the list view. It would be really nice to have it on v3.

+1

Share this post


Link to post
Share on other sites

Love the new UI, looking very sleek! Could I please request a feature that was removed with major update? The ability to play a single song with the expanded options menu (ie long hold).

 

For me, I use the queuing function as the default, but there is no way now to play a single song without queuing, going into the queue and then playing from the first song in the queue.

 

If this is already a feature please let me know, I just can't find it since the revamp.

 

Many thanks!

Share this post


Link to post
Share on other sites
20 minutes ago, liltimmy said:

The ability to play a single song with the expanded options menu (ie long hold).

Poweramp has never had the ability to play a single song then stop. The long-press options for starting music (play, shuffle, etc) are now available after a tap rather than a long-hold.

Andre

Share this post


Link to post
Share on other sites
9 minutes ago, andrewilley said:

Poweramp has never had the ability to play a single song then stop. The long-press options for starting music (play, shuffle, etc) are now available after a tap rather than a long-hold.

Andre

Thank you for your quick reply Andre.

I'll try and clarify what I mean. Because I have changed in the options for a single tap to simply enqueue rather than provide me with that menu (the menu which used to be long hold as you say) I have no way of starting music without navigating to the queue. Is there a way round this whilst keeping the quick one tap queue functionality?

 

In the previous major build I loved the versatility Poweramp provided of easy queuing for longer listening sessions, but also quick playing from a list for a one-off song.

Share this post


Link to post
Share on other sites

Thank you very much for this new update. It is impressively good!

I would like to make a suggestion. If possible, it would be nice to have a 'play next' option when a song is selected. Once that PA song was played, it would continue with the playback that was predefined (random, 'play queue', 'all songs', etc.)

thank you.

IMG_20190102_155923.jpg

Share this post


Link to post
Share on other sites
11 hours ago, liltimmy said:

Because I have changed in the options for a single tap to simply enqueue rather than provide me with that menu (the menu which used to be long hold as you say) I have no way of starting music without navigating to the queue.

Ah, I see what you are asking now.

In Settings > Library > Queue you can tell PA to start playing an enqueued track immediately, rather than waiting until the end of the current track, but you would probably be better simply setting tap-to-play mode for the songs list, and use long-press for enqueuing.

Andre

Share this post


Link to post
Share on other sites
On 1/1/2019 at 9:19 PM, maxmp said:

@cheungie try to reset audio outputs to defaults. If you’re on Pie, try Hi-Res output, especially if you’re upped basses.

@maxmp I did what you suggested and increased the buffer size to huge. It seems to solve the problem. 

Share this post


Link to post
Share on other sites

I would like to see a "play next" and "play later" options like in itunes and musicbee.   Where you play a playlist or whatever and manually choose a song to play next and then resume playing what list it was playing.

Share this post


Link to post
Share on other sites

My hi Res is still saying only 16 bit at 48 kHz on my

2 hours ago, FeedLeeRack said:

Are you working on fixing hi-res on the S9 Pie update?,because i have wrote many times but i got no unswerd

s9 plus on pie same here

Share this post


Link to post
Share on other sites
4 hours ago, hypomaniac-eric said:

I would like to see a "play next" and "play later" options like in itunes and musicbee.   Where you play a playlist or whatever and manually choose a song to play next and then resume playing what list it was playing.

In Poweramp, that's called the Queue. While you are listening to your normal music playback (for example an album, an artist, a folder, etc) just search for a song, or look through your Library, and then long-press on something you want to listen to next (could be a single song, or tick multiple songs, or choose an album title, etc) and tap Add to Queue.

You can set the queue to operate in two ways, either for the first queued item to start playback immediately, as soon as you add it to the queue, or wait until the currently playing song is finished before the queue starts playing. See Settings > Library > Queue to adjust.

Once the queue is finished, normal playback will resume from where it left off.

Andre

Share this post


Link to post
Share on other sites

Hi @maxmp, CJK characters in UTF-8 CUE file is not displayed correctly. If I use UTF-8 without BOM, any CJK characters cannot be displayed correctly. If I use UTF-8 with BOM, only the song title is correct, artist is incorrect.

Please address this issue. Much thanks.

Share this post


Link to post
Share on other sites
9 hours ago, andrewilley said:

In Poweramp, that's called the Queue. While you are listening to your normal music playback (for example an album, an artist, a folder, etc) just search for a song, or look through your Library, and then long-press on something you want to listen to next (could be a single song, or tick multiple songs, or choose an album title, etc) and tap Add to Queue.

You can set the queue to operate in two ways, either for the first queued item to start playback immediately, as soon as you add it to the queue, or wait until the currently playing song is finished before the queue starts playing. See Settings > Library > Queue to adjust.

Once the queue is finished, normal playback will resume from where it left off.

Andre

Oh I must have missed something.  I tried queing a song up many months ago but it left the playlist and went to que for that one song and then i had to go back to the playlist all over again .  I never used que till that one day but not used to the layout of it all.   How do you switch from que back the recently played playlist without going through the list of playlists all over again?  

Share this post


Link to post
Share on other sites
5 minutes ago, hypomaniac-eric said:

 How do you switch from que back the recently played playlist without going through the list of playlists all over again?  

Adding a song to the queue doesn't remove it. Depending on the settings it either plays the song directly from the queue, or after the currently playing song has finished. When the queue has finished, either PA returns to the previous list, or it stays in the queue, this also depends on settings.

Share this post


Link to post
Share on other sites

ok now this is weird.   @maxmp  When rotating the screen sideways and back sometimes it changes songs album cover and all.  I didn't have music playing so i don't know what it would do then.   But when rotating from vertical to horizontal in back it sometimes shows a different song either vertical or horizontal.  I have no idea how or why that happens.  

Share this post


Link to post
Share on other sites
4 hours ago, hypomaniac-eric said:

How do you switch from que back the recently played playlist without going through the list of playlists all over again?  

The "Recently Played" list would probably not be able to return back to the same position after playing a queued track, as the very fact of playing a track would change the contents of that list and force PA to reload it. Non-dynamic lists (albums, folders, playlists, etc) should return to where they left off after any queued items are finished, assuming you have that option selected in Settings > Library > Queue.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

The "Recently Played" list would probably not be able to return back to the same position after playing a queued track, as the very fact of playing a track would change the contents of that list and force PA to reload it. Non-dynamic lists (albums, folders, playlists, etc) should return to where they left off after any queued items are finished, assuming you have that option selected in Settings > Library > Queue.

Andre

So I tried changing the setting for queue and queued up the song and then when it was done it just stopped.   It did not return to the playlist and keep playing.   I'm so disappointed.   How do I go back to the playlist in the same spot without having to hunt for the playlist and then scroll through up to a 1,000 songs to find where i was?  edit:  I was also on shuffle for the playlist as well.  btw. 

Share this post


Link to post
Share on other sites

Oh I'm so mad.   I went back to the playlist and it's empty!!!!   So I selected a different one and 10 seconds later the music stopped and it was on all songs and the playlist was empty.   So i had to pick a different one again.   and it played.   How many more updates do we need to fix this?  I want to extract the app from my phone and throw it at the wall as hard as I can.   I've never had an app cause such grief in my life.   

Share this post


Link to post
Share on other sites

I think there is a bug in notification type.

Type 'Auto': everything looks ok.

Screenshot_2019-01-04-06-39-47-149_com_miui_home.thumb.png.2b0e27f016a5d47711208d643da5037d.png

 

Type 'Media/Colorized': some track data is missing/displayed incorrectly.

Screenshot_2019-01-04-06-40-48-656_com_miui_home.thumb.png.57f59b98dd0ead8ecc035ea7888551eb.png

Share this post


Link to post
Share on other sites

I don't know if this is a bug or I'm missing something here, but I found that Gapless is not functioning smoothly in the recent V-3 builds (800+). 

When playing the last song in the list (when repeat turned off meaning the playback is supposed to stop after the current song ends), last 5-6 seconds are skipped and the audio stops without playing the last song till end. 

This happens to all the files being played last in the list and not with a particular track. I tried tweaking all the possible options in Gapless and Crossfade settings, but nothing worked. Even when "No Crossfade" is selected in Auto-advance Fading, same thing happens.

I could not reproduce this in V-2 with same files. So, I believe this is something with V-3' new Gapless algorithm.

I hope Max fix this in upcoming releases, cuz this is really annoying.

Share this post


Link to post
Share on other sites
32 minutes ago, Vedant_1525 said:

When playing the last song in the list (when repeat turned off meaning the playback is supposed to stop after the current song ends), last 5-6 seconds are skipped and the audio stops without playing the last song till end. 

I am just curious: what does the played time show ? I sometimes encounter the effect that after the last song it shows neither the song's duration nor "0:00" but something like "0:06". Maxmp explained that this comes from the ffmpeg-decoder that Poweramp uses.

Share this post


Link to post
Share on other sites
5 hours ago, hypomaniac-eric said:

Oh I'm so mad.   I went back to the playlist and it's empty!!!!   

Are these file-based (e.g. M3U files) playlists that got wiped, or internal Poweramp playlists?

I've just tried what you mentioned, and the following process worked fine for me:

  • Started a Playlist playing and enabled 'Shuffle Songs' mode,
  • Moved forward a few tracks, so it was playing random track 4 out of 36 from the playlist.
  • When into the library and queued up an album (which added 20 tracks to the queue).
  • Waited for the current song (i.e. 4 of 36 in the shuffled playlist) to finish, and the queue automatically commenced as expected (as I have the "Start Queue after current song finishes" mode enabled).
  • Moved through all 20 tracks in the queue, and at the end of the final track playback automatically resumed at track 5 of 36 in the original shuffled playlist. I could use the << button to move backwards through the shuffled list to the previous track 4, 3, etc which indicated that the shuffle sequence had not been re-randomised.

Andre

Share this post


Link to post
Share on other sites
1 minute ago, andrewilley said:

Are these file-based (e.g. M3U files) playlists that got wiped, or internal Poweramp playlists?

I've just tried what you mentioned, and the following process worked fine for me:

  • Started a Playlist playing and enabled 'Shuffle Songs' mode,
  • Moved forward a few tracks, so it was playing random track 4 out of 36 from the playlist.
  • When into the library and queued up an album (which added 20 tracks to the queue).
  • Waited for the current song (i.e. 4 of 36 in the shuffled playlist) to finish, and the queue automatically commenced as expected (as I have the "Start Queue after current song finishes" mode enabled).
  • Moved through all 20 tracks in the queue, and at the end of the final track playback automatically resumed at track 5 of 36 in the original shuffled playlist. I could use the << button to move backwards through the shuffled list to the previous track 4, 3, etc which indicated that the shuffle sequence had not been re-randomised.

Andre

yes they are file based, synced from musicbee.   I don't use the regular based ones as they eventually get cleared out for whatever reason.   and I get duplicates, the regular ones and the file based ones.  but the regular ones are empty after awhile.   never figured out why that happens.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×