Jump to content
Poweramp
maxmp

Poweramp Build 815

Recommended Posts

18 hours ago, Absinthequ said:

Maxmp would have to create a whole new option just for this category. Artist label always shows in Album Artists category for tracks. 

Reasons:

1. Compilation albums - logically PA doesn't recognize the name of the folder of various artists' tracks, hence when viewing via Album Artists category they are scattered. 

My solution: I edit all songs' Album Artist tag in the folder to VA or Various Artists, or sometimes just to be specific, FolderName VA first in my laptop then upload to my phone. 

2. With #1 above, leaving Artist tag as it is for the track/s I would know the said Artist but then again playing via AA category only shows the AA tag coz that is how it was designed to be. We get it. 

3. We implore you @maxmp to give us a chance to have an option as @Absinthequ detailed above, in order for the main player, list, notification panel, and other sections of the app I might've missed to include to show the Artist tag when playing via Album Artist category. 

4. The Album Artists category has a much consolidated look for albums by artists plus the fact that we can shuffle/play all of the Artist's songs in one tap wherever the actual physical folder of that Artist is saved in the storage. It doesn't need to be specifically in /storage/album/artistalbum1... 2... 3... Etc. Unlike the Folders or Folders Hierarchy category. 

Hope I got this clearer as I also made a feature request but didn't get any response. 

Share this post


Link to post
Share on other sites

If I use Google Play Music then close it down and switch to Poweramp, sound from Poweramp will not play through my Bluetooth headset.  I can still control volume and track advance, but sound only comes through my phone speaker.  I have tried various things (dis/reconnecting the headset, changing SmartThings settings & even disabling SmartThings, turning Bluetooth for the phone off and back on etc) in an attempt to get the sound playing through the headset again but the only thing I've found that works is rebooting the phone.  But once I use Google Play Music again the problem returns when I try to use Poweramp again afterwards.

This hasn't been a problem until recently, 815 I think, but Google Play Music also released an update earlier this month.  However, I use both apps on a daily basis and haven't noticed this problem until very recently - perhaps 2 or 3 days ago.

I use both Poweramp (815) and Google Play Music on my Galaxy S9+ so I can run two playlists and keep the current location (playing song) for both lists.

Share this post


Link to post
Share on other sites
15 minutes ago, Gork said:

 

I suppose you're on Hi-res output? Try Settings / Audio / Advanced Tweaks / toggle On "Force Speaker Off"

Share this post


Link to post
Share on other sites
34 minutes ago, invaderzim said:

I suppose you're on Hi-res output? Try Settings / Audio / Advanced Tweaks / toggle On "Force Speaker Off"

Thanks!  So far this seems to work - and yes, Hi-res.  I'll post back in the next few days if further testing proves problematic.  Curious as to the change requiring this setting to now solve a problem which didn't seem to be there before.

Share this post


Link to post
Share on other sites

Please have the Album Artist view of a selected album honor the "Album Artist Label..." settings in Library -> Lists. Just for grins name the track artists for these displayed tracks off the top of your head.

Screenshot_20181229-121856.thumb.png.b95f3257c72b7121cf232e823427a7c4.png

Share this post


Link to post
Share on other sites

If the Album Artist view of a selected compilation album honored the "Album Artist Label..." settings in Library -> Lists it would look like this.

Screenshot_20181229-123119.thumb.png.6edf8811920544038088e580fd085a15.png

Share this post


Link to post
Share on other sites

Can something be done for sorting by title. Currently numbers like 100 appear before numbers like 2 or 42. I think Poweramp is sorting based on the first digit instead of the entire number.

I also link an image showing this. This didn't used to be in v2.

Screenshot_20181229-175549_Poweramp.jpg

Share this post


Link to post
Share on other sites
33 minutes ago, supcube said:

Can something be done for sorting by title. Currently numbers like 100 appear before numbers like 2 or 42. I think Poweramp is sorting based on the first digit instead of the entire number.

I also link an image showing this. This didn't used to be in v2. 

How is PA expected to know what part of the title should be interpreted numerically ? One would have to introduce a sorting option that takes a format string like the Unix sort command does.

As to the screenshot : what were your sorting options ?

Share this post


Link to post
Share on other sites
41 minutes ago, blaubär said:

How is PA expected to know what part of the title should be interpreted numerically ?

That's how Windows does it, strings of consecutive numbers are treated numerically for filename sorting purposes.

Andre

Share this post


Link to post
Share on other sites
11 hours ago, w3wilkes said:

If the Album Artist view of a selected compilation album honored the "Album Artist Label..." settings in Library -> Lists it would look like this.

Screenshot_20181229-123119.thumb.png.6edf8811920544038088e580fd085a15.png

Please don't confuse the Album Artist tag in the Album Artist category. The Album Artist tag will always be Various Artist, Various or how you name the tracks in the compilation album/folder. If you will read my post above what you want is also my request to Max. It is simple, have an option to enable Artist label always shows in Album Artist category for tracks. This way we see the Artist despite being on the Album Artist category, same as your image above. This will be true to the main player, notification panel and other locations in the app. 

Share this post


Link to post
Share on other sites

Hi

Early testing is looking good with my gapless issues - brilliant - more testing when I'm back at work and using it all day.

One other issue - the small "What's Playing" thing on this screen, occasionally shows a totally wrong track - see below- the FLC Track shown wasn't what was playing and hasn't been played for some time!

 

 Screenshot_20181228-100633.thumb.png.636637c070c10453aba2940c3dc6a05f.png

 

Screenshot_20181228-100652.thumb.png.6c66999c9153ce33f9dda27276b5a5c1.png

 

Not a huge issue at all really now that the gapless issue seems to have been sorted

 

Many thanks - I'll report back only if gapless issues reappear on further testing!

Share this post


Link to post
Share on other sites
1 hour ago, eserim said:

One other issue - the small "What's Playing" thing on this screen, occasionally shows a totally wrong track - see below- the FLC Track shown wasn't what was playing and hasn't been played for some time!

It's also called "navbar" or "miniplayer" 😀. And you're not the only one with this issue:

 

Share this post


Link to post
Share on other sites
33 minutes ago, blaubär said:

It's also called "navbar" or "miniplayer" 😀. And you're not the only one with this issue:

 

Ah - thanks - I thought I had been keeping up 🙂 obviously not.

Share this post


Link to post
Share on other sites
1 hour ago, eserim said:

Not a huge issue at all really now that the gapless issue seems to have been sorted.

I know right, isn't it awesome?! I did loads of testing and no gapless issues at all.

Share this post


Link to post
Share on other sites

notice some irregular display of elements. i'm using build 815. whenever i'm adjusting the knob ,the value zooms in until it can't be seen. not only the l/r output but also stereo expansion and volume knob. 

Screenshot_20181230-193944_1.jpg

refer to his thread: https://forum.powerampapp.com/topic/16058-several-very-obvious-bugs-have-been-found-please-fix-them/

Share this post


Link to post
Share on other sites
11 minutes ago, maxmp said:

@eserim have you noticed what was the category track was from when such bottom miniplayer de-sync happened? Thanks!

No - but I'll keep an eye on it next time.

Share this post


Link to post
Share on other sites
20 hours ago, blaubär said:

How is PA expected to know what part of the title should be interpreted numerically ? One would have to introduce a sorting option that takes a format string like the Unix sort command does.

As to the screenshot : what were your sorting options ?

I don't know how it can be done, i don't know about coding, but i know it can be done since that's how it worked in v2. I have also seen gallery apps like QuickPic that have a toggle in the settings for things like that.

In the screenshot i posted i have it sorted by Year, since this artist has multilple albums are released on the same year Poweramp's second criteria of sorting is by Name.

 

Share this post


Link to post
Share on other sites

Poweramp v3 supports same sortings as v2 and adds more. It continues to support track number infered from filename, but actual track # in tags takes priority over filename number.

Share this post


Link to post
Share on other sites

V815 updated today on my device. Sounds really good. Sound is 99% of a music player in my view..the rest is just visual aid. 

Share this post


Link to post
Share on other sites
On 12/30/2018 at 4:04 PM, maxmp said:

Poweramp v3 supports same sortings as v2 and adds more. It continues to support track number infered from filename, but actual track # in tags takes priority over filename number.

V3 does indeed support the same sortings as v2 but they work differently or they are bugged.

In the image i posted before i show the albums of a certain artist, therefore filenames have nothing to do with the problem, neither do the track #.

My problem is when in a list that is sorted by title, and the titles have numbers, numbers like 100 would be between 1 and 2; instead of 100 being after 2, which would align with regular numerical conventions.

I personally would like it to function the way andrewilley mentioned before, that is, in the same vein as Windows Explorer, where strings of consecutive numbers are treated numerically for sorting purposes.

 

Share this post


Link to post
Share on other sites
9 hours ago, supcube said:

My problem is when in a list that is sorted by title, and the titles have numbers, numbers like 100 would be between 1 and 2; instead of 100 being after 2, which would align with regular numerical conventions.

As Max said, this is the same as v2 as far as I know. Are you saying V2 provided natural numerical sorting,  rather than simple character-accurate ASCII sorting? 

Andre

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

As Max said, this is the same as v2 as far as I know. Are you saying V2 provided natural numerical sorting,  rather than simple character-accurate ASCII sorting? 

Andre

Yes, V2 had numerical sorting. I had the same music when i used v2 and it was sorted numerically.

Share this post


Link to post
Share on other sites

@supcube thanks for the screenshot, but Poweramp (any version) doesn’t sort as you’re expecting it, it sorts by track tag (numeric tag) if appropriate sorting (by track#) is selected in List Options for given list. IF tags are missing from the song, Poweramp will substitute file name number into track field.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×