Jump to content

Cannot control Poweramp from Pebble


Recommended Posts

Hello there!

I've experienced this issue since the first time I've tried the v3 beta (quite some time ago). I've noticed it reported here and there by other users too. Now that the stable line has been updated to the v3 branch...

Control from the default music control app found on the Pebble watch is no longer working. No pause toggle, no next/prev song. This seems to be an Poweramp specific issue since all other apps (Spotify, Play Music, Deezer, Tidal, etc) are working as expected. Moreover if one of those players have a permanent notification present, even if Poweramp is currently playing, the other player will intercept the command and act accordingly. 

A similar problem is noticeable with the playback commands sent from Tasker app. Neither in this case Poweramp is not reacting.

The issue is Poweramp v3 specific and, since it is very annoying, I'm seriously considering jumping back to the last v2 release.

Otherwise, thanks for the great Poweramp update!


PS: I am free to provide any assistance in solving this issue.

Link to comment
Share on other sites

I don't develop or somehow can touch/modify or do something the pebble companion app you're using, unfortunately. Poweramp obviously supports all the API required - it's the same as used for lockscreen, media buttons, etc. functionality. I can't comment on other apps as well - they are too different from Poweramp (specifically, Powermap doesn't use system media player as they do). Sometimes ROMs just tuned for that system media player and have bugs for any other audio sources.

Some devices/ROMs have bugs around hi-res output - when they play via it, they (or their particular components) don't know music is played as they don't understand such audio or they fail to support appropriate APIs (some of them 5 years old) and use something like Android 2.x era APIs which work only with normal audio, some other devices can have other issues, but I can't comment on this as you didn't provide any further info.


Link to comment
Share on other sites

maxmp, I totally understand your point and respect it. No questions asked about absolute support! But...

Something has changed between version 2  and version 3 of Poweramp. Otherwise I cannot explain why there is no similar problem on v2 .This is the only thing I am trying to say and that's why I insisted on mentioning it.

maxmp, I will try to find out more details on the Tasker forum (like what methot/intent it is used) and I'll return.



Scopesys, I'm not sure these two issues have anything to do with one another.

Link to comment
Share on other sites

Many things changed between v2 and v3. Try normal audio output (Not hi res) - if it works with this output - the problem is with the old apis usage.

Also Google pushes new/updated apps to higher target sdks, while some old apps stay on lower sdks. Higher target sdks have much more limitations.

Link to comment
Share on other sites

I can confirm Pebble remote control is not working on this new version (814). Phone is a Verizon LG V30, stock ROM (Android 8.0.0). I have tried all 3 outputs and none of them allow control via Pebble. Meta transfer is still happening (still getting track info on the watch), it's just inputs that do not work. Volume control is still working, but I suppose that is a system control instead of a direct app control. Other players still respond to the controls.

Also, I had trouble getting my bluetooth headset's controls to work (Sony WH-1000MX2). I had to clear the app storage to reset to defaults to get it to work. It works with all 3 outputs. But, I absolutely hate the touch controls on this headset so I'd rather use the watch controls.

In the Developer options on this version of Android, the AVRCP version can be adjusted between 1.4-1.6. I have tried all 3 versions and that doesn't help either.

Link to comment
Share on other sites

I've just reinstalled Poweramp and then reset the settings to default (from within Poweramp). Tried AVRCP 1.3 to 1.6 on default output (restarted the phone after each AVRCP version change). Somehow Play Music works, Poweramp doesn't.

I don't know what else to try!

PS: My phone is a OnePlus 5 with OxygenOS v5.1.7 (Oreo).

Link to comment
Share on other sites

  • 1 month later...

@maxmp Looks like this issue has been reported since v3 alpha https://forum.powerampapp.com/topic/9235-bug-mediacontroller-commands-ignored/?tab=comments#comment-35268

v2 works perfectly fine and allows control from such devices as Garmin or Pebble smartwatch, etc. While v3 ignores these commands.

I posted detailed report here, but still no response (in general, changing output doesn't help): https://forum.powerampapp.com/topic/8998-lost-pebble-track-control/

Is there any chances to fix this for v3? Maybe add some settings toggle which will switch to old-good-working logic from v2?

Related Garmin thread: https://forum.powerampapp.com/topic/15521-bluetooth-controls-dont-work-on-garmin-vivoactive-3-smartwatch/?tab=comments#comment-66596

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...