Jump to content
Poweramp
tommochocolate

Can't work out how to enable gapless playback on new version

Recommended Posts

On 2/26/2019 at 7:10 PM, blaubär said:

Yes, it's in the tags, and shown in the audio info and tag info.

Thanks, but I obviously misphrased my question: is there a formal way of checking whether a given file is encoded for gapless playback without using Poweramp? After all, my problem is that Poweramp won't play these tracks gaplessly, so I wouldn't expect it to acknowledge that they're gapless. On the other hand, Windows Media Player will play them gaplessly, and as far as I can tell it isn't able to do that with files that aren't encoded for gapless playback - so I want some way of checking that I can reasonably trust.

EDIT: I have just done some tests and have found the following: if I rip tracks from a CD in wma format with Windows Media Player 12, they play gaplessly in Media Player but do not play gaplessly in Poweramp (and Poweramp does not say "gapless" in the audio info). I believe that these tracks are encoded for gapless playback on the grounds that they play gaplessly on Media Player and that the Wikipedia page for gapless playback says "Windows Media Audio encoded with Windows Media Player 9 can be gapless with Windows Media Player 9 and onwards". Therefore I conclude that Poweramp will not play (these) gapless wmas gaplessly. Is Poweramp really able to play gapless wmas without gaps?

Share this post


Link to post
Share on other sites

I brought this issue up.

FACT:  I can take the exact two same files and play them on Poweramp V2 without any stutter between tracks.  The same two identical files stutter on V3.  I can even downgrade to V2 to get them to work again with no stutter. Some functionality has been lost.

FACT: The issue occurs with mp3 files, but not WAV on V3.  Same exact tracks - WAV works; mp3 does not.

FACT: The issue occurs even when I don't store them on the SD card (i.e. I use the phone's internal storage to eliminate the possibility of "very slow storages, like slow sd cards"

FACT: The issue occurs in versions of V3 up to 816.

FACT: Poweramp absolutely blows away the competition in all respects, so I'm staying with it.  I can't even begin to describe how much better the audio quality is when I have the output set to OPENSL ES, and the stereo expansion set to 100% (note - 100% is optimal for old two-track soundboard source tapes from the 70s, such as the Grateful Dead; may need to cut it back on modern recordings).

Most important FACT: I found if enable cross-fading and set the slider to the lowest # of milliseconds, the problem is almost not noticeable, so that's what I've been using as a workaround.  I do notice on transitions into songs with "hard intros", such as Slipknot => Franklin's Tower, but for something like China Cat Sunflower => I Know You Rider, the transition is almost imperceptible.

But it should be not be lost on us that the issue simply does not occur in in Poweramp V2.

Thanks max for such a great product - I am pretty stoked with V3 now that I've discovered a workaround.

Share this post


Link to post
Share on other sites
On 12/20/2018 at 7:17 PM, maxmp said:

Gapless always works - and there was no gapless options for v2 (there was silence removal option - not related to gapless).

v3 has gapless smoothing which radically lowers number of possible clicks in gapless tracks.

There is an issue with very slow storages, like slow sd cards (or highly fragmented, etc.). But also there is a dev build with the new gapless preload option (for slow storages). PM me if you want to test it. Thanks!

Please please please help me. I've been. Using Poweramp for many many years, now with the new update my gapless tracks are nkt working. I think it's because of the slow SD card. What should I do? 

Share this post


Link to post
Share on other sites
28 minutes ago, Roberta said:

Please please please help me. I've been. Using Poweramp for many many years, now with the new update my gapless tracks are nkt working. I think it's because of the slow SD card. What should I do? 

You could test that theory by copying a folder of two of your gapless albums to internal memory and see if they work from there? There is also a pre-load buffer setting in PA which might help.

Andre

Share this post


Link to post
Share on other sites

I solved this problem by disabling "Parse Cue files" in the Poweramp app.  That's where things seem to go wrong.

If I did not have found this 'fix' I would not have bought the app.

Share this post


Link to post
Share on other sites
2 minutes ago, DeadHead2112 said:

Where is the Parse Cue files setting?

Settings > Library > Scanner

Andre

Share this post


Link to post
Share on other sites

@DeadHead2112 your post is quite old, but there were more fixes for gapless tracks in builds 831+, so latest builds will fix those gapless issues for you. 

The fixes are based on tracks sent for testing by users, thanks to that it’s possible to polish it more and more.

(The problem in ideal gapless for formats like mp3 is absence of strict standards for gapless metadata, so tracks in the wild may fail to be processed as gapless tracks by even the most recent/updated decoders. Poweramp adds own workarounds based on those (shared by users for tests) tracks.)

Share this post


Link to post
Share on other sites
2 hours ago, maxmp said:

@DeadHead2112 your post is quite old, but there were more fixes for gapless tracks in builds 831+, so latest builds will fix those gapless issues for you. 

The fixes are based on tracks sent for testing by users, thanks to that it’s possible to polish it more and more.

(The problem in ideal gapless for formats like mp3 is absence of strict standards for gapless metadata, so tracks in the wild may fail to be processed as gapless tracks by even the most recent/updated decoders. Poweramp adds own workarounds based on those (shared by users for tests) tracks.)

I just wanted to extend a sincere thank you. Prior to posting my question about the Cue Parse setting (a user recommended I adjust this setting to overcome gapless playback issues), I went to the Google Play Store to download what I thought was the most recent version of Poweramp, just to see if the Gap issue I was having was fixed. The latest version they had was 831, so I didn't realize there were versions up to 836 (my issue still occurs in 831).  Anyway I've just downloaded 836 and my problem went away!  Repeat - problem resolved!! 

I had been working around it by doing the minimal amount of crossfading that you can configure between tracks (along with preloading tracks the maximum amount). This masked the problem a little bit, but it was still apparent (albeit much less obtrusive).  I listen to a lot of live Grateful Dead, wherein there are always a lot of contiguous musical pieces broken up into several different tracks. This makes the Gapless playback feature more important for me than probably most others.  I also listen to music about 12 hours a day, so I can't overstate how pleased I was to see your suggestion in my email. 

I stuck with Poweramp since the release of V3, because even with my clunky workaround, it is by far the best player available. I will continue to sing its praises on the various blogs and message boards that I frequent. Thanks again for fixing this. Again, my Gapless is working :D  Maxamp is the best!  Poweramp rules the airwaves.....

Andrewilley - thank you as well. You are always quick to respond with a suggestion.

Share this post


Link to post
Share on other sites

I just upgraded to v3 from v2 to see if the gapless issue was corrected.  I have build 838 and am still getting the slight gap between songs.  I have tried DeadHead's workarounds (disabling Cur Parse, Preloading tracks with maximum amount, Crossfade with minimal amount) and that helps somewhat.  DeadHead, would you be able to pass along any other tips for me to completely eliminate the gapless issue?  The majority of my files are WMA files.  Thanks!

Share this post


Link to post
Share on other sites

I believe that V3 always supports gapless. I've had problems with some of my older rips that I used the Fraunhofer encoder, there's a slight gap on music that's supposed to be gapless and play gapless perfectly on my PC based music system (Logitech Music System). As I find them I rerip the CD using my now DBPoweramp which uses the LAME MP3 encoder and they play gapless perfectly on Poweramp. I think that the problem was the encoder and not Poweramp since they work fine after reripping.

Share this post


Link to post
Share on other sites

@Kingog if you can reproduce the issue on pair of tracks - please share them (preferable via Poweramp itself - in list select tracks / Send / Gmail / gpmaxmpz@gmail.com) for testing. Thanks!

Share this post


Link to post
Share on other sites
4 hours ago, Kingog said:

I just upgraded to v3 from v2 to see if the gapless issue was corrected.  I have build 838 and am still getting the slight gap between songs.  I have tried DeadHead's workarounds (disabling Cur Parse, Preloading tracks with maximum amount, Crossfade with minimal amount) and that helps somewhat.  DeadHead, would you be able to pass along any other tips for me to completely eliminate the gapless issue?  The majority of my files are WMA files.  Thanks!

Hi Kingog,

I received a very generous proactive response from Max himself, a while after my initial report of the issue, indicating that the more recent builds have gapless fixes implemented in them.  I simply upgraded from V3 build 815 to V3 build 836, and the problem disappeared completely.  I say "generous" because he took the time to revisit my old issue and reach out to me. 

Keep in mind, however, I experienced the issue using mp3s ripped at 320 kbps, not WMA.  Also keep in mind, I never experienced the issue on any V3 build when I used WAV files. The moral of the story is file format counts!

I also received a notification while writing this that Max replied to you a moment ago, so maybe he has something for you!  Max is the best. Poweramp is the best. 

DeadHead2112

Share this post


Link to post
Share on other sites

Thank you very much for your thoughtful replies!  Max, I just sent you a couple of files via gmail.

Fingers crossed!  I would agree with DeadHead that Poweramp is an amazing app and that Max has done a fabulous job with it!

Share this post


Link to post
Share on other sites

@Kingog thanks for the files. Based on these I’ve just added support for gapless wma tracks to the next build. 

Share this post


Link to post
Share on other sites

That is fabulous news, Max!  Thank you so much for such incredible customer service!  Can't wait for the new build!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...