Jump to content
Poweramp
maxmp

Poweramp Build 814

Recommended Posts

Has the "Play Filtered" function when playing from the search tab been removed from v3 ?

In v2 I could search for every song with a certain keyword in the search tab and when I first chose a song it asked me if I wanted to "play all" or "play filtered" (play only through the songs that were found using the search function). I can't seem to find this feature in v3 as it just plays through all my songs and not only the ones that I searched for, even if I choose the "Shuffle songs" (not shuffle all) mode.

So for example if I search for "cat" in the search tab, I would want to be able to play through all the songs that have the word "cat" in them, directly from the search tab and without first needing to put them in my queue (something that was possible in v2).

Thanks a lot for your help !

Share this post


Link to post
Share on other sites

v2 hidden "filtered" queue transformed to actually visible Queue with the search results.

You can search and immediately play / shuffle results from that Search page (via in-header play / shuffle button - shuffle may be disabled if you have Ignore shuffle option disabled in settings / Library / Queue).

Share this post


Link to post
Share on other sites
2 hours ago, blaubär said:

Is this skinnable ? If yes Is there a skin that combines non-alternative-layout with transparent or semi-transparent background for display of artist and album ?

Edit: Okay, it is skinnable, "Dark default skin" by "Ultimate Designs" with the following settings does the trick :

"Alternative Layout" = disabled

"(Transparency) Buttons and labels on play screen" = "Semi transparent"

"App Background" = "Blur (default)"

1118201892524.jpg

1118201892853.jpg

Thanks for the hint. 👍

@maxmp should had them to the default theme since it seems no-one likes those black boxes.

Those semi transparent buttons are far better.

Share this post


Link to post
Share on other sites

Thanks a lot for your answer !

It is indeed as you say, thanks for the clarification. But this sparks another question :

When I do it like you say (by using the in-header play button), with an artist with approx. 60 songs spread across multiple albums, my visible queue actually bumps up to like 270 songs in-queue instead of the expected 60.

Maybe it's because it adds every song for every occurrence (once for each album + once for each individual song appearing in the search results).

So: Is there a way to automatically not add any duplicates in my visible queue when using the play function ?

Thank you !

Share this post


Link to post
Share on other sites

@Madikan thanks for the request, there is a similar Don't add duplicates option, but it's for playlists. I think I can extend it to Queue as well, or even make it always enabled for search results. At the meantime, I recommend just limiting scope of search (search header menu / List options, e.g. for just songs) to avoid duplications.

Share this post


Link to post
Share on other sites
12 hours ago, TheDoc said:

The 'seek' bar is just * awful. Not that the rest of it is much better, but I could maybe deal with the rest of it if not for that.

What music player ya'll moving to now?

PA of cause, plenty of options for seek bar in skins.

Share this post


Link to post
Share on other sites
2 hours ago, pauldamo said:

PA of cause, plenty of options for seek bar in skins.

Exactly, should you prefer a simple layout then you could use the "Dark default skin" :

11182018123534.jpg

11182018123544.jpg

Share this post


Link to post
Share on other sites

@maxmp, is it possible in future realise preview or something else for skins ?

Now every change on options of skin we need press back 4 times and trying not forget WHAT you have change last time.

With preview - changing options in skins will be more usefull

Share this post


Link to post
Share on other sites

Here's a screenshot of the big with the song not playing. The timer stays at zero but the progress bar moves along for a few seconds before resetting and repeating the movement.  Hitting pause then play fixes it.

Screenshot_20181218-103031.png

Share this post


Link to post
Share on other sites
1 hour ago, dumahim said:

The timer stays at zero but the progress bar moves along for a few seconds before resetting and repeating the movement

I sometimes get this when the last song of an album has finished. It doesn't stop but shows a behaviour like the one you describe.

Share this post


Link to post
Share on other sites
On 12/13/2018 at 10:33 AM, MotleyG said:

I am using the latest 813 build on a stock LG G6. Everything seems to be running pretty smooth now, and this has become my daily driver for music. Thanks for the efforts in building and evolving this amazing player!

One item that seems to not follow. I have the option enabled for list click actions to play and go to the main UI, and it works when selecting specific items from within the list. However if using the shuffle or play buttons at the top of the list in the header area, the list UI remains even though the action is executed.

Is this the expectation? I would prefer if it would follow the list click action, and in this case move to the main now playing UI same as after clicking on list items.

GB

Hi Max, not sure if this was noted from the previous post. Are you able to consider if this is something you can update to the 815 version?

Share this post


Link to post
Share on other sites
6 hours ago, 7OH said:

@maxmp, is it possible in future realise preview or something else for skins ?

Now every change on options of skin we need press back 4 times and trying not forget WHAT you have change last time.

With preview - changing options in skins will be more usefull

If you click the "X" on the right side rather than using the back arrow on the left side of the top bar it will take you directly back to the screen you went to settings from.

Share this post


Link to post
Share on other sites

Nice update. But I hear small popping noises when I play my music through bluetooth in my car now. Also the sound plays at a higher pitch tone now. It's not bad but I did notice a change in sound.

Share this post


Link to post
Share on other sites
1 hour ago, w3wilkes said:

If you click the "X" on the right side rather than using the back arrow on the left side of the top bar it will take you directly back to the screen you went to settings from. 

But then i need to go settings again - search needed skin and search what option was changed last time.

It must be viewed realtime (or maybe add ability to add 2 pics to each option to show difference).

Share this post


Link to post
Share on other sites

I have posted a while back because my Hi Res audio is not working on the S9+ One UI Beta

A member of the forum told me kindly that he thought the problem was Samsung's UHQ wasn't implemented yet. After an update to the beta I noticed that UHQ has been implemented yet Hi Res audio still isn't working.

I don't have the option of AUX/Wired Hi Res audio. 

Here are some screenshots as well as my audio_policy and audio_effects and audio_conf

I could not extract Build.prop as I have not rooted my phone

Hope you'll be able to help me out

audio_effects (1).conf

audio_effects.conf

audio_effects.xml

audio_effects_sec.xml

audio_effects_common.conf

audio_policy_configuration_sec.xml

audio_policy_configuration.xml

Screenshot_20181218-203141_SoundAlive.jpg

Screenshot_20181218-203204_Poweramp.jpg

Share this post


Link to post
Share on other sites

I managed to install Poweramp v3 on mu Asus ZenFone 2 (yaaaaay!) and the app works pretty fine now, though it kept crashing when I first opened it. It stopped crashing and started working as it should only when I changed the list of folders to be scanned.

Polish translation is pretty bad in some places, by the way. I mean, messages like "tu nie ma nic dla mnie" (shown when there's no music files in a folder) look like very un-professional translations. Is it possible to correct them? Maybe you could send Polish translation to someone (maybe to me) to correct them?

Share this post


Link to post
Share on other sites

 

Hello I have root on my xiaomi, and I have completely disabled the play store and play service, but I do not want to go OT.

why does Poweramp continue to check the license each (I think) 48 hours? is not there a way to fix license or lengthen the time between a check and another?

Share this post


Link to post
Share on other sites

I could use this app normally before, but when I upgrade my Poweramp from build 805 to build 814, it tips that my email address no order for act. I bought this app on March 5th 2017 by Alipay. How to deal with the problem? Hope reply as soon as possible, thanks.😖

Screenshot_20181219-224559.jpg

Share this post


Link to post
Share on other sites
16 hours ago, Mvensjip said:

I have posted a while back because my Hi Res audio is not working on the S9+ One UI Beta

A member of the forum told me kindly that he thought the problem was Samsung's UHQ wasn't implemented yet. After an update to the beta I noticed that UHQ has been implemented yet Hi Res audio still isn't working.

I don't have the option of AUX/Wired Hi Res audio. 

Here are some screenshots as well as my audio_policy and audio_effects and audio_conf

I could not extract Build.prop as I have not rooted my phone

Hope you'll be able to help me out

Thanks for the details - if you're on Pie beta - I can't do anything yet with it as I just don't have Pie on my S9 - beta it's limited for few countries. As soon as Pie hits my S9+ (I have both variants), it will be added.

Hi-Res works OK on S9+ @ Android 8.

PS Also, if you can get build props (you can do it via "adb shell getprop" command if you have adb) - that may help to implement support even earlier. Thanks!

Share this post


Link to post
Share on other sites
51 minutes ago, maxmp said:

Thanks for the details - if you're on Pie beta - I can't do anything yet with it as I just don't have Pie on my S9 - beta it's limited for few countries. As soon as Pie hits my S9+ (I have both variants), it will be added.

Hi-Res works OK on S9+ @ Android 8.

PS Also, if you can get build props (you can do it via "adb shell getprop" command if you have adb) - that may help to implement support even earlier. Thanks!

As of right now you can get the pie beta from XDA forums.

https://forum.xda-developers.com/galaxy-s9/how-to/s9-s9-pie-alpha-beta-sm-g960f-sm-g965f-t3867627

As to build prop I can unfortunately not acces as I don't have ADB either.

Could you please check this Max senpai.

Maybe try flashing the beta yourself and implement hi res already if it's not too much to ask 😁

 

Share this post


Link to post
Share on other sites

Android 9

Google Pixel 1

Poweramp v3-build814-play (Full Version)

 

1. I have a bug where the now playing bar on the bottom will show a different song from the one that is playing. I think closing the app and reopen reproduces sometimes, but I am struggling to consistently reproduce this.

2. Also, is there a way to disable the feature where you hold an artist and it opens up the selection items?

3. Do you a place where I can donate to Poweramp? I really like v3! It's fantastic so far

Share this post


Link to post
Share on other sites
13 hours ago, Darrenjfwalsh1701 said:

the sound seems to be lower on hi Res too, is there a way to fix this

Try disabling DVC ( Direct Volume Control ),

11202018990.jpg

112020189952.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...