Jump to content
Poweramp
maxmp

Poweramp Build 811

Recommended Posts

In version 810, if I pulled the album cover image down, it only showed the albums that were associated with it. Now, all albums will be displayed. How can this be restored?

Share this post


Link to post
Share on other sites

Can we have a way to add or edit the 'Lyrics' tag inside Poweramp? That way we don't have to resort to other apps to add or edit lyrics to our songs.

Bug: When pressing the 'back' button while editing the 'Genre' tag with the expandable menu provided by Poweramp it doesn't close the expandable menu of genres. Instead, pressing the 'back' button with the expandable menu of genres open closes the keyboard and on a second press it closes the Info/Tags window.

Share this post


Link to post
Share on other sites

Improvement on cover art would be nice and definitely artist image.

Share this post


Link to post
Share on other sites
2 hours ago, Laszlo52 said:

In version 810, if I pulled the album cover image down, it only showed the albums that were associated with it. Now, all albums will be displayed. How can this be restored?

Are you sure that you play from the same category as before ? For me it does exactly what is described in the V3 Changelog.

20181205_100633.jpg

Share this post


Link to post
Share on other sites
2 hours ago, blaubär said:

Are you sure that you play from the same category as before ? For me it does exactly what is described in the V3 Changelog.

Same here. Pulling down or tapping on the cover art both do the same thing, which is to go the the songs list that contains the currently playing track. How you see it will depend on the playback mode of course (Folder, Album, Playlist, Queue, etc).

Edit: There does seem to be a bug if you are listening to a Playlist though. When you pull-down, or tap, on the artwork area while listening to a Playlist, PA displays the current track in All Songs mode rather than in the current playlist. Queue and other categories seem fine though.

Andre 

Share this post


Link to post
Share on other sites

Not sure if anyone has brought up this question already (looked through search).

When you have a song in a playlist (.m3u) and move the song to a new directory on the phone, PA removes it from the playlist after the next scan. Is there any way for it to just keep and re-link the file in playlist to the new folder automatically, just like it re-links songs in a playlist when you import a Playlist into PA?

Share this post


Link to post
Share on other sites

I found out the issue of the bluetooth volume problem with it jumping from what I had to max volume. I was enabling and disabling dvc via bluetooth under hi res but that seems to have the issue but if I leave it disabled for the to turn off dvc under bluetooth via hi res, and just go to the global setting of dvc via advanced tweaks instead, then it has no volume jumping issue with playing and pausing via headphones. So basically I have to do the global enable and disable for dvc for all outputs for it to work right. Individual setting does not work for each output or just bluetooth. Just in case for those wondering about it too.

Share this post


Link to post
Share on other sites
3 hours ago, JohnnySapphire said:

When you have a song in a playlist (.m3u) and move the song to a new directory on the phone, PA removes it from the playlist after the next scan. 

As soon as you remove a song (OK copy it, but still removed from its original location) PA considers it deleted and will remove it from the library database (and thus any dependencies, such as playlists). The same title may reappear elsewhere, but PA has already removed the old entries by then.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

As soon as you remove a song (OK copy it, but still removed from its original location) PA considers it deleted and will remove it from the library database (and thus any dependencies, such as playlists). The same title may reappear elsewhere, but PA has already removed the old entries by then.

Thank you. This would explain why it links missing files in playlists to their new location on import, but not when they move AFTER the playlist is already on the device.

Share this post


Link to post
Share on other sites
3 hours ago, JohnnySapphire said:

Thank you. This would explain why it links missing files in playlists to their new location on import, but not when they move AFTER the playlist is already on the device.

I found an easier way to make m3u's for Poweramp and no need to edit them after moving files. I used to create temporary folders and m3u playlists using winamp every time I added music and later I would move things around and I would redo the playlists to reflect the new locations, but I found Poweramp only needs a list of the files, the folders and all that other crap in the m3u don't matter.

For example if you open your m3u playlist in notepad it will probably have a bunch of useless #EXTM3U info and the locations of the files something like this:
../sort/2018rock/Weezer - Zombie Bastards.mp3
../sort/P.O.D.-Circles-2018/P.O.D. - 11 Home.flac

But all you need is to open notepad and save a list of the file names as a .m3u something like:
../Weezer - Zombie Bastards.mp3
../P.O.D. - 11 Home.flac

If you move the files or rename the folders a full rescan or resync of the m3u repairs the playlist for the new file locations. No need to edit the playlists.

The direction of the / \ doesn't seem to matter and my list requires ../ because my playlists are in Music/playlists/ and I need to tell it to jump back out of that folder and start looking for files at Music/

Share this post


Link to post
Share on other sites
16 hours ago, andrewilley said:

Same here. Pulling down or tapping on the cover art both do the same thing, which is to go the the songs list that contains the currently playing track. How you see it will depend on the playback mode of course (Folder, Album, Playlist, Queue, etc).

Edit: There does seem to be a bug if you are listening to a Playlist though. When you pull-down, or tap, on the artwork area while listening to a Playlist, PA displays the current track in All Songs mode rather than in the current playlist. Queue and other categories seem fine though.

Andre 

I mentioned this once before in the 807 thread, but I still have this problem with this build, no matter what the current playback mode is. Whether I play from Most Played, Recently Added, or Recently Played, tapping the cover art always returns to All Songs.

Share this post


Link to post
Share on other sites
5 hours ago, anh.tt said:

Whether I play from Most Played, Recently Added, or Recently Played, tapping the cover art always returns to All Songs.

I think Max mentioned that dynamic lists (such as Recently Played, Top Rated, etc) are handled differently. IMHO though, Playlists ought to behave like normal playback modes such as Folder, Album, Artist, Genre, etc. Especially since the Queue behaves as you would expect when you return to the Library view, and that's one of the most dynamic list types of all.

Andre

Share this post


Link to post
Share on other sites
13 hours ago, Absinthequ said:

I found an easier way to make m3u's for Poweramp and no need to edit them after moving files. I used to create temporary folders and m3u playlists using winamp every time I added music and later I would move things around and I would redo the playlists to reflect the new locations, but I found Poweramp only needs a list of the files, the folders and all that other crap in the m3u don't matter.

For example if you open your m3u playlist in notepad it will probably have a bunch of useless #EXTM3U info and the locations of the files something like this:
../sort/2018rock/Weezer - Zombie Bastards.mp3
../sort/P.O.D.-Circles-2018/P.O.D. - 11 Home.flac

But all you need is to open notepad and save a list of the file names as a .m3u something like:
../Weezer - Zombie Bastards.mp3
../P.O.D. - 11 Home.flac

If you move the files or rename the folders a full rescan or resync of the m3u repairs the playlist for the new file locations. No need to edit the playlists.

The direction of the / \ doesn't seem to matter and my list requires ../ because my playlists are in Music/playlists/ and I need to tell it to jump back out of that folder and start looking for files at Music/

You nailed it. This is why. I always made my playlists like you did above with relative links, thus they auto find/re-link once the playlist is imported.The reason my latest issue removes it is because i added those songs to the playlist inside Poweramp, which is why Poweramp does not relink them. It only relinked the songs i added to the playlists on my computer, not inside PW. Solves the reason behind this. 

Share this post


Link to post
Share on other sites
56 minutes ago, JohnnySapphire said:

You nailed it. This is why. I always made my playlists like you did above with relative links, thus they auto find/re-link once the playlist is imported.The reason my latest issue removes it is because i added those songs to the playlist inside Poweramp, which is why Poweramp does not relink them. It only relinked the songs i added to the playlists on my computer, not inside PW. Solves the reason behind this. 

To add to this, i did some testing this morning. As soon as you add a file to a playlist inside PA, it completely wipes out the relative paths for ALL songs in that playlist. So the only way to keep that format intact is to never add a new songs to the playlist via Poweramp.

 

Before:

../Disturbed - Are You Ready.mp3
../Disturbed - In Another Time.mp3
../Disturbed - The Best Ones Lie.mp3

 

After: (added only Ice Cube song from inside Poweramp)

/storage/4052-26FF/Music/All/Disturbed - Are You Ready.mp3
/storage/4052-26FF/Music/All/Disturbed - In Another Time.mp3
/storage/4052-26FF/Music/All/Disturbed - The Best Ones Lie.mp3
/storage/4052-26FF/Music/All/Ice Cube - Arrest The President.mp3

 

Share this post


Link to post
Share on other sites

That's good to know! I try to stay away from adding anything using Poweramp and now I have a good reason to never do it. 

Share this post


Link to post
Share on other sites
1 hour ago, JohnnySapphire said:

To add to this, i did some testing this morning. As soon as you add a file to a playlist inside PA, it completely wipes out the relative paths for ALL songs in that playlist. So the only way to keep that format intact is to never add a new songs to the playlist via Poweramp.

Yes, but Poweramp never uses full paths to resolve tracks. It uses just last directory and file name, it basically ignores everything else and doesn't take path "relativeness" into account.

Share this post


Link to post
Share on other sites
21 hours ago, ReeceS269 said:

Could we get the option to change artwork for playlists?

+1

Or, option to delete/remove artwork.

Share this post


Link to post
Share on other sites
On 12/5/2018 at 1:20 PM, andrewilley said:

Same here. Pulling down or tapping on the cover art both do the same thing, which is to go the the songs list that contains the currently playing track. How you see it will depend on the playback mode of course (Folder, Album, Playlist, Queue, etc). 

Edit: There does seem to be a bug if you are listening to a Playlist though. When you pull-down, or tap, on the artwork area while listening to a Playlist, PA displays the current track in All Songs mode rather than in the current playlist. Queue and other categories seem fine though.

Andre 

Seems - logic asks to get back to swipe up\down for change category\list\folder as in v2 )

Share this post


Link to post
Share on other sites

@maxmp collected some logs additionally.

 

2018-12-06 21:32:39.052 2744-14902/system_process I/ActivityManager: Start proc 27823:com.maxmpz.audioplayer/u0a81 for activity com.maxmpz.audioplayer/.StartupActivity
2018-12-06 21:32:39.103 27823-27832/? E/art: Failed sending reply to debugger: Broken pipe
2018-12-06 21:32:39.103 27823-27832/? I/art: Debugger is no longer active
2018-12-06 21:32:39.103 27823-27832/? I/art: Waiting for a blocking GC Instrumentation
2018-12-06 21:32:39.107 27823-27832/? I/art: Starting a blocking GC Instrumentation
2018-12-06 21:32:39.216 27823-27823/? W/audioplayer.Application: Poweramp edition: arm-play
2018-12-06 21:32:39.233 27823-27840/? D/libEGL: loaded /system/lib/egl/libEGL_mali.so
2018-12-06 21:32:39.255 27823-27823/? W/Platform: man=samsung pro=lt01wifiue mod=SM-T310 dev=lt01wifi type=user board=smdk4x12 rel=7.1.2 osVersion=3.0.31-kerNoleCM14.1+ max memory=192
2018-12-06 21:32:39.259 27823-27823/? W/Platform: tab=true screenSize=3 isLong=false dpi=213 density=1.3312501 swdp=600 w/h=1280x800 w/h dp=961x576
    {1.0 ?mcc?mnc [ru_RU] ldltr sw600dp w961dp h576dp 213dpi lrg land finger -keyb/v/h -nav/h s.15}

 

 

Share this post


Link to post
Share on other sites
36 minutes ago, egorlins said:

@maxmp collected some logs additionally.

 

2018-12-06 21:32:39.052 2744-14902/system_process I/ActivityManager: Start proc 27823:com.maxmpz.audioplayer/u0a81 for activity com.maxmpz.audioplayer/.StartupActivity
2018-12-06 21:32:39.103 27823-27832/? E/art: Failed sending reply to debugger: Broken pipe
2018-12-06 21:32:39.103 27823-27832/? I/art: Debugger is no longer active
2018-12-06 21:32:39.103 27823-27832/? I/art: Waiting for a blocking GC Instrumentation
2018-12-06 21:32:39.107 27823-27832/? I/art: Starting a blocking GC Instrumentation
2018-12-06 21:32:39.216 27823-27823/? W/audioplayer.Application: Poweramp edition: arm-play
2018-12-06 21:32:39.233 27823-27840/? D/libEGL: loaded /system/lib/egl/libEGL_mali.so
2018-12-06 21:32:39.255 27823-27823/? W/Platform: man=samsung pro=lt01wifiue mod=SM-T310 dev=lt01wifi type=user board=smdk4x12 rel=7.1.2 osVersion=3.0.31-kerNoleCM14.1+ max memory=192
2018-12-06 21:32:39.259 27823-27823/? W/Platform: tab=true screenSize=3 isLong=false dpi=213 density=1.3312501 swdp=600 w/h=1280x800 w/h dp=961x576
    {1.0 ?mcc?mnc [ru_RU] ldltr sw600dp w961dp h576dp 213dpi lrg land finger -keyb/v/h -nav/h s.15}

 

here is black screen. and after tappig on screen can be seen this exception

 

repro 100%
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×