Jump to content
Sign in to follow this  
zaq1wsx

Replay Gain tags not working?

Recommended Posts

Which replay gain tags does Poweramp look at?

I recently discovered I was doing something wrong with MP3Gain. I used to do analysis + gain, thinking that analysis was just to come up with the numbers and applying gain would write the tags, but know I know that analysis does write the tags and that  applying gain actually modifies the files (which I don't want).

So in order to test that, i picked the same song and produced 4 versions: 1. a raw one, 2. one with only the tags, 3. one with the gain change without the tags, 4. and one with gain change and tags. I expected that both 1 and 2, and 3 and 4 would sound the same with RG off (with the latter two being quieter) and that  with RG on 1 would be the loudest, 4 the quietest, and 2 and 3 sounding the same in the middle.

When I tested them on my PC with MusicBee everything worked out nicely (tho it seems it does some counter gain as 3 and 4 sounded the same with RG on). However when I tried it on Poweramp, it sounds the same as if RG was off. I tried both Album and Track gains, and both Apply Gain and Apply Gain/prevent clipping, as well as re-scanning after changing to Apply gain.

In the case of MP3Gain it writes 4 APEv2 tags, REPLAYGAIN_ALBUM_GAIN, REPLAYGAIN_ALBUM_PEAK, REPLAYGAIN_TRACK_GAIN, REPLAYGAIN_TRACK_PEAK. I'm wondering if these are the tags Poweramp looks at or not, that may be the cause of it not working?

Share this post


Link to post
Share on other sites

RG does indeed work for all the test files I have. Please PM me the files you think should support RG, but don't work for you in PA. (You mentioned apev2 tags, but these are not primary tags for mp3 and if id3v2 exists, ape tags won't be read).

Share this post


Link to post
Share on other sites
13 minutes ago, maxmp said:

RG does indeed work for all the test files I have. Please PM me the files you think should support RG, but don't work for you in PA. (You mentioned apev2 tags, but these are not primary tags for mp3 and if id3v2 exists, ape tags won't be read).

Same thing happens to me with Opus with correct tags from dBpoweramp, should I PM you the files as well? 

Share this post


Link to post
Share on other sites
32 minutes ago, maxmp said:

RG does indeed work for all the test files I have. Please PM me the files you think should support RG, but don't work for you in PA. (You mentioned apev2 tags, but these are not primary tags for mp3 and if id3v2 exists, ape tags won't be read).

Ok this seems to be the problem then. I copied the tags to ID3 and it worked. All my info (track, album and artist name for example) are in the ID3v2 tags, except for the replay gain info, so since PA found the ID3v2 tags it stopped looking and the APEv2 tags were not read.

Thanks for the quick answer!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...