Jump to content
Poweramp
Yttersta

(814) Car bluetooth reports incorrect track numbers

Recommended Posts

Hello!

 

Devices tested: Huawei P9, Mate 9, and HTC 10

Folder structure used, album track count and track information are correct in track metadata and/or cue sheets.

 

Test Example: An album of (let's say) 10 songs. When the first track is being played, Poweramp reports 2/10. When the penultimate (9th) track is being played, Poweramp reports 10/10. When the last track (actual 10th) is being played it fails to display track counter in car display and simply shows "Track: " instead of "Track: 10/10"

 

Track numbers in my car did not work at all until v3 release in any of the devices aforementioned. I have realised the issue at beta 797, and it has been persistent since.

 

Edit: Photos added

IMG_20181023_160732.jpg

Screenshot_20181023-160716.jpg

Screenshot_20181027-112857.jpg

Share this post


Link to post
Share on other sites
On 10/22/2018 at 9:24 AM, Yttersta said:

 

Test Example: An album of (let's say) 10 songs. When the first track is being played, Poweramp reports 2/10. When the penultimate (9th) track is being played, Poweramp reports 10/10. When the last track (actual 10th) is being played it fails to display track counter in car display and simply shows "Track: " instead of "Track: 10/10"

 

Hmm Never noticed before recently but I see the same thing. I have a Kenwood head unit in one car that only shows track run-time but I've just acquired a 2nd car with a modern (3 year old) head unit (well, I say modern, but the OS is a re-worked android 4.x!). Now this  shows all the correct song title/artist/album but, like yours, shows the incorrect track number. Not sure if it's a BT bug or generic PA bug. But not got around to testing other players yet.

Share this post


Link to post
Share on other sites

Apparently on some days it gets worse. Also the bug still persists at version 805. As @dvhttn said also I have tried this in two other cars (specifically a Seat Leon 2017 and a 3 series F30 BMW) and both have the issue so it is not specific to my phone and/or car.

 

IMG_20181108_082719.thumb.jpg.d98a56cf3df9737e614d6b2f429c79bd.jpgIMG_20181108_082657.thumb.jpg.3f3a02b1b21a48c19926c9414d36d141.jpg

Share this post


Link to post
Share on other sites

With mine, I have 8000+ songs on my phone which I always have on 'shuffle all songs'. The numbers say things like '3/8000' and increment by 1 for each song. Not checked to see if the numbering persists over a reboot or anything like that though as, for me anyway, I'm not usually that interested in which track number it is.

Share this post


Link to post
Share on other sites

Still no fix at version 814, I'm updating the OP accordingly. I have tested this to be a persistent bug in nearly every car I have been to and with all phones I have at hand that are at or above Android 6.

 

At least an admission of the bug actually existing and is under work would be most welcome at this point.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...