Jump to content
Poweramp
maxmp

Poweramp Build 807 (Release Candidate)

Recommended Posts

On 10/19/2018 at 5:17 PM, maxmp said:

Poweramp-v3-build-801-uni.apk
https://play.google.com/apps/testing/com.maxmpz.audioplayer

Build 801:
• fixed crash due to the translation bug in Spanish
• fixed notification colorize issue for some devices

Build 800:
• website purchase doesn't require Google services anymore
• bug fixes

Xiaomi Redmi Note 4 Global

Screenshot_2018-10-21-12-22-31-749_com-compressed.jpg

Share this post


Link to post
Share on other sites
3 hours ago, 66muramasa said:

Poweramp 801 STILL stops after the end of each track.  Reverted to 797, again.

It might have to do with updating instead of doing a clean install. If you downgrade to 797 you're forced to remove Poweramp and do a clean install. Try doing the same with 801. It fixed it for me.

Share this post


Link to post
Share on other sites

Facing issues in rescanning library, the  rescan option from the 3dot button does not work. Need to go to settings and rescan library from there. Already tried fresh install. 

Share this post


Link to post
Share on other sites

Alas, no progress on gapless, still noticeable on my phone, whereas V2 was perfect. And GMMP, alpha3, is also perfect.

What had changed in the engine between versions that had made things worse?

Share this post


Link to post
Share on other sites

@eserim v3 has lower default buffer sizes. If you have slow storage it can be a problem for some gapless files (system is not able to provide data in 500ms-1s - that's quite slow). Try to increase Audio buffer for the outputs you use.

Share this post


Link to post
Share on other sites

@blaubärCan you please be more specific:

- what is the Audio Output used in PA when stop happened?
- what is the actual device used (wired / speaker / BT / something else)?
- what was the format of file stopped
- do you use some crossfade options?

Thanks!

Share this post


Link to post
Share on other sites
22 hours ago, Mr. Make Believe said:

It might have to do with updating instead of doing a clean install. If you downgrade to 797 you're forced to remove Poweramp and do a clean install. Try doing the same with 801. It fixed it for me.

Okay, I'll try that.  Thanks.

EDIT:. It's no good.  Back to 797.

Share this post


Link to post
Share on other sites
3 hours ago, maxmp said:

@blaubärCan you please be more specific:

- what is the Audio Output used in PA when stop happened?
- what is the actual device used (wired / speaker / BT / something else)?
- what was the format of file stopped
- do you use some crossfade options?

Thanks!

Max, maybe I can be of some assistance on this issue as I'm suffering from the same thing on multiple devices with this same past three to four versions or Poweramp. 

It currently is randomly stopping after songs with high res output as well as both other options for output on Bluetooth and wired both. 

I haven't tested this issue with just speakerphone as of yet but the same issue happens with both Bluetooth and wired. 

The format doesn't appear to make a difference of the songs used (its happening the same between flac, mp3, and wav all the same from testing). 

Crossfade is currently entirely default on my device, none of these settings are touched so they remain completely default. 

Edit: Mine is currently doing this on the LG v20/LG v35 thinq/and now the LG v40 thinq

Share this post


Link to post
Share on other sites

@Ps3hacker Does it reproduce for non hi-res output? Your device is complicated - I won't be able to reproduce your setup.

Can you check logcat when such stop happens - does it contain anything related to "audiotrack died"?

Share this post


Link to post
Share on other sites
26 minutes ago, maxmp said:

Poweramp-v3-build-802-uni.apk
https://play.google.com/apps/testing/com.maxmpz.audioplayer

Build 802:
• support for MusicFX on MIUI
• visualization state is saved more frequently
• folders hierarchy shuffle improvements
• hardware menu button expands navbar
• fixed widget color selection on smaller screens

I just did a fresh reinstall about 30 mins ago.   now just got the update.   do i need to uninstall and reinstall again?  Funny thing was when i reinstalled the settings didn't get cleared out like it used to with the older versions.   

Share this post


Link to post
Share on other sites
58 minutes ago, maxmp said:

Poweramp-v3-build-802-uni.apk
https://play.google.com/apps/testing/com.maxmpz.audioplayer

Build 802:
• support for MusicFX on MIUI
• visualization state is saved more frequently
• folders hierarchy shuffle improvements
• hardware menu button expands navbar
• fixed widget color selection on smaller screens

Wow,thanks

Share this post


Link to post
Share on other sites

Dear @maxmp

I am Poweramp user since version 2 from past 6 years. Great music player and fabulous work by you. 

I have 2 licenses, one I use on my Android TV box running on Android 7.1.2. 

Mouse scroll support was very much there upto alpha versions, since Poweramp has entered beta and close to final release I humbly request you to bring back the most wanted feature back. It is cumbersome to drag mouse through the library list when the folder contain large number of files. 

Scrolling using mouse is supported elsewhere in the app (menus and settings) 

I have requested this several times in this forum but my concern has never been addressed. 

Thanks in advance, 

Share this post


Link to post
Share on other sites
5 hours ago, maxmp said:

@blaubärCan you please be more specific:

- what is the Audio Output used in PA when stop happened?
- what is the actual device used (wired / speaker / BT / something else)?
- what was the format of file stopped
- do you use some crossfade options?

Thanks!

- what is the Audio Output used in PA when stop happened?

OpenSL ES Hi-Res Output / Wired Headset/AUX / Active (24-bit 192khz)


- what is the actual device used (wired / speaker / BT / something else)?

wired Headphones


- what was the format of file stopped

mp3, Variable Bit Rate, encoded with lame V0, 251 kbps, Duration 544 sec, 16727 kB, Stereo, Gapless, 44100 Hz, Album art jpg size 8kB in Tags included; file is appended in yesterday's posting (dexter gordon, you can depend on me)


- do you use some crossfade Options?

Should be Default : Auto-Advance Fading : No Fading, Manual Track Cange Fading : Short Crossfade, Fade Play : On, Fade on Seek : off, Crossfade length : 5000ms, Short Manual : 400ms, Play/pause : 400 MS, seek : 100ms

My Device : Samsung Galaxy S7 SM-G930F, Android 8.0.0

I just retried on 802 : was reproducible. Then I started via seekbar from 30 sec before end, also reproducible

 

Share this post


Link to post
Share on other sites

I have the same issue. It stops during the track. Doesn't matter format and bitrate. It can't read anything from library. I'm using Fiio X7 II. 

Share this post


Link to post
Share on other sites
7 hours ago, maxmp said:

@eserim v3 has lower default buffer sizes. If you have slow storage it can be a problem for some gapless files (system is not able to provide data in 500ms-1s - that's quite slow). Try to increase Audio buffer for the outputs you use.

Sorry, tried that straight away - makes a very small difference, but stll not as good as v2 - which was perfect.

Share this post


Link to post
Share on other sites
16 hours ago, superluig164 said:

I think just showing the settings/changelog/help menu anytime the button is pressed is the best option.

No, the three-lines button is basically redundant apart from the Settings item. The hardware Menu button should bring up the context menu for the current screen (i.e. same as the three-dots icon) which contains things you might regularly use (such as Delete track, Add to Playlist, Info, etc). Only if there is no three-dots icon on the current screen should it bring up the three-lines menu content.

 

On a slight tangent, I honestly don't see the point of the extra confusion and wasted space of having two menu options anyway, apart from Google's patently stuff-and-nonsense about one being an 'overflow list' instead of a menu - as clearly the three-dots icon in PA is not an overflow list at all, but is a regular menu.

There is so little content within the three-lines icon that it would make much more sense to get rid of it completely and just put the 'Settings' item at the bottom of every three-dots menu (like it used to be in v2) which could then be tidily and more logically located at the bottom/right (i.e. replacing the removed three-lines icon). 'Changelog' is already present in Settings > About anyway so isn't needed at all, and Help could easily be added to the Settings screen too, just above 'Get Support'.

That way the menu feature would always be in the same place on every screen rather than bouncing around screen-by-screen - or indeed sliding away completely and becoming inaccessible when you scroll down within category views. One unified menu icon would be so much more consistent and simpler and easier to use, I honestly can't see any downside to this approach at all.

Andre

Share this post


Link to post
Share on other sites

Have the letters of the title and album labels been changed to be complete? Since they did not move before and they were incomplete when they were long names.

Share this post


Link to post
Share on other sites
13 hours ago, maxmp said:

@eserim v3 has lower default buffer sizes. If you have slow storage it can be a problem for some gapless files (system is not able to provide data in 500ms-1s - that's quite slow). Try to increase Audio buffer for the outputs you use.

Ah - using 802 with maximum buffer and 2 buffers, seems to be OK - Cheers

 

In fact - as someone else pointed out - first play small gap - second play OK - I thought this may just be reading from a cache - I restarted and cleared cache and all is still OK

OK - I know nothing how things work on this app , but is it possible PA is only reading the gapless tag into the library when it first plays a file?  So a gap on first play, then gapless on subsequent?

Share this post


Link to post
Share on other sites
On 10/22/2018 at 3:01 AM, JoseLoma said:

Have the letters of the title and album labels been changed to be complete? Since they did not move before and they were incomplete when they were long names.

No, they don't scroll in build 802.

Share this post


Link to post
Share on other sites
On 21/10/2018 at 0:24, MeGustaPowerAmp said:

Mmm, entonces ?‍♂️

La verdad que no lo sé lo llevo todo de serie osea que no tengo ninguna custom rom ni nada por estilo. La opción de colorear la notificación si la tengo activada.

P.D con el bulid 801 ese error se fue muchas gracias por tu trabajo @maxmp 

 

Share this post


Link to post
Share on other sites

Poweramp with new design doesn't have a play option on long press, when the default tap action is set to enqueue leaving me with no way to Play the song other then to enqueue it then go to the queue and play it. This used to be there in the classic Poweramp. Please correct this. 

Screenshot_20181022-160551.png

Screenshot_20181022-160613_1.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Quez said:

Poweramp with new design doesn't have a play option on long press, when the default tap action is set to enqueue leaving me with no way to Play the song other then to enqueue it then go to the queue and play it. This used to be there in the classic Poweramp. Please correct this. 

Right, long press now opens selection menu. I will think about something else for this use case.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...