Jump to content
Poweramp
maxmp

Poweramp Build 799 (Release Candidate)

Recommended Posts

5 minutes ago, Panda Patético said:

Hope everything gets fixed in this build btw what's mean by Rc build

Release Candidate. ?

Share this post


Link to post
Share on other sites
19 minutes ago, Panda Patético said:

Hope everything gets fixed in this build btw what's mean by Rc build

It's in the thread title...

From Wikipedia: 

Quote

A release candidate (RC), also known as "going silver", is a beta version with potential to be a final product, which is ready to release unless significant bugs emerge. In this stage of product stabilization, all product features have been designed, coded and tested through one or more beta cycles with no known showstopper-class bugs. A release is called code complete when the development team agrees that no entirely new source code will be added to this release. There could still be source code changes to fix defects, changes to documentation and data files, and peripheral code for test cases or utilities. Beta testers, if privately selected, will often be credited for using the release candidate as though it were a finished product. Beta testing is conducted in a client's or customer's location and to test the software from a user's perspective.

 

Share this post


Link to post
Share on other sites
1 hour ago, hypomaniac-eric said:

day one already still have problems.   Earlier i got in the car, phone connected to bluetooth started playing last song it was on.   15 secs later it changes from the middle of the song to the first song on the playlist.   

another bug:  answered the phone hung up and then the music didn't come back on.   had to it the play button on the bluetooth controller but the volume was real low.  pulled in the driveway and dug my phone out of the holster and turned the volume up and as soon as i hit the volume button it resumed the volume up all the way where it was supposed to be.  

an update.   i turned the bluetooth speaker on and got in the shower.   15 seconds later it started back at the beginning of the playlist again.   so i got out of the shower and tried skipping to another song since it's on shuffle songs.   and it was going in order.   i turned shuffle off and back on and then it started working again.    I wish i could take the app out of my phone and throw it at the wall.   How many more updates do we need to get rid of these bugs.   so far i hadn't had and bugs fixed yet that I"m having problems with.   that I"m aware of.  

Share this post


Link to post
Share on other sites

Thanks for the update @maxmp!

It's looking good so far but I've found one issue with Album Artists list. It seems like Poweramp marks any file without Album Artists tag as a track with unknown album and it carries that information to the main player screen (only that part, somewhere else shows the correct Artist). I know it can be fixed by filling the missing Album Artists tag but I hope it can fall back to Artists tag when Album Artists are empty/unavailable. Join Albums option inside Settings > Library > Lists does not do anything with this issue. 

These are the screenshots of the behavior I just stated above

In Artist > Albums list: https://i.imgur.com/FkbsAaM.png

Main screen when played from Artist >  Albums list: https://i.imgur.com/2YcIYCg.png

In Album Artists > Artists > Unknown Artist list: http:// https://i.imgur.com/QKnd1Kn.png

Main screen when played from Album Artists > Artists > Unknown Artist list: https://i.imgur.com/Va3Ag0m.png

Share this post


Link to post
Share on other sites

Skin-related discussions moved to a new separate subforum, as I think these will get more prevalent as PA moves towards an official v3 release.

Andre

Share this post


Link to post
Share on other sites
8 hours ago, hypomaniac-eric said:

day one already still have problems.   Earlier i got in the car, phone connected to bluetooth started playing last song it was on.   15 secs later it changes from the middle of the song to the first song on the playlist.   

another bug:  answered the phone hung up and then the music didn't come back on.   had to it the play button on the bluetooth controller but the volume was real low.  pulled in the driveway and dug my phone out of the holster and turned the volume up and as soon as i hit the volume button it resumed the volume up all the way where it was supposed to be.  

 No problems with my head unit via BT. But be aware of 2 issues. 1) the problems you're seeing could be problems with the head unit firmware. I used several music players/phones to narrow down a problem and it pointed at PA. However, a firmweare upgrade to my cars head unit fixed that issue. 2) I have my phone (PAs volume settings) set to max. volume output and then alter the volume in the car with the head unit. However, recent android versions have an additional BT setting that tend sto f$$$ this up. Go into Settings > Connections > Bluetooth and hit the 3-dot menu. You want to look at 'media volume sync' and 'phone ringtone sync'. I just turn them 'off'.

If you're aware of these and it doesn' alter what you're seeing, my apologies, but I'm setup this way and don't have the problems you're seeing.

Share this post


Link to post
Share on other sites

I like this kind of half-transparent background. I think it's better to have a few default options in the background settings section of the program.

Screenshot_2018-10-06-12-27-27.png

Screenshot_2018-10-06-12-27-17.png

Share this post


Link to post
Share on other sites
On 10/5/2018 at 3:31 AM, maxmp said:

Poweramp-rc-build-799-uni.apk

https://play.google.com/apps/testing/com.maxmpz.audioplayer

RC Build 799:
• 799: fixed Stop
• 799: swapped Artist <-> Album labels
• 799: fixed crash due to bad zoom (Android 9.0)
• 799: Album Art downloading logic update
• rating is shown in almost all categories (not shown in Queue, Most Played)
• long press on miniplayer brings current category / track • lists follow current playing track
• improved seek for mp3 files with large embed cover. You may need to do a full rescan for the waveseek to update
• Genres are not split on single / anymore (split on ; and //). You may need to do a full rescan for this to apply
• added Look and Feel / Notifications / (Always) Keep Notification options
• added Album Art / Send High Resolution Album Art. When enabled, high resolution images are sent to Android lock screen, widgets, Media Session API
• added sort by last played time
• added help hints
• Poweramp will try to return to the next track from Queue
• Poweramp API improvements
• fixed Send menu item not always visible on some devices
• fixed issue with pause/resume cycles and track not auto-advancing
• fixed notification pause/resume button state on some devices
• fixed scrobbling via Simple Last.FM Scrobbler
• fixed miniplayer de-sync after some rescans
• fixed crash with Lock Screen / Show Default Image enabled
• few other bug fixes and small improvements
 

Hi Max,

Im trying to open MusicFX by pressing and holding the button but it's taking me anywhere.

I started a discussion about please review it.

Hopefully it's not an issue on my end..

Regards,

Share this post


Link to post
Share on other sites

Hi Max,

 

Thanks for the update (I'm on 799). It was fine on Android 8.1.

 

Today, I've updated my OnePlus 6 to Android 9. Unfortunately, it started making distorted sounds when I increase / decrease volume, or just a notification came up and making sounds. Same with OpenSL ES and AudioTrack output on speaker. On wired headset, Hi-Res output stopped working, and it does the same with OpenSL ES output... 

This doesn't happen, when I'm not using Poweramp, and it is fine with YouTube.

Please fix this ASAP! I can send you a short video in private if you want.

 

Thank you very much

Share this post


Link to post
Share on other sites

I'm still sometimes getting the issues with tracks not auto-advancing. RC build 799.

Android 6.0.1 

Samsung Galaxy C9 Pro 

Share this post


Link to post
Share on other sites

ReplayGain still isn't working on Opus files that work fine on PCs (VLC, foobar2000).

Are you aware of this problem, and if you are then are you planning to fix this before the "stable" v3 releases?

Share this post


Link to post
Share on other sites
On 10/5/2018 at 8:44 AM, karry said:

Noticed that too, looks like it lost one level of sorting at parent folder level.

When I renamed one folder it goes on top, instead of being sorted alphabetically like in the previous release. I didn't change folder settings before the upgrade.

I tried removing then rescanning my music folders to see what would happen. The folder hierarchy now seems to be dictated by chronology, going downwards from oldest to newest, although if you add a new folder, as you say, it goes to the top. 

I'll be staying with build 797 for the moment, as at least the stopping after 2 or 3 songs problem can be overcome by using the Advance List option.

Android 6.0 - Cubot Max

Share this post


Link to post
Share on other sites

Is there a bug where the size of the playlist can't exceed certain number of tracks?? 1214 is what I noticed no matter how many I add, i don't know if the actual number is that or the number just freezes beyond the 1214 mark. It shows up fine in other music players though.

Share this post


Link to post
Share on other sites

@maxmp remember that "bug" about Hi-Res + DVC compatibility issue in some devices that causes audio leaking through speakers after a random period of time passes? I noticed that when I repeatedly click my headphones mic button the audio briefly comes back to headphones, maybe for half a second each time I press it (then leaks again from speakers)

Share this post


Link to post
Share on other sites

V 799: Album tracks not playing in sequence automatically after first track plays.  Error message: "Failed to play." Help?

Update: Seems to occur only when wired headphones are plugged in.  Seems to be OK with my car's Bluetooth.

Update 2: Hi res in use with headphones, not with Bluetooth.

Share this post


Link to post
Share on other sites

The error with the hierarchy was not fixed in version 799. New folders did not become on year.

 

Screenshot_20181005-221300.jpg

Share this post


Link to post
Share on other sites

 

On 10/5/2018 at 11:56 AM, maxmp said:

Right, app just can't freeze forever and stay as is, as users will complain about that even more (and they did).

There is always an option not to update and use previous releases.

I swapped album artist to artist album in build 799 (out tonight).

Thanks for making the change =D

Share this post


Link to post
Share on other sites
It would be good if the x in the notification disappears and will slip to close this notification.
please
 
 
 
 
 
 
 

Share this post


Link to post
Share on other sites

I have a little problem when playing over Bluetooth. 

And I use a Fiio BTR3 coupled to my headphones. 

The problem is that the sound always distorts and briefly interrupts and so the music listening is no Fun. 

There are no connection problems with neutron, but there are persistent connection problems with Poweramp. 

Can someone give me some tips on how to fix this? 

 

Share this post


Link to post
Share on other sites

It would be nice to have an option to separate users playlist like in older versions (user playlist and playlist from files)

i usually do playlist backups and now i have duplicated playlist one after another

Example added

 

Screenshot_20181007-003347.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...