Jump to content
Poweramp
maxmp

Poweramp Build 799 (Release Candidate)

Recommended Posts

Is the Replay Gain working fine at the moment? I did not use it for a long time and wanted to know.

Share this post


Link to post
Share on other sites
52 minutes ago, JKF said:

thanks two of my problems was fixed in this update.. added sort by time played, and it now return to the list after playing the queue.. thanks Dev.

but please let us disable the delete option just like in v2

and one other problem when the "shuffle all" is enable it ignores the queue, please fix that.. i already mention that last time..

I second the being able to disable the delete function.

Share this post


Link to post
Share on other sites

Very bad .. my Redminote4 Qualcomm android 7.0 (miui 9.6.3) was supported high res Audio output till rc build 797. But after new update the high res Audio output fails to play through headset ..I tried installing rc build 797 again but no positive result ...I'm disappointed

@maxmp

Share this post


Link to post
Share on other sites
6 hours ago, RunRabbitRun said:

Is the song bar at the bottom going to be fixed in future builds? It still shows the incorrect song at the bottom of the menu upon startup, looks like the only thing that fixes it is closing the app and reopening. 

This may happen during initial scans, but it should reload the state within few seconds after the scan.

During the scanning, Poweramp database is changed a lot, and UI doesn't reflect that immediately, so there are "snapshots" of data in the UI. After rescan, it should all sync to the actual data. This is usually not noticeable on small collections, but can be noticeable in large ones, esp. if user manages to click some song right during scan when database changes.

The other alternative is to block UI completely until all scans are complete.

Share this post


Link to post
Share on other sites
19 minutes ago, maxmp said:

This may happen during initial scans, but it should reload the state within few seconds after the scan.

During the scanning, Poweramp database is changed a lot, and UI doesn't reflect that immediately, so there are "snapshots" of data in the UI. After rescan, it should all sync to the actual data. This is usually not noticeable on small collections, but can be noticeable in large ones, esp. if user manages to click some song right during scan when database changes.

The other alternative is to block UI completely until all scans are complete.

i like the idea of blocking the ui.  it seems more predicable and closed end from a code perspective.

maybe a little spinning wheel or progress bar if want to be fancy.

Share this post


Link to post
Share on other sites

why the *** the queue list is shuffling??? please give us option to ignore the shuffle mode when queue begin.. 

Share this post


Link to post
Share on other sites
10 hours ago, clever_man said:

Rebuil the skin with the last API changes. Max didn't compile this skin you must ask skinbuilder.

Sorry, dunno how to do this...

Share this post


Link to post
Share on other sites

Playback Stops at the end of the song  displaying "Failed to Play" if "shuffle All" is active . Never happened before. 

 

Share this post


Link to post
Share on other sites
12 minutes ago, pwamps said:

Playback Stops at the end of the song  displaying "Failed to Play" if "shuffle All" is active . Never happened before. 

 

Same here, it happens when playing an mp3 audiobook with shuffle off.

Share this post


Link to post
Share on other sites
3 hours ago, egorlins said:

@maxmp, still does not start at Lineage 14.1

 

Poweramp is tested on few Lineage builds, including 14.* and no major issues there. Please try another Lineage build (you can also PM me a log after "not working" event to investigate). 

Share this post


Link to post
Share on other sites
1 hour ago, JKF said:

why the *** the queue list is shuffling??? please give us option to ignore the shuffle mode when queue begin.. 

Actually, queue is not shuffled in Shuffle Songs mode - this is a bug as it's shuffled in Shuffle Songs / Categories. Queue is not shuffled / started in Shuffle All mode - other shuffle modes should shuffle queue.

Share this post


Link to post
Share on other sites

Thanks for the update. I would like to see the "ignore shuffle" for the queue settings again so it can play the queue songs that I picked in order.

Share this post


Link to post
Share on other sites

Working very well on LineageOS 16. Only the problem with the volume keys also starting the playback while screen is locked and Poweramp is NOT playing persists. Though I still do not know wether it is a problem with Poweramp or LOS, maybe Max can tell me? :) It does not happen with other players like stock LOS player or Pulsar, though.

Share this post


Link to post
Share on other sites

I still think you guys made a huge mistake. changing the original app so drasticly.. it's just absurd. every time I update my 709 build by accident to this piece of **** breaks my nerve right away.. no hierarchy preserved, everythings unballanced, cant browse through folders like we used to.....  (like, do I really have to scroll up 1000 songs to get back one folder?). why couldnt it be just another app version - a separate one? why?! makes no sence.. basically u destroyed our trust on urselves. will never advice to buy this thing to anyone EVER again. was biggest mistake.. you unresponsible devs! ? it feels like you sold the product to some millenium shmucks  or smth. and the spirit of this wonderfull Poweramp is gone. all is lost.. :( you killers...... never coming back to this forum as well. all these tries.. such a waste of time.

Share this post


Link to post
Share on other sites
1 hour ago, pauzak said:

I still think you guys made a huge mistake. changing the original app so drasticly.. it's just absurd. every time I update my 709 build by accident to this piece of **** breaks my nerve right away.. no hierarchy preserved, everythings unballanced, cant browse through folders like we used to.....  (like, do I really have to scroll up 1000 songs to get back one folder?). why couldnt it be just another app version - a separate one? why?! makes no sence.. basically u destroyed our trust on urselves. will never advice to buy this thing to anyone EVER again. was biggest mistake.. you unresponsible devs! ? it feels like you sold the product to some millenium shmucks  or smth. and the spirit of this wonderfull Poweramp is gone. all is lost.. :( you killers...... never coming back to this forum as well. all these tries.. such a waste of time.

If you don't like it then just use old version or switch to other player but you don't have any right to use this language. I am very much happy with ui and sound it is the best android audio player till date.

Share this post


Link to post
Share on other sites

Always process album art still doesn't work with android auto plugins (PowerAMPCar, Poweramp Auto). I don't know if it's a bug with the plugins (or change in sdk), or Poweramp itself, but in b709 it's fine.

Share this post


Link to post
Share on other sites

Is there a way to switch the album name with the artist name? the artist name  will never display if the album name is to long. There is also no animation to display the artist name in this situation 

Share this post


Link to post
Share on other sites
13 minutes ago, Manikant said:

If you don't like it then just use old version or switch to other player but you don't have any right to use this language. I am very much happy with ui and sound it is the best android audio player till date.

Right, app just can't freeze forever and stay as is, as users will complain about that even more (and they did).

There is always an option not to update and use previous releases.

1 minute ago, hjjiang said:

Is there a way to switch the album name with the artist name? the artist name  will never display if the album name is to long. There is also no animation to display the artist name in this situation 

I swapped album artist to artist album in build 799 (out tonight).

Share this post


Link to post
Share on other sites
10 hours ago, lasse said:

Settings -> Library -> Queue 

Disable 'Start Playing Queue Immediately' 

I overwrited v2 with all alpha versions by thinking that my settings is saved. Thank you. ?

Share this post


Link to post
Share on other sites
9 minutes ago, maxmp said:

I swapped album artist to artist album in build 799 (out tonight).

Can't wait for this. Hope the long titles will be scrolling (animated) like in V2. Thanks in advance, Max!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...