Jump to content
Poweramp
Semx11

Album art issue

Recommended Posts

Hello,

I'm running into an issue with the beta that I haven't had before.

I have a directory of 46 songs, mp3 format. All songs belong to the same album, and have the same album name. They are properly numbered 1 through 46. Every song has a unique title. Each individual song has it's own embedded album art, 600x600 png. There are no other image files present in the folder where these songs are located.

Today, I tried to change the album art of a single song. I selected the song, pressed "Album Art", and picked an image from my gallery. When I changed it, it changed the album art of all the songs in that album. When I look at every single song and look at the "Album Art" option, each one still has the proper embedded art inside it file. Selecting the right image again changes the cover art for every song in that album.

I tried resetting the album art cache, doing a full rescan, restarting Poweramp, restarting my phone, copying all the songs from my Android phone onto my PC and copying it back, etc. (When I look at the songs on my PC, each one has the correct cover image).

How do I reset the album art in Poweramp that it always shows the embedded image, and not some thing I once selected?

Thanks,

Sem

Share this post


Link to post
Share on other sites

@clever_man I did this, and now all songs have no cover art. After doing this I also tried to reboot my phone, tried to clear the cache and tried to do a full rescan. No luck so far ?

Share this post


Link to post
Share on other sites

@clever_man yes, each individual song shows a 600x600 image and it says "Embed album art" under it. The "Embed album art" is different for each song. But when I select it for that song, it changes the album art for all the songs in that album. But before I tried changing one of them, all songs had their unique and original cover art.

Share this post


Link to post
Share on other sites

I wonder if Max has implemented the long-requested mode to change artwork for a whole album in one go? Try viewing in All Songs mode and see if you can change them song-by-song.

Andre

Share this post


Link to post
Share on other sites

@andrewilley I tried doing that, but it still changes the cover of every song in the album. It's kind of weird ?

And if that was a long-requested feature, I can't find a toggle for it. Perhaps it is a bug? I didn't think it would be, because it worked properly before I changed any cover.

Share this post


Link to post
Share on other sites

@maxmp, could you comment on this please? If this is a new feature, then I agree with the OP that it ought to be an optional setting.

Andre

Share this post


Link to post
Share on other sites

Seeing the same behavior on latest v3-build-838-amd64-play [838004-ab48a502a] installed via Play Store's beta channel.

Share this post


Link to post
Share on other sites

I have the exact same problem. An album with 212 songs, each song has its own embedded album art. But it applies the album art of one of the songs to every song on the album, and when I change it to the right album art for one song, it changes all the songs to that same album art. Any solution to this yet?

Share this post


Link to post
Share on other sites

@Semx11 album art is per album. Poweramp will set per-track cover for singles only (tracks missing album tag). Thanks!

Share this post


Link to post
Share on other sites

Found the solution in another thread:

"Album Art" means art for the album. If you don't want that but have already seleted one, go to the following directory

/Android/data/_com .maxmpz.audioplayer /selected_aa

and remove the file for the album.

This works. Just delete the jpg for the album in that folder.

Share this post


Link to post
Share on other sites
1 hour ago, Daniel Knoll said:

Found the solution in another thread:

"Album Art" means art for the album. If you don't want that but have already seleted one, go to the following directory

/Android/data/_com .maxmpz.audioplayer /selected_aa

and remove the file for the album.

This works. Just delete the jpg for the album in that folder.

Thank you so much, this fixed my issue!

17 hours ago, maxmp said:

@Semx11 album art is per album. Poweramp will set per-track cover for singles only (tracks missing album tag). Thanks!

I understand, but gladly I was able to reset it to a different image per track in the same album through the above method. Perhaps it could be made more clear that this is possible, possibly through a "reset selected album art" button?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...