Jump to content
Poweramp
KoolMoeDe

Poweramp (797) Car Steering Wheel Controls No Longer Work After Update

Recommended Posts

Hi,

I am running an android (OREO 8.0) car head unit with Poweramp installed for my music needs. Unfortunately the steering wheel controls no longer work after updating the app on the head unit however they did work before the update.

I updated it from a much older build (I know as the new build has a new layout) and it is now running PA build 797.

Its a bit annoying as this is the reason why I purchased PA. Is there any advise or workaround to get this working again?

Let me know if I can provide you with anything to assist troubleshooting the issue. I have performed an uninstall of the app and a reinstall which had no effect.

Cheers. 

Share this post


Link to post
Share on other sites

@KoolMoeDe, now Poweramp doesn't support car head units. On this devices it is working "as is". Dev has no abillity to perform testing on such devices. 

Share this post


Link to post
Share on other sites

Hi @clever_man,

Is this really the response I am going to get?

The fact that it was working before the update is a bit strange. Something must have been changed for this functionality to cease. It would be great to get a more technical answer from someone.

I also had the idea of using an older build. Is there a way this can be achieved?

Cheers.

Share this post


Link to post
Share on other sites

 

@KoolMoeDe, now main purpose fot Dev will release stable version for smartphones and he has not ability to find and fix problems for not supported devices.

9 minutes ago, KoolMoeDe said:

Is there a way this can be achieved?

You can try using apps like the Tasker for find events which triggered by pressing buttons on steering wheel and than create action (via Poweramp API) for controlling of Poweramp.

 

Share this post


Link to post
Share on other sites

The Tasker way to work around this is too dark and confused, and it needs at least AutoInput to listen to hardware buttons. And then, there's a 200ms delay for media control events via Poweramp API (as stated in the source). Also, who will ever purchase two separate apps to work around something that should just work?

It isn't only a car unit problem: I can't control media playback with my headphones attached on my phone also, so it's more like "Poweramp doesn't listen to media buttons" rather than "it's a car unit problem".

Share this post


Link to post
Share on other sites

A number of people have been having issues with headset buttons (and bluetooth buttons) not responding with Oreo, this could be related to that? 

Andre

Share this post


Link to post
Share on other sites
13 hours ago, clever_man said:

 

@KoolMoeDe, now main purpose fot Dev will release stable version for smartphones and he has not ability to find and fix problems for not supported devices.

You can try using apps like the Tasker for find events which triggered by pressing buttons on steering wheel and than create action (via Poweramp API) for controlling of Poweramp.

 

I completely understand however you seem to be very very quick to say the issue cannot be fixed/supported. Like I said earlier, it was working completely fine before the update so the dev team has changed something related to this. I am sure I am not the only one having these problems.

I have already tried using tasker for other app purposes. Its really not worth the hassle but thanks for the suggestion.

 

7 hours ago, AryToNeX said:

The Tasker way to work around this is too dark and confused, and it needs at least AutoInput to listen to hardware buttons. And then, there's a 200ms delay for media control events via Poweramp API (as stated in the source). Also, who will ever purchase two separate apps to work around something that should just work?

It isn't only a car unit problem: I can't control media playback with my headphones attached on my phone also, so it's more like "Poweramp doesn't listen to media buttons" rather than "it's a car unit problem".

Agree about tasker. Ok so others are having problems also. Good to know the issue is a larger scale with other hardware so it has a higher probablity of being bug fixed in an upcoming build.

 

4 hours ago, andrewilley said:

A number of people have been having issues with headset buttons (and bluetooth buttons) not responding with Oreo, this could be related to that? 

So I can confirm that my car head unit was always on OREO and the steering wheel buttons where always working without fault on an older build.

If you mean an issue with the latest build of PA and OREO then sure there could definitely be an issue.

Share this post


Link to post
Share on other sites

Does anyone know the easiest way to install an older build of PA?

Where to get etc.

Currently every time I need to change a song I have to look at the cars head unit and and use the touch screen to hit 'NEXT'. While it does not seems that bad. It is definitely not a safe thing to do while trying to drive at the same time.

 

Share this post


Link to post
Share on other sites
5 hours ago, KoolMoeDe said:

it was working completely fine before the update

You must understand that for find problem the dev need to install the on the same device with the same firmware and testing new options. "It is working before the last update" isn't help because many change per each updates and only testing will help to find solution. At that monent the dev doesn't support such devices and he hasn't it for testing.

5 hours ago, KoolMoeDe said:

Does anyone know the easiest way to install an older build of PA?

Uninstall current version and install previous version. Oldest versions you can find in the download section of this site.

Share this post


Link to post
Share on other sites
17 hours ago, clever_man said:

Uninstall current version and install previous version. Oldest versions you can find in the download section of this site.

Ok thanks mate. I didn't see that section. Ill try it out and see if it fixes the problem.

@everyone else

Thank you for your feedback on the issue. In summary it seems like since the new build of PA was released there have been ongoing media input external hardware button issues with many different devices including bluetooth devices, headphones, head units etc. For now I will be using an old version to resolve the issue. It would be great someone could update this thread if the situation changes.

Share this post


Link to post
Share on other sites
On 10/2/2018 at 8:39 PM, andrewilley said:

A number of people have been having issues with headset buttons (and bluetooth buttons) not responding with Oreo, this could be related to that? 

Andre

Personally I use AOSP-Extended Oreo 8.1 and media play/pause only works when I have PA in foreground. Even the "long press volume keys to skip track" feature of my ROM that once worked flawlessly now doesn't work. Tried with other players and it simply works even in background, so it sounded weird to me. A thing I noticed, using AudioTrack as output causes the media buttons to work, always; I don't know why and I don't know how buttons and audio output are related to each other. I don't believe that this is an issue with the ROM I'm using since the same behaviour can be observed in other Custom ROMs and even in my friend's OnePlus 3T with stock OOS Oreo.

Share this post


Link to post
Share on other sites

Hi All,

To anyone wondering. I have had a chance to revert to a previous version of Poweramp (build 588) and the hardware button functionality on the steering wheel controls is now fully functional again.

Updating the build of Poweramp had broke this functionality.

It would be great if this functionality is fixed in the new build that someone could update this thread.

Share this post


Link to post
Share on other sites

Hi all!

I have a Joying stereo and had exactly the same problem with v3. After reverting to v2 the functionality was restored.

It was a little more challenging for me, cuz I replaced my coreboard and went from Android 7 to Android 8 at the same time with upgrading to v3. So, I suspected something is wrong with the new firmware on my unit and was about to write to manufacturer about the problem. But after finding this thread and downgrading back to v2, the steering wheel buttons functionality is restored.

 

I hope dev will investigate and fix this issue, as it's affecting a lot of people which are using Poweramp on their Android stereos and purchased Poweramp to support dev.

 

Pavel

Share this post


Link to post
Share on other sites
On 10/7/2018 at 11:19 PM, blind-bird@yandex.ru said:

Проблема решена ?

Проблема не решена, но есть костыль. Удалите текущую версию, скачайте и установите v2 из раздела Download и будет вам счастье. Ответ разработчиков вы видели - не я и лошадь не моя.

Share this post


Link to post
Share on other sites
On 10/11/2018 at 8:24 AM, KoolMoeDe said:

Hi All,

To anyone wondering. I have had a chance to revert to a previous version of Poweramp (build 588) and the hardware button functionality on the steering wheel controls is now fully functional again.

Updating the build of Poweramp had broke this functionality.

It would be great if this functionality is fixed in the new build that someone could update this thread.

Hi,

Still an issue for me to. I also have other friends with similar android car stereos who are having the same issue.

Share this post


Link to post
Share on other sites
On 1/14/2019 at 7:05 AM, KoolMoeDe said:

Hi,

Still an issue for me to. I also have other friends with similar android car stereos who are having the same issue.

Видимо тут всем наплевать на это , что очень жаль ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×