Jump to content
Poweramp
maxmp

Poweramp Build 797 (Release Candidate)

Recommended Posts

It would be nice if DVC worked for Snapdragon based audio in the full release.

OnePlus 6 now has an official release of Android Pie, but DVC still doesn't work with HiRes, though it did in Oreo and below.

Share this post


Link to post
Share on other sites

Спасибо за новую версию! Но, прошу, дайте возможность выбрать формат файлов, которые Poweramp будет добавлять в свою библиотеку (как было ранее). Также, было бы здорово, если бы Вы добавили управление плеером через окошко чехла (экран блокировки) 

Google Translation:
Thanks for the new version! But, please, give the opportunity to choose the file format that Poweramp will add to your library (as it was before). Also, it would be great if you added control of the player through the cover window (lock screen) 

Share this post


Link to post
Share on other sites
On 9/20/2018 at 2:01 AM, andrewilley said:

Have either of you tried tapping on the meta-data line in the player screen? You can cycle through multiple display options.

Andre 

oh thank you for the tip. :)

Share this post


Link to post
Share on other sites
1 hour ago, GodFather said:

Thanks for the new version! But, please, give the opportunity to choose the file format that Poweramp will add to your library (as it was before). 

Poweramp has never offered that option in any version. You can choose which folders are allowed to be scanned though, via Settings > Library > Music Folders.

You can also control the player via the Android lockscreen (or PA's own version) if you enable that feature in Settings > Lock Screen.

Andre

Share this post


Link to post
Share on other sites

well another bug still not fixed.   I synced my music form the computer the night before last.   then the next day turned on my bt headphones started to mow the yard and the song only played for 3 seconds then switched to another song.   after stopping the mower and pulling my phone out I see it's on "all songs" again.   I tried to go back to the playlist but it's gone .  deleted.   vanished.   i tried a rescan.   gave up.   picked a different playlist.   forgot about it.   went to the gym today and looked for the playlist that i used the day before and it's still gone.   So i got mad.   I resynced the phone again from the computer.  looks like the playlist got synced back.   good.   till next time.   I hope this can be resolved once and for all.   the last two updates didn't fix it.   I don't know if Max tried to fix it yet.  

Share this post


Link to post
Share on other sites

maxmp Hi Max.

I am translating using crowdin's translation project, but there are places that I can not translate (newly added points). Please add it.

example: Look and Feel-"Hide Status Bar", Notifications-"Show Previous Track Action(<<)", Player UI-"Rating Type" "Show Track Counter", Audio-Output-"Experimental" etc.

Share this post


Link to post
Share on other sites

In the v79x branch "Resume on Wired Headset" stopped working.  Not observed with the v70x branch.

Also in the v79x branch, sometimes there is no sound output when a new song begins. Stop/Pause will bring the sound back.

Nokia 6 2017 Oreo 8.1.

 

Share this post


Link to post
Share on other sites
On 9/16/2018 at 6:59 PM, maxmp said:

Poweramp-rc-build-797-uni.apk

https://play.google.com/apps/testing/com.maxmpz.audioplayer

RC Build 797:
• slightly increased selected item contrast
• fixed crash on category change
• fixed lockscreen not always appearing
• Folders Hierarchy is now always enabled by default
• widgets now should survive reboots better
• fixed constant reloads (flashing) on Android 7-
• fixed few crashes due to the translations
• fixed Enqueue and stay in the list option
• improved BT/headset keys support for Hi-Res audio output on Android 8+
• removed Send Album - Artist with Metachanged Title option, as it doesn't work for new Androids anyway
• clear action for Recently Added / Recently Played / Most Played
• app icon (launcher) shortcuts (Android 7+)
• few other bug fixes and small improvements

 

 

 

Where can I d/l the last release prior to the first release of this HORRIBLE UI? 

Share this post


Link to post
Share on other sites

i found another bug.   I went to the EQ while playing music and then when i clicked the now playing bar at the bottom, instead of going to "now playing" it just kept going to the next song.   i went though 15 songs before i forced close and started over.   It's only did it just that one time.   weird.   

Share this post


Link to post
Share on other sites

If I start playing the first song of an album, after the second song finishes, playback stops and I have to select the next song manually to resume playback. Anyone else experiencing this?

Share this post


Link to post
Share on other sites
3 minutes ago, streaml1ne555 said:

If I start playing the first song of an album, after the second song finishes, playback stops and I have to select the next song manually to resume playback. Anyone else experiencing this?

Me, when Im using other app (Poweramp in background) after the second song finishes it stops playing

Share this post


Link to post
Share on other sites
1 hour ago, MeGustaPowerAmp said:

Mucho malo? xD

Sure, the new UI is... polarizing, but IMO I like it.

haha.... perhaps a short linguistic lesson? ?

Mucho, being a Spanish word means Big, Large, Grand, etc....

Mahalo means Thank You in Hawaiian.

Put the two together and you have a multilingual phrase defining a muy grande thanks Dude!  hehe....

I hadn't used Poweramp for a few, then last week I had to drive to the northern side of LA from N. San Diego and the radio was irritating. So I fired up Poweramp as I always have at least 30 GB of .flac music files, and much to my chagrin, the GUI was all fkd up. I quickly discovered that while driving at 80+ mph was not a good time to be messin wit it, so I pulled off the freeway and spent 15 mins trying to figure it all out, finally giving up. Beyond that however, I hate the GUI, the size of the buttons, and the general non-existence of a fast forward button, a folder tree view, and easily accessible (physically with my fat fingers) EQ settings, etc. I could go on & on but it would be fruitless. I did find a major bug in it once i got home and messed with it. Both on my Note 8 and Note 7, whenever I swiped up so the Folder tab was visible, Poweramp would completely die asking me if I wanted to send a debug file. I have replicated this issue EVERY TIME I have tried it.

But seriously guys (Poweramp Tech Engineers), the glitter and fluff needs to go, bye bye, adios, sayonara, chow, don't let the door hit you in your posterior as the worthless GUI leaves the building. As an 8+ year avid user of Poweramp, I am completely disappointed in the Engineering staff for modifying a very great interface and replacing it with flash, bam, pow, lookie here UI to try to gain customers. SAD..... I would forever be totally dedicated to Poweramp should the old GUI will always be an option..... as much as I continue to use only WinAmp on all my systems. (Stereo Tool is the best DSP/Effect Plugin ever, and in combination with WinAmp, opens up a whole nother wurl of music being able to listen to those oldy moldy scratched 33 & 1/3 thin round disks.) Perhaps a young smart programmer might dive in and write something for Poweramp...????

1 hour ago, MeGustaPowerAmp said:

Mucho malo? xD

Sure, the new UI is... polarizing, but IMO I like it.

 

Share this post


Link to post
Share on other sites
1 hour ago, fsalfen said:

haha.... perhaps a short linguistic lesson? ?

Mucho, being a Spanish word means Big, Large, Grand, etc....

Mahalo means Thank You in Hawaiian.

Put the two together and you have a multilingual phrase defining a muy grande thanks Dude!  hehe....

I hadn't used Poweramp for a few, then last week I had to drive to the northern side of LA from N. San Diego and the radio was irritating. So I fired up Poweramp as I always have at least 30 GB of .flac music files, and much to my chagrin, the GUI was all fkd up. I quickly discovered that while driving at 80+ mph was not a good time to be messin wit it, so I pulled off the freeway and spent 15 mins trying to figure it all out, finally giving up. Beyond that however, I hate the GUI, the size of the buttons, and the general non-existence of a fast forward button, a folder tree view, and easily accessible (physically with my fat fingers) EQ settings, etc. I could go on & on but it would be fruitless. I did find a major bug in it once i got home and messed with it. Both on my Note 8 and Note 7, whenever I swiped up so the Folder tab was visible, Poweramp would completely die asking me if I wanted to send a debug file. I have replicated this issue EVERY TIME I have tried it.

But seriously guys (Poweramp Tech Engineers), the glitter and fluff needs to go, bye bye, adios, sayonara, chow, don't let the door hit you in your posterior as the worthless GUI leaves the building. As an 8+ year avid user of Poweramp, I am completely disappointed in the Engineering staff for modifying a very great interface and replacing it with flash, bam, pow, lookie here UI to try to gain customers. SAD..... I would forever be totally dedicated to Poweramp should the old GUI will always be an option..... as much as I continue to use only WinAmp on all my systems. (Stereo Tool is the best DSP/Effect Plugin ever, and in combination with WinAmp, opens up a whole nother wurl of music being able to listen to those oldy moldy scratched 33 & 1/3 thin round disks.) Perhaps a young smart programmer might dive in and write something for Poweramp...????

 

Mucho also means “a lot"... actually, in Spanish, the correct phrase is “lot of thanks" (muchas gracias) but I'm just being pedantic here xD

Mahalo for teaching me that “Mahalo" is an actual word ?

I'm with you, the new UI has a steep learning curve... but someone said that Max may create a V2 based skin... ETA for that skin? IDK, it's a good question for Max.

 

Edit:

On 8/15/2018 at 11:03 AM, clever_man said:

Thx to Max for pins this topic.

Now he working on test skin for dev and trying add old-style progressbar to v3. Maybe he'll created a v2-styled skin for conservatives.

 

Share this post


Link to post
Share on other sites
2 hours ago, hypomaniac-eric said:

i found another bug.   I went to the EQ while playing music and then when i clicked the now playing bar at the bottom, instead of going to "now playing" it just kept going to the next song.   i went though 15 songs before i forced close and started over.   It's only did it just that one time.   weird.   

I can't replicate your issue, so it's probably a “single time bug"... maybe it's related to the “swipe left / right to previous / next track" action

Share this post


Link to post
Share on other sites
5 minutes ago, MeGustaPowerAmp said:

Mucho also means “a lot"... actually, in Spanish, the correct phrase is “lot of thanks" (muchas gracias) but I'm just being pedantic here xD

Mahalo for teaching me that “Mahalo" is an actual word ?

I'm with you, the new UI has a steep learning curve... but someone said that Max is working in a V2 based skin... ETA for that skin? IDK, it's a good question for Max.

Si. I'm really bummed tho because I've been yelling from the mountaintops for 8+years how great Poweramp was for an Android phone. I couldn't live without it, seriously. There IS nothing better, (as far as I know) but I've not had the need to check out anything else...... until now. Thanks for the replies. It seems we are on the same page. I'm a 30-year IT Network and Server Engineer and that friggin UI was worse than trying to teach users how to use Vista! Haha

Share this post


Link to post
Share on other sites
6 minutes ago, fsalfen said:

Si. I'm really bummed tho because I've been yelling from the mountaintops for 8+years how great Poweramp was for an Android phone. I couldn't live without it, seriously. There IS nothing better, (as far as I know) but I've not had the need to check out anything else...... until now. Thanks for the replies. It seems we are on the same page. I'm a 30-year IT Network and Server Engineer and that friggin UI was worse than trying to teach users how to use Vista! Haha

Maybe check out some of the optional skins? Might help a little...

https://forum.powerampapp.com/topic/14907-Poweramp-v3-sample-skin-enru/?page=1

I don't think it will help the crashing issue you found though.

Share this post


Link to post
Share on other sites

Hey @maxmp I'm still having that issue with the various Artist album's from the previous version where each artist shows up as a seperate version of the same album... Any progress on this?

Share this post


Link to post
Share on other sites
6 hours ago, thesleezking said:

Hey @maxmp I'm still having that issue with the various Artist album's from the previous version where each artist shows up as a seperate version of the same album... Any progress on this?

Check to see that the 'Album Artist' tags in every file are the same in each tracks in the compilation album.

Andre

Share this post


Link to post
Share on other sites
8 hours ago, andrewilley said:

Check to see that the 'Album Artist' tags in every file are the same in each tracks in the compilation album.

Andre

This is the problem?

Album Artists:
Albums are listed according to the tag 'Album Artist' and if it is empty, albums are listed in the 'Unknown artist' item.
Fix: If the tag 'Album Artist' is empty for a normal artist album, the tag 'Artist' is used for the Album Artist.

Albums by Artist:
Albums are listed according to the tag 'Album', where a compilation album is shown multiple times for each 'Artist' tag in the album.
Fix: If the 'Album Artist' is specified, ignore the 'Artist' tag and label it as 'Various' or blank, to have a compilation album only listed once.

The only way that is working for me, is to have both the 'Album Artist' tag and all the 'Artist' tags the same name, e.g. Various ...
To display the artist, the 'Title' tag is set to Title/Artist, which is a problem in the Artist list.

Share this post


Link to post
Share on other sites

Poweramp does not keep track correctly of which song is currently playing. Full rescan is not an option.

This data is stored in the sharedprefs. For Poweramp these are stored here: /data/data/com.maxmpz.audioplayer/shared_prefs/*  The relevant file is PlayerService.xml.

I swear this file gets reset to the first song of the playlist. This happens when not having Poweramp open or sometimes when closing Poweramp.

It's not happening all the time, but I cannot pinpoint why. The only errors I see are the "toUriCore FAIL to moveFilesCursorToId" errors. Max said these are fixable by a full rescan which does is NOT working :/

Please don't release this code as is, this is not ready for production.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×