Jump to content
Poweramp
maxmp

Poweramp Build 797 (Release Candidate)

Recommended Posts

On 9/18/2018 at 9:01 PM, CypherMK said:

I tried every setting with dvc on and off, but nothing works.

I got the Sonata HD up and running.

Screenshot_2018-09-23-00-02-00.thumb.jpg.f7a91a90f92401f4b67975e92720588f.jpgScreenshot_20180922-235936.thumb.jpg.42a8b826807ef91d45366b20e5a72260.jpgScreenshot_20180922-235949.thumb.jpg.98e4752c44d33ea8ddfb2f574f726526.jpgScreenshot_20180923-000401.thumb.jpg.f01448c86a233474650c90150eada397.jpg

Share this post


Link to post
Share on other sites
2 hours ago, Spaceoid said:

Anybody having problems with the volume keys for skipping a track? Even if Poweramp is NOT playing, a long press on the volume key (while phone is locked) does start Poweramp and playback. So often while I sit in university and the music accidently starts playing. It does not happen with standard LineageOS music player. So I THINK it might be a Poweramp issue...

Lucky. At me they at all do not work.

Share this post


Link to post
Share on other sites
On 9/21/2018 at 1:48 PM, luv4metalcore said:

Likely, excuse, and most custom roms need root to flash. Maybe now a days the custom recovery without root can install them. Still does not make it that both or multiple buggy software can only be Poweramp that causes it. If you ask every single person that announces a bug here, more likely they have a custom rom installed. Most people that said they did not have the option for hi res said they had custom rom.

Custom roms is what is making this process for Max take even longer. Oh, and he can't test for every single custom rom that has been installed.

Haber, no necesariamente ahora en las versiones de Android que trabajamos, la mayoría solo con tener bootloader abierto se pueden flashear por fastboot   y tener una Custom ROM en nuestro terminal sin rootearlo, como también podríamos tener acceso a raíz y tener una Stock ROM, yo pienso que Poweramp puede trabajar bien tanto en una custom como en una stock ROM independientemente de si el terminal este rooteado o no, siempre y cuando lo que afecte a perfiles, conf, y prop referentes al audio y a lo que Poweramp demande no hayan sido alterados, modificados o sustraidos, referente a lo del desarrollo, creo que Max cumple con verificar que sobretodo en las versiones stables de software trabaje bien su reproductor.

Un Saludo,

Google Traductor (sorry) 

Haber, not necessarily now in the versions of Android that we work, most only with having open bootloader can be flashed by fastboot and have a Custom rom in our terminal without Rootearlo, as we could also have access to root and have a Stock ROM , I think that Poweramp can work well both in a custom and a stock ROM regardless of whether the terminal is rooted or not, as long as it affects profiles, Conf, and prop related to audio and what Poweramp Sue have not been altered , modified or stolen, referring to the development, I think that Max complies with verify that especially in the stable versions of software work well your player.

A greeting,

 

Share this post


Link to post
Share on other sites
57 minutes ago, SynekPablo said:

I got the Sonata HD up and running.

Screenshot_2018-09-23-00-02-00.thumb.jpg.f7a91a90f92401f4b67975e92720588f.jpgScreenshot_20180922-235936.thumb.jpg.42a8b826807ef91d45366b20e5a72260.jpgScreenshot_20180922-235949.thumb.jpg.98e4752c44d33ea8ddfb2f574f726526.jpgScreenshot_20180923-000401.thumb.jpg.f01448c86a233474650c90150eada397.jpg

How did you get this to work? I tried your settings, but I can't match them all the same. For example, I can't switch of resampler. What Poweramp version are you running?

 

I also tried my original pixel dongle earlier today, and it gave me hi res audio. But not the Sonata. 

Share this post


Link to post
Share on other sites
1 hour ago, CypherMK said:

How did you get this to work? I tried your settings, but I can't match them all the same. For example, I can't switch of resampler. What Poweramp version are you running?

 

I also tried my original pixel dongle earlier today, and it gave me hi res audio. But not the Sonata. 

I'm running PA rc Build 797 (play).

I connected the Sonata HD to the notebook again.

Then I looked for the Sonata HD in the device management and uninstalled it.

On Hidizs.net in the download area you download the PURE_MUSIC_D firmware.

The following link contains a description for the installation of the firmware.

The explanation is quite simple as opposed to that which is offered by Hidizs.

You do not have to install Windows drivers just the PURE_MUSIC_D firmware.

I did it that way and then it worked.

A small hint, if you have the PURE_MUSIC_D firmware installed then it may be that the music stops when you use another app in the foreground.

This is not a malfunction but the catch on the PURE MUSIC mode.

Share this post


Link to post
Share on other sites
21 hours ago, MeGustaPowerAmp said:

1. Yeah, that's already possible, just tap the metadata text line until it shows next song's info.

Lol, thanks. I didn't notice it was always there. Now if the text was a little more bigger... but at least I've what I needed.

 

@pauldamo

@andrewilleythanks. Yes, the 4 boxes button works but maybed what I needed to mention Is that I usually play an album and when I decide to listen to a specific song from another list, i goone screen back. This might be because the song is in a different album but the same genre o same artist, which is why I wouldn't want to go back to the very beginning, but probably is only my issue. Thank you for your sugfestion though, i found out too you can swipe from left to right to go back so this might help me not close the app accidentaly.

Share this post


Link to post
Share on other sites
2 hours ago, Franc1sc0 said:

Haber, no necesariamente ahora en las versiones de Android que trabajamos, la mayoría solo con tener bootloader abierto se pueden flashear por fastboot   y tener una Custom ROM en nuestro terminal sin rootearlo, como también podríamos tener acceso a raíz y tener una Stock ROM, yo pienso que Poweramp puede trabajar bien tanto en una custom como en una stock ROM independientemente de si el terminal este rooteado o no, siempre y cuando lo que afecte a perfiles, conf, y prop referentes al audio y a lo que Poweramp demande no hayan sido alterados, modificados o sustraidos, referente a lo del desarrollo, creo que Max cumple con verificar que sobretodo en las versiones stables de software trabaje bien su reproductor.

Un Saludo,

Google Traductor (sorry) 

Haber, not necessarily now in the versions of Android that we work, most only with having open bootloader can be flashed by fastboot and have a Custom rom in our terminal without Rootearlo, as we could also have access to root and have a Stock ROM , I think that Poweramp can work well both in a custom and a stock ROM regardless of whether the terminal is rooted or not, as long as it affects profiles, Conf, and prop related to audio and what Poweramp Sue have not been altered , modified or stolen, referring to the development, I think that Max complies with verify that especially in the stable versions of software work well your player.

A greeting,

 

Another one that does not get what I am talking about. Waste of time.

I guess today's word is still the same as yesterdays. "Troubleshooting".

You know what, just keep doing what you guys are doing. I am done saying anything. Talking just gets interpreted the wrong way. Not going to keep repeating myself because others can't read English to well.

Not going to reply to every single mis-interpretation. Conversations are so dragged on that it is pointless to even bother anymore.

Share this post


Link to post
Share on other sites
12 hours ago, MeGustaPowerAmp said:

It looks... cluttered, to say the

the sample ui will be best for us....i'll be very happy if max add this function in this music player....

Share this post


Link to post
Share on other sites
14 hours ago, pauzak said:

Come on guys, wouldn't it be sensible to make the UI smart finally? I just don't get it, why have you decided to move backwards with all the navigation and playback? makes no sense...
You wanna listen, you browse, you fast forward and skipp in seconds when you browse through your library for the right tune. it has to be like supermegasimple and intuitive! PLEASE bring back at least the playback option to library UI and fast option for foldier hierarchy in playlist..
 
as a mad audiophile I'm a huge PP fan and.. srsly, gu ys, just sit down and finish that UI once and for all. current build does not make little sence, except for the attempt on fresh design approach. which is simply useless for core users. why not just leave the esthetics to those guys who make skins..? :)

made a rough sample of LIBRARY AND MAIN UI MERGED:
 pwramp_sample_03.thumb.png.4835b07e1ca1a5b2a006b93b89f57c55.png

+ I strongly suggest to make vital nav buttons static (play, forward etc) in MAIN and LIBRARY UIs. just like in an e-browser tool bar - you don't wanna look for a hidden home button or page back/page forward, don't u?!

comon guys, who does that!? :D

it's great...@max ....try to add this function pls...

Share this post


Link to post
Share on other sites
6 hours ago, Red Balooon said:

It's been a few days.   Frankly I'm finding more bugs than I ever expected when I first got the beta.  (I have 797).  I would love to know if they will be fixed.

1.  I can't get the queue to start playing immediately after an album.  It sometimes plays after a single song, which is what the setting says is the default (it isn't), but this is inconsistent.  The folder setting is too obscure:  I don't know tech, but I know how to communicate in English, and this doesn't.  It says that turning it on will get rid of the default setting that moves to the queue after a single song.  It doesn't do that, and it is not clear what it is supposed to do.  I want to move from any completed list to the queue:  that was easy in the old version and completely unavailable in this one.

2.  Sometimes when I'm playing an album, Poweramp just stops playing after one or two songs.  Why?

3.  When it does this, it's sometimes associated with a song scrobbling to Last FM that I never played.  For example, I was playing Regina Carter, and Last FM told me I was scrobbling the Rolling Stones.  WTF?

4.  When I load a playlist (which is often), or a queue, there are two buttons that will begin playing music:  one for play (a triangle) and one for shuffle (two arrows twisted together).  Elsewhere in Poweramp, the twisty arrows symbol means "shuffle all songs":  here it means something different.  Use a different symbol, and be consistent.  Worse, pushing that button defaults to "shuffle all songs and all lists."  Why is that the default?  I always choose "shuffle this [gosh darn] list".  Why won't Poweramp remember this choice?

5.  When you touch a song on certain lists, it starts to play.  WTF?  ONLY the play button should start the music playing.  I woke up my wife at 3AM, and now I'm in big trouble and it's your fault.

I thought I'd get more and more used to the upgrade.  Instead, I like it less and less, the more I use it.

1. As far as I know, when shuffle all songs it's on, queue does not start in that way... 

2. No idea, but I think this bug is already reported.

3. IDK

4. This is the “shuffle" button

 1085612370_Screenshot_Poweramp_20180922-10533101.png.70a116398445a6a214094f3364a4cb29.png

This is the “repeat" button

1163512539_Screenshot_Poweramp_20180922-10533102.png.0c845f8a44b66b2a30be02daf51117f9.png

It's not counterintuitive at all, IMO.

5. lol. 

Isn't that logical? 

Share this post


Link to post
Share on other sites
5 hours ago, SynekPablo said:

I got the Sonata HD up and running.

Screenshot_2018-09-23-00-02-00.thumb.jpg.f7a91a90f92401f4b67975e92720588f.jpgScreenshot_20180922-235936.thumb.jpg.42a8b826807ef91d45366b20e5a72260.jpgScreenshot_20180922-235949.thumb.jpg.98e4752c44d33ea8ddfb2f574f726526.jpgScreenshot_20180923-000401.thumb.jpg.f01448c86a233474650c90150eada397.jpg

I flashed the Pure Music Firmware but it is recognized as Wired Headset/AUX..

Share this post


Link to post
Share on other sites
35 minutes ago, PizzaEX said:

I flashed the Pure Music Firmware but it is recognized as Wired Headset/AUX..

In this case, the Sonata HD is recognized as an adapter and not as a DAC.

Is it recognized by the OpenSL HD driver or AudioTrack driver?

Have you tried if the Sonata HD is detected if you have USB DAC enabled, too ?

Otherwise, you can connect the Sonata HD back to the PC and uninstall.

Follow EXACTLY the instructions in this link to install the firmware.

http://www.tempotec.com.cn/en/2-Product/Sonata/SonataHD/firmware.htm

You do not have to install anything except the PURE_MUSIC_D firmware !!!

After that it should work.

Share this post


Link to post
Share on other sites
49 minutes ago, SynekPablo said:

In this case, the Sonata HD is recognized as an adapter and not as a DAC.

Is it recognized by the OpenSL HD driver or AudioTrack driver?

Have you tried if the Sonata HD is detected if you have USB DAC enabled, too ?

Otherwise, you can connect the Sonata HD back to the PC and uninstall.

Follow EXACTLY the instructions in this link to install the firmware.

http://www.tempotec.com.cn/en/2-Product/Sonata/SonataHD/firmware.htm

You do not have to install anything except the PURE_MUSIC_D firmware !!!

After that it should work.

Recognized by OpenSL ES and Hi Res Output, if I turn them off it will go to AudioTrack and all of them are Wired Headset/AUX. (I don't have the OpenSL ES HD)
Works perfectly on windows
Tried reinstall, still no luck.. I guess it is the problem of MIUI or Poweramp by not detecting USB C Audio on default
It works on HibyMusic and USB Audio Player Pro (There is a prompt ask me to access the USB device)

Share this post


Link to post
Share on other sites
17 minutes ago, PizzaEX said:

Recognized by OpenSL ES and Hi Res Output, if I turn them off it will go to AudioTrack and all of them are Wired Headset/AUX. (I don't have the OpenSL ES HD)
Works perfectly on windows
Tried reinstall, still no luck.. I guess it is the problem of MIUI or Poweramp by not detecting USB C Audio on default
It works on HibyMusic and USB Audio Player Pro (There is a prompt ask me to access the USB device)

I talked about this topic with the developer of the Neutron Player.

In his opinion, it is because some apps allow direct access to the USB port, such as the Neutron Player which recognizes the Sonata HD as a driver.

Thus the signal is passed through without detours.

With Poweramp, the whole thing works on the OS which can lead to compatibility issues, as in your case.

Share this post


Link to post
Share on other sites
11 hours ago, Red Balooon said:

1.  I can't get the queue to start playing immediately after an album.

2.  Sometimes when I'm playing an album, Poweramp just stops playing after one or two songs.  Why?

5.  When you touch a song on certain lists, it starts to play.  WTF?  ONLY the play button should start the music playing.  I woke up my wife at 3AM, and now I'm in big trouble and it's your fault.

1. Not sure why this option has been removed, there used to be three options for when queued items would commence playlist (immediately; after current song; after current list) but now it's just an on/off toggle.

2. Max has mentioned he is aware of this and has solved it in his next dev build.

5. This is intended functionality, and has always been the case. Single tap to play a track, long-press for more options. Sorry you are in trouble with your wife though, perhaps headphones might be an idea when using a music player in bed next time? :)

Andre

Share this post


Link to post
Share on other sites

On EMUI 9 android pie The sound is disorted on higher volume . Not max. It s like You put the bass 200% and disable limiter. Poweramp v2 works well though

Share this post


Link to post
Share on other sites
5 hours ago, SynekPablo said:

I talked about this topic with the developer of the Neutron Player.

In his opinion, it is because some apps allow direct access to the USB port, such as the Neutron Player which recognizes the Sonata HD as a driver.

Thus the signal is passed through without detours.

With Poweramp, the whole thing works on the OS which can lead to compatibility issues, as in your case.

I have already flashed the correct firmware. And I also get this usb notification for Hibymusic and Neutron to get direct access to the usb DAC. So I guess Poweramps implementation isn't correct?

Share this post


Link to post
Share on other sites

Anyone have a dark theme with pro controls, text not covering the album art, and squared corners on album art? It's like the holy grail of Poweramp skins and I haven't found it yet :S

Share this post


Link to post
Share on other sites
13 hours ago, MeGustaPowerAmp said:

 

4. This is the “shuffle" button

 1085612370_Screenshot_Poweramp_20180922-10533101.png.70a116398445a6a214094f3364a4cb29.png

This is the “repeat" button

1163512539_Screenshot_Poweramp_20180922-10533102.png.0c845f8a44b66b2a30be02daf51117f9.png

 

Isn't that logical? 

I think you missed the whole point I was trying to make.  I didn't mistake "repeat" for "shuffle."  Nothing in my post indicated any lack of understanding of the many (confusingly different) things the "shuffle" button does in different situations.  Please read again what I asked:

  •  When I load a playlist (which is often), or a queue, there are two buttons that will begin playing music:  one for play (a triangle) and one for shuffle (two arrows twisted together).  Elsewhere in Poweramp, the twisty arrows symbol means "shuffle all songs":  here it means something different.  Use a different symbol, and be consistent.  Worse, pushing that button defaults to "shuffle all songs and all lists."  Why is that the default?  I always choose "shuffle this [gosh darn] list".  Why won't Poweramp remember this choice?

The question is about the difference between "shuffle" (the twisty arrows in the picture above), "shuffle all songs in a list" (the twisty arrows, with three small rectangles to the left), and "shuffle all songs and all lists" (the twisty arrows, with rectangles to the left, two rectangles underneath, and a wee small arrow at the bottom left).  in prior versions of Poweramp, the "shuffle" button you depict only meant one thing, and it meant the same thing in every situation in which it appeared:  shuffle every single song in the whole library, in my case, all 22,000.  Now, it only has that meaning on the main screen when playing a song.  When I load a queue, or a playlist, its meaning changes.  That is what is confusing.  

Here is the screen that is the actual subject of my prior post:

 

 

 

 

image.thumb.png.9d875f519fba009baae9ac91c6ec8ee0.png

this is the screen that comes up after I tap on a playlist.  You will see, under the name of the playlist (here "after hours"), the "shuffle" icon.  Here, it does not mean "shuffle every song in the whole damn library."  It means something else.  This is inconsistent and needs correcting.

When I get to this screen what I want to do is shuffle the songs in the playlist I just selected.  I don't want to command Poweramp to shuffle all songs and all playlists, but that is what it does when I hit the "shuffle" icon.  That's bad on two counts:  the icon doesn't match the command, and the option I want isn't there.

So I tap the mislabeled "shuffle" icon.  It gives me a "pop-up" to tell me that I have just told Poweramp to shuffle songs and categories, something that doesn't match the icon.  It plays a random song from the playlist (which is what I wanted to do).

So I tap on the song, a (too) narrow horizontal band at the bottom.  (In the screenshot, it reads "The One I love").  It brings up the "main" screen, which now shows a different "shuffle" icon, the one for "shuffle songs and categories."  Note that I never told the program to make that choice.

What I wanted was "shuffle just songs."  I have to tap twice more.  I shouldn't have to do that.

In fact, that should be the option when you reach the screen depicted above, upon selecting a playlist or queue.  And I don't think it's too egotistical to say that it should be the default choice on that screen, and depicted with the correct icon.  Moreover the screen above should allow you to tap the "shuffle" icon repeatedly to get the option you want, just as Poweramp does elsewhere.

Are we clear now?  Or are you  gonna send me another picture of the "repeat" icon?

Share this post


Link to post
Share on other sites
9 hours ago, andrewilley said:

1. Not sure why this option has been removed, there used to be three options for when queued items would commence playlist (immediately; after current song; after current list) but now it's just an on/off toggle.

2. Max has mentioned he is aware of this and has solved it in his next dev build.

5. This is intended functionality, and has always been the case. Single tap to play a track, long-press for more options. Sorry you are in trouble with your wife though, perhaps headphones might be an idea when using a music player in bed next time? :)

Andre

Headphones are for when I actually want to listen to music, not for when I am fiddling with a buggy program with a confusing UI that used to be able to do what I want and doesn't any longer.

Share this post


Link to post
Share on other sites
19 minutes ago, Red Balooon said:

I think you missed the whole point I was trying to make.  I didn't mistake "repeat" for "shuffle."  Nothing in my post indicated any lack of understanding of the many (confusingly different) things the "shuffle" button does in different situations.  Please read again what I asked:

  •  When I load a playlist (which is often), or a queue, there are two buttons that will begin playing music:  one for play (a triangle) and one for shuffle (two arrows twisted together).  Elsewhere in Poweramp, the twisty arrows symbol means "shuffle all songs":  here it means something different.  Use a different symbol, and be consistent.  Worse, pushing that button defaults to "shuffle all songs and all lists."  Why is that the default?  I always choose "shuffle this [gosh darn] list".  Why won't Poweramp remember this choice?

The question is about the difference between "shuffle" (the twisty arrows in the picture above), "shuffle all songs in a list" (the twisty arrows, with three small rectangles to the left), and "shuffle all songs and all lists" (the twisty arrows, with rectangles to the left, two rectangles underneath, and a wee small arrow at the bottom left).  in prior versions of Poweramp, the "shuffle" button you depict only meant one thing, and it meant the same thing in every situation in which it appeared:  shuffle every single song in the whole library, in my case, all 22,000.  Now, it only has that meaning on the main screen when playing a song.  When I load a queue, or a playlist, its meaning changes.  That is what is confusing.  

Here is the screen that is the actual subject of my prior post:

 

 

 

 

image.thumb.png.9d875f519fba009baae9ac91c6ec8ee0.png

this is the screen that comes up after I tap on a playlist.  You will see, under the name of the playlist (here "after hours"), the "shuffle" icon.  Here, it does not mean "shuffle every song in the whole damn library."  It means something else.  This is inconsistent and needs correcting.

When I get to this screen what I want to do is shuffle the songs in the playlist I just selected.  I don't want to command Poweramp to shuffle all songs and all playlists, but that is what it does when I hit the "shuffle" icon.  That's bad on two counts:  the icon doesn't match the command, and the option I want isn't there.

So I tap the mislabeled "shuffle" icon.  It gives me a "pop-up" to tell me that I have just told Poweramp to shuffle songs and categories, something that doesn't match the icon.  It plays a random song from the playlist (which is what I wanted to do).

So I tap on the song, a (too) narrow horizontal band at the bottom.  (In the screenshot, it reads "The One I love").  It brings up the "main" screen, which now shows a different "shuffle" icon, the one for "shuffle songs and categories."  Note that I never told the program to make that choice.

What I wanted was "shuffle just songs."  I have to tap twice more.  I shouldn't have to do that.

In fact, that should be the option when you reach the screen depicted above, upon selecting a playlist or queue.  And I don't think it's too egotistical to say that it should be the default choice on that screen, and depicted with the correct icon.  Moreover the screen above should allow you to tap the "shuffle" icon repeatedly to get the option you want, just as Poweramp does elsewhere.

Are we clear now?  Or are you  gonna send me another picture of the "repeat" icon?

Sorry man, I missed the playlist part... As far I knew, that button was an aleatory button... I'm pretty dumb xD

Actually, your idea is quite good. 

Share this post


Link to post
Share on other sites
2 minutes ago, MeGustaPowerAmp said:

Sorry man, I missed the playlist part... As far I knew, that button was an aleatory button... I'm pretty dumb xD

Actually, your idea is quite good. 

thanks for that

.  come to think of it, once you hit either play or shuffle (preferably "shuffle this list") on the playlist screen, the main screen with the song playing should come up right away.

Share this post


Link to post
Share on other sites
1 hour ago, Red Balooon said:

thanks for that

.  come to think of it, once you hit either play or shuffle (preferably "shuffle this list") on the playlist screen, the main screen with the song playing should come up right away.

I came across that problem when i was looking at the top of the playlist screen.  I was like i never tried the shuffle button in playlist before.   So i clicked it and was mad because it took me to shuffle all songs and i had to go back to playlist and click a song in playlist to play the playlist.  

Share this post


Link to post
Share on other sites

Had drinks with my bros and sis when playing via PA. Song stops on queue and even on lists when playing over bluetooth. Hope Max gets this fixed on the new update.... Cheers y'all. ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×