Jump to content
Poweramp
maxmp

Poweramp beta build-795

Recommended Posts

Max I bought the Poweramp unlocker many years ago from this Site and it works with version 2 no problem. But with version 3 it fails to authenticate that I bought Poweramp. 

Has it something to do that when I bought it I was using my Email address ending with: @googlemail.com

Now my account on my Android device is set up with the shorter version: @gmail.com

I think the unlocker fails to realize that these are the same and therefore fails to authenticate. However why it works with version 2 I have no idea. Anyway, is there any way fo fix this or do I now need to buy a new license through the Play Store? 

Share this post


Link to post
Share on other sites
8 hours ago, sztsam said:

Hi

All thing is perfect now except one. 

There is a huge memory leak problem. When you switch music every time, Poweramp consumes ~10mb of ram. After listening or switching few songs it can increase easily to 1 gb!!!  (Redmi note 5 pro 4/64, android 8.1 non rooted oem stable rom)

Thanks

I think that may be the probable reason fr the app crashing after playing 2-3 songs? Dunno just a guess . Ive already a report via mail

Share this post


Link to post
Share on other sites
7 hours ago, djdarko said:

You guys should consider encoding your albums as single file + cue for true gapless. It's a bit of a hassle if you have a lot of albums, but it's worth it.

Of course this is assuming you have the lossless source files to encode from.

Thnx for the tip! I also have a lot of CDs. (2000+) they are all organized in a orderly manner where every track should have its own file. It would be a hell of job to re-encode them. Working with cue files makes them gapless but database wise, search wise, etc. It is not ideal.

Since the silence is added to the MP3 (sort of) the decoder can remove this gapp and with the cut silence feature Poweramp did a pretty decent job on true gapless concept albums and live recordings.

It would be great if Max could bring back this feature

Share this post


Link to post
Share on other sites

@maxmp Please bring back the Per Song EQ preset assignments. I really hate having to pull my phone out my pocket just to change EQ presets. Sometimes I have to like every 4 minutes because I made a lot of presets for specific songs.

Thank you for your hard work, I greatly appreciate it. 

Share this post


Link to post
Share on other sites
59 minutes ago, Mahaan said:

Learn me about professional EQ setting plz

Ok, here are some basics...

1.  Don't just go with the simple cliche-esque smile-shaped EQ curve. And yes, that's what I used to do. Wouldn't doubt that everyone does this at first.
2.  Ideally, you need to find settings that sound good for you. This takes into account the kinds of music you enjoy listening to, and the amplifiers, speakers and headphones you'll be replaying through.  You may end up creating several EQ curve presets, because there may not be one best one if you like a variety of music, or play poorly recorded/mastered source material.
3.  I would use either tone controls, or EQ.  I never use both.  Actually, I never use tone controls.
4.  It's preferable to cut a few db on the EQ sliders, rather than boost.  If there was one frequency you wanted to boost, you could cut the rest to achieve the same effect.

I start with the EQ flat, then play a looping sine wave sample who's frequency rises and falls, covering the whole audible spectrum. Listen for frequencies that are exaggerated or shallow, and cut/boost the frequencies until the rising/falling sine wave sounds flat, without peaks or dips in energy.

I will then play a variety of music, and make small adjustments until I get the best overall sound.

One thing... There is something called ear fatigue.  If you spend a long time playing music and playing around with the EQ controls, you will eventually become oblivious to how bad the sound has truly become.  You will often notice after giving your ears time to relax, like after a good sleep.

Share this post


Link to post
Share on other sites
22 minutes ago, Mahaan said:

Hi guys,

What's the best EQ setting? 

Bass and treble?

Or other EQ setting?

 

Screenshot_20180902-094331.png

 

21 minutes ago, Mahaan said:

Learn me about professional EQ setting plz

Depends what genre of music and (usually) to a lesser degree what headphones/speakers you're using.

Also with Poweramp it's hard to say because it doesn't display thte exact decibels for each band. Unless import someone else's settings, reproducing others' presets will be more appropriate than exact. That can be a huge difference in sound as the sliders can be quite sensitive (which is good), in my opinion.

Share this post


Link to post
Share on other sites

Dear @maxmp,

Thank you for keeping the project alive and making it back on track. I've been exploring the new player and I found its pretty stable. But there are a few bugs that I would like to address.

1. When Hi-res output is enabled, the off screen gestures on OnePlus devices doesn't work. 

2. If I press an alphabet in All Songs menu to directly jump to that Position and when I press return to top button, it shows the last alphabet to which i navigated. Please find the screenshots below

Screenshot_20180902-121129.jpg

Share this post


Link to post
Share on other sites

gestures on oneplus work, sorting files in the library works fine, Max fixed it. I generally think that this is most likely a RC version.

Share this post


Link to post
Share on other sites
On 8/31/2018 at 6:52 PM, MortTheBeast said:

@maxmp Just sent a crash report. First real problem encountered. Using the new 795 on an S8+... I hit the Search option, type a couple letters and then hit the 3 dots, then hit List Options and it crashes every single time.

Deleted 793 and fresh install of 795 and still the problems persists. Crash after crash attempting List Options. Not only that, but I just noticed if I just bring up the Search, hit the 3 dots to open the menu for the List Options... but not actually press it and just back out, it also crashes. Dangit.

Share this post


Link to post
Share on other sites

I've just added build 795 (and 792 for completeness) to the Test section of the Downloads tab at the top of the page to make it easier to find and download for new users. The files are the same as the ones in the forum posts though.

Andre

Share this post


Link to post
Share on other sites

@maxmp Thank you very much for the new update! Especially thank you for fixing sorting and for adding compact list for songs. Is there possibility to add such list for folders, albums, etc? Also, there is still a bug with displaying "play"-"pause" button in notification which I was stated in v.790 and v.792 topics:

On 8/29/2018 at 8:19 AM, Liza V said:

@maxmp thank you for the update and your hard work! This version is beautiful but it has some bugs you know (sorting, etc) and one minor but annoying bug from v.790: if you pause music in notification (this will change two images: Poweramp icon in notification from playing to paused and "pause" button in notification to "play") and press on "next" or "previous" buttons in notification, the music still be paused but "play" button in notification will change it's image back to "pause" button but continue to work as "play" (if you press it, music will start). Sometimes it leads to misunderstanding. Fix it please

Also, I suddenly found a new very strange bug which appears only in .m3u8 plaulists (they were created in Poweramp, exported and imported). How to repeat this bug: play any song in .m3u8 playlist, pause the music, close Poweramp, wait for a few seconds, open it again, open playlist you played, choose any other song - Poweramp will open first song in playlist and every time you tap any other song, the first song will be played untill you start music from any other list. If you continue to listen to music after opening Poweramp, it will play the music as it has to play and you can change the song using "next" or "previous" buttons or getures, but once you choose other song from this playlist, the bug will appear. Is there any way to fix it?

P.S. My English isn't very good, I can explain this bugs in Russian much better, but it's English forum after all.

Share this post


Link to post
Share on other sites

Hello. I bought Poweramp a few years ago, and i'm using the beta for some time. I hope I'm posting this on the right section. I'm facing a problem with the widget not showing the current song. This started to occur after the latest update a few days ago. 

2hplvsw.png

Share this post


Link to post
Share on other sites
15 hours ago, maxmp said:

Per song preset assignment is disabled due to new audio engine. New audio engine always does crossfading / fading and other smoothing over audio, but changing equalizer preset during such crossfades has several issues:

- clicks / pops when preset differs esp. in basses
- there is no defined start of song or end of song during crossfade, so presset applying always sounds weird in this case

Also per song eq management was complicated and had own issues as well - you can't directly see what songs have presets assigned causing sudden preset changes.

Please make it possible to lock an EQ setting to an Album or Playlist, as many albums require altering the sound for optimal listening.

This should not lead to problems, e.g. if the locked sound has to be altered, it must first be unlocked and possible locked again.

Share this post


Link to post
Share on other sites
3 hours ago, Mahaan said:

Hi guys,

What's the best EQ setting? 

Bass and treble?

Or other EQ setting?

 

Screenshot_20180902-094331.png

The best setting is to turn it all off and let it be natural.

Share this post


Link to post
Share on other sites
26 minutes ago, MTK said:

The best setting is to turn it all off and let it be natural.

In a perfect world I'd agree, flat is generally best. However an EQ can be used to compensate for inadequacies in the output equipment (speakers, headphones) and varying room acoustics.

Andre

Share this post


Link to post
Share on other sites

First of all Thanks to @maxmp for great sounding player. 

I also use Poweramp on my Android TV box. For navigation I use bluetooth mouse. Everything is working fine, only the problem I have got is I cannot browse through my Library via mouse's scroll, I have to click and drag the mouse to go up/down in the list. Mouse's scroll was working well in alpha version. I can use the mouse to scroll through menu options, it is NOT working ONLY in LIBRARY menu. 

Any setting I am missing or is it a bug? 

Please let me know about this. 

Thanks in advance 

 

Share this post


Link to post
Share on other sites
On 9/1/2018 at 11:06 AM, Prosenjit said:

 

1. Skin SDK is out so it's up to third party skin developers

2. Reinstall Poweramp & check 795 working flawlessly on my phone

If still not solved then downgrade from here

 

Thanks. Problem solved. ?

 

Share this post


Link to post
Share on other sites
7 hours ago, fyourself said:

 

Depends what genre of music and (usually) to a lesser degree what headphones/speakers you're using.

Also with Poweramp it's hard to say because it doesn't display thte exact decibels for each band. Unless import someone else's settings, reproducing others' presets will be more appropriate than exact. That can be a huge difference in sound as the sliders can be quite sensitive (which is good), in my opinion.

Yeah, i prefer Bass & Trebles.

Share this post


Link to post
Share on other sites

For Forum members into Playlists, I have just released a new version of New Playlist Manager which now allows you to create playlists for Poweramp. No more exporting to .m3u is required. In addition, you can add tracks and/or playlists to the queue, easily rate your songs from library, playlist or single track views, launch play directly.

ps. it will work with v795 (and future releases)

Thanks to Max for provising the latest API.

Share this post


Link to post
Share on other sites
5 hours ago, Liza V said:

@maxmp Thank you very much for the new update! Especially thank you for fixing sorting and for adding compact list for songs. Is there possibility to add such list for folders, albums, etc? Also, there is still a bug with displaying "play"-"pause" button in notification which I was stated in v.790 and v.792 topics:

Also, I suddenly found a new very strange bug which appears only in .m3u8 plaulists (they were created in Poweramp, exported and imported). How to repeat this bug: play any song in .m3u8 playlist, pause the music, close Poweramp, wait for a few seconds, open it again, open playlist you played, choose any other song - Poweramp will open first song in playlist and every time you tap any other song, the first song will be played untill you start music from any other list. If you continue to listen to music after opening Poweramp, it will play the music as it has to play and you can change the song using "next" or "previous" buttons or getures, but once you choose other song from this playlist, the bug will appear. Is there any way to fix it?

P.S. My English isn't very good, I can explain this bugs in Russian much better, but it's English forum after all.

I had this problem yesterday too. Mine was a regular .m3u.

Sony Xperia Z5 Compact

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×