Jump to content
Poweramp
Phrosh

Poweramp for Android Auto

Recommended Posts

11 minutes ago, fatal said:

I've just downgraded to 790 but will test it tomorrow. :)

 

Does the plugin resets the media volume on purpose (or use it's own media volume)? It's not bothering me at all, just found out that even if I pull down media volume on the phone, the next time I start auto the music is loud. I was just surprised because I was testing at home and it's late here :D

Haha, nevermind :D . We'll find someone with 797 soon enough, I guess ;) .

Yes, this is done on purpose - so you don't have to bother with the "internal" phone volume when e.g. your music was quiet before, you turn up the master volume and suddenly your navigation shouts in your face :D .
It's set to 75% (to prevent distortion by overdrive) and the original volume should be restored when you quit AndroidAuto.

Share this post


Link to post
Share on other sites
5 minutes ago, Phrosh said:

Haha, nevermind :D . We'll find someone with 797 soon enough, I guess ;) .

Yes, this is done on purpose - so you don't have to bother with the "internal" phone volume when e.g. your music was quiet before, you turn up the master volume and suddenly your navigation shouts in your face :D .
It's set to 75% (to prevent distortion by overdrive) and the original volume should be restored when you quit AndroidAuto.

It's restored, that's why it's not bothering me at all. Thanks :)

Share this post


Link to post
Share on other sites

Regarding the volume, this has been bugging the hell out of me! I have a Tasker profile that sets media volume to max when in the car, and I couldn't figure why it had stopped working! Now I know... 

Any chance you could make the volume reduction optional? Not a massive deal, but would be appreciated by me at least. 

Share this post


Link to post
Share on other sites

@Phrosh i now have implemented all functionalty to my app New pPaylist Manager so you can manage all your playlist needs. I now only support Poweramp v795 and above as trying to cover older versions became messy. Let me know if i can help in any way.

Share this post


Link to post
Share on other sites
2 hours ago, flyingdutchman said:

I now only support Poweramp v795 and above as trying to cover older versions became messy. 

While I fully understand your logic, I'm wondering if quite a number of users might want to use your app when migrating from PA v2 to v3?

Would it be possible to leave in enough legacy v2 code to just backup playlists, ratings, etc from a v2 setup into your own system, allowing them to be written back out and edited/etc for v3 users?  

Andre

Share this post


Link to post
Share on other sites

@andre, good idea, i will think about this. Perhaps Poweramp users can register their interest either on this forum or by emailng me.

Trouble will be though that users will probably update to the new version of Poweramp first and realise they have lost their ratings. It will be too late by then. 

What i will do is release the free version which will allow Poweramp ratings export. It will be by the end of next week though

Share this post


Link to post
Share on other sites

Hello, 

How do I uninstall this?  It plays music randomly.  Woke me up at 3 am and just blared music at my desk at work.  lol

Or better yet how can I stop the random startup?

Share this post


Link to post
Share on other sites
2 hours ago, v64 said:

Hello, 

How do I uninstall this?  It plays music randomly.  Woke me up at 3 am and just blared music at my desk at work.  lol

Or better yet how can I stop the random startup?

I don't have this issue, but you can uninstall just like a regular app, from the Settings.

Share this post


Link to post
Share on other sites
On 9/26/2018 at 9:42 AM, fishyweb said:

Regarding the volume, this has been bugging the hell out of me! I have a Tasker profile that sets media volume to max when in the car, and I couldn't figure why it had stopped working! Now I know... 

Any chance you could make the volume reduction optional? Not a massive deal, but would be appreciated by me at least. 

Again, this would force the app to appear in the app drawer. You might set a tasker profile to the launch of PowerampAuto itself and change the volume back to 100%. Just the first quick fix that came into my mind :D .

The only reason, I decided not to use max volume is that Google Maps / TTS voice was distorted when I used maximum media volume. I thought this might have an impact on other devices / cars as well.

 

On 9/26/2018 at 4:02 PM, v64 said:

Hello, 

How do I uninstall this?  It plays music randomly.  Woke me up at 3 am and just blared music at my desk at work.  lol

Or better yet how can I stop the random startup?

My app only operates within Android Auto and thus can not randomly start itself.

Maybe your Android Auto starts in the middle of the night? Does someone use your car and your phone detects the BT radio and starts Android Auto?
If someone uses your car without your knowledge, you got some other problems than starting music at work :P .

Share this post


Link to post
Share on other sites
9 hours ago, Phrosh said:

Again, this would force the app to appear in the app drawer. You might set a tasker profile to the launch of PowerampAuto itself and change the volume back to 100%. Just the first quick fix that came into my mind :D .

The only reason, I decided not to use max volume is that Google Maps / TTS voice was distorted when I used maximum media volume. I thought this might have an impact on other devices / cars as well

Thanks for the suggestion, but sadly Tasker doesn't offer PowerampAuto in its list of apps. I'd give that a go otherwise. 

I guess I'm fortunate to have a phone and car combination where max volume is fine, no distortion at all ?

Quick question for you - I wanted to assign an equaliser profile for use with AA. I assumed the appropriate output device for this would have been the USB DAC, but it seems to only work if I assign the profile to Bluetooth,which seems a bit strange seeing as it's playing via a USB cable. Any ideas about that? 

Share this post


Link to post
Share on other sites
16 hours ago, bettsaj said:

Does this mean Poweramp will run on a normal Android 8 head unit??

It should do, yes, but it's hard to be certain. Don't forget the licence key requires an internet connection.

There may be issues with steering wheel remote buttons though, as they depend on how the manufacturer has designed and connected them.

Andre

Share this post


Link to post
Share on other sites
On 7/25/2018 at 8:01 PM, Phrosh said:

This is a bridge to enable support for Poweramp in Android Auto.

To make Poweramp visible in Android Auto you need to enter the developer settings in Android Auto and enable "unknown sources":
https://9to5google.com/2018/01/12/how-to-enable-android-auto-developer-settings-android-basics

Please enable "Alyways Process Album Art" in the Poweramp Settings > Album Cover (feature of Poweramp v3) to ensure the correct album art is shown when the device is in sleep mode.

Key features:
- Playback control (no sh*t, Sherlock)
- Display album art
- Repeat and shuffle mode
- Access playlists from the menu
- Notifications on title change

If you like to give me a cookie or two, here is a link :)
https://paypal.me/phrosh

 

Download 1.0.2 ]

funk2.jpg

I have tested this bridging app and while it works there are a couple of quirks I have discovered.
The first issue is that once you install this app it prevents you from selecting alternative music apps that is available on Android Auto. For example if you select Deezer it will present the Poweramp Auto app instead.
The second issue is that the Poweramp Auto app disconnects the bluetooth audio after a few seconds of stopping play. Before this I use to be able to play a music app then hit stop and the audio would still continue to function if I manually ran an app on my phone that outputs audio such as a stream.
Only when I uninstall Poweramp Auto do both of these issues disappear. 

Share this post


Link to post
Share on other sites
On 7/25/2018 at 3:01 AM, Phrosh said:

This is a bridge to enable support for Poweramp in Android Auto.

To make Poweramp visible in Android Auto you need to enter the developer settings in Android Auto and enable "unknown sources":
https://9to5google.com/2018/01/12/how-to-enable-android-auto-developer-settings-android-basics

Please enable "Alyways Process Album Art" in the Poweramp Settings > Album Cover (feature of Poweramp v3) to ensure the correct album art is shown when the device is in sleep mode.

Key features:
- Playback control (no sh*t, Sherlock)
- Display album art
- Repeat and shuffle mode
- Access playlists from the menu
- Notifications on title change

If you like to give me a cookie or two, here is a link :)
https://paypal.me/phrosh

 

Download 1.0.2 ]

funk2.jpg

Please help. I can't even find the developer setting in android auto and there's no such option to enable album cover art in Poweramp. This is very confusing. 

Also, when I installed the apk you included, it did nothing. It did install successfully, but nothing happened.

Share this post


Link to post
Share on other sites
On 10/25/2018 at 3:50 PM, Pointro said:

I can't get this to work. I'm on v802. I've also had the issue with it playing music randomly. 

Just saw your comment. Apparently this topic was abandoned. Disappointed.

Share this post


Link to post
Share on other sites
On 10/26/2018 at 12:50 AM, Pointro said:

I can't get this to work. I'm on v802. I've also had the issue with it playing music randomly. 

Try using Poweramp 79x

On 11/12/2018 at 11:58 PM, pump_up_pete said:

I have tested this bridging app and while it works there are a couple of quirks I have discovered.
The first issue is that once you install this app it prevents you from selecting alternative music apps that is available on Android Auto. For example if you select Deezer it will present the Poweramp Auto app instead.
The second issue is that the Poweramp Auto app disconnects the bluetooth audio after a few seconds of stopping play. Before this I use to be able to play a music app then hit stop and the audio would still continue to function if I manually ran an app on my phone that outputs audio such as a stream.
Only when I uninstall Poweramp Auto do both of these issues disappear. 

When you are in the music section of AA, tap on the music icon again and you can re-select your music app. This is general AA behavior. 

I stop the music when AA quits, but I don't disconnect BT or anything like that. As far as I know, I don't even use BT permissions. I can't tell why you have these problems, sorry. 

2 hours ago, Lucas27 said:

Please help. I can't even find the developer setting in android auto and there's no such option to enable album cover art in Poweramp. This is very confusing. 

Also, when I installed the apk you included, it did nothing. It did install successfully, but nothing happened.

When the dev options and unknown sources are not enabled, nothing will change. Use Google. 

2 hours ago, Lucas27 said:

Just saw your comment. Apparently this topic was abandoned. Disappointed.

To log in to this forum, I ALWAYS have to trigger the "forgot password" function, so I don't always have the time to answer everything right away. 

Merry Christmas 

Share this post


Link to post
Share on other sites

Hi I'm using Poweramp v3 build 814. 

Installed Poweramp auto Bridge app.

Enabled developer support in Android Auto and unkown sources.  

Rooted device unlocked Android auto apps.

Now whenever Android auto starts Poweramp auto stopping and even clicked music it's keep loading.

Enclosed error screenshot's.

 

Screenshot_20181225-200127.png

Screenshot_20181225-200029.png

Screenshot_20181225-200202.png

Share this post


Link to post
Share on other sites
On 12/25/2018 at 12:19 AM, Phrosh said:

To log in to this forum, I ALWAYS have to trigger the "forgot password" function

Use your username not your email address to login. If that does not work, PM me and I'll reset your account password for you.

Andre

Share this post


Link to post
Share on other sites

Hi Andre. Is there a good reason why Poweramp v3 doesn't work with the various Android Auto bridge apps out there? 

Also, I think I saw it said that Max would be working on AA support once v3 was complete. Any guidance on when this will be ready? 

Thanks. 

Share this post


Link to post
Share on other sites
3 hours ago, fishyweb said:

Hi Andre. Is there a good reason why Poweramp v3 doesn't work with the various Android Auto bridge apps out there? 

Also, I think I saw it said that Max would be working on AA support once v3 was complete. Any guidance on when this will be ready? 

I don't know on either score I'm afraid. It is on Max's to-do list, but I don't know how far down.

Andre

Share this post


Link to post
Share on other sites

 

On 12/25/2018 at 3:37 PM, robe said:

Hi I'm using Poweramp v3 build 814. 

Installed Poweramp auto Bridge app.

Enabled developer support in Android Auto and unkown sources.  

Rooted device unlocked Android auto apps.

Now whenever Android auto starts Poweramp auto stopping and even clicked music it's keep loading.

Enclosed error screenshot's.

 

Try to use build 70x (Okay, I should put this in the initial post by now... :D) 

14 hours ago, andrewilley said:

Use your username not your email address to login. If that does not work, PM me and I'll reset your account password for you.

Andre

Wow, this just worked. Big thx :)

Share this post


Link to post
Share on other sites
3 hours ago, Phrosh said:

 

Try to use build 70x (Okay, I should put this in the initial post by now... :D) 

Wow, this just worked. Big thx :)

Thanks for your Input. Today Max updated PAmp V3 Build 815 but no AA support. Hope he is working on to it.

Meanwhile as @Phrosh said I tried PA Alpha Build 709

https://www.apkmirror.com/apk/max-mp/Poweramp/Poweramp-alpha-build-709-play-release/Poweramp-music-player-alpha-build-709-play-android-apk-download/download/

It works like a charm but can't pause audio.😜

Thanks @Phrosh

Share this post


Link to post
Share on other sites
On 12/25/2018 at 1:19 AM, Phrosh said:

To log in to this forum, I ALWAYS have to trigger the "forgot password" function, so I don't always have the time to answer everything right away. 

I had the same problem. I solved it by giving my username, not my email address in the login.

Share this post


Link to post
Share on other sites
11 minutes ago, blaubär said:

I had the same problem. I solved it by giving my username, not my email address in the login.

I can also reset your account password centrally, which then seems to allow login either way. PM me if you want me to do this.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...