Jump to content
Poweramp
danhash

Fade-in at beginning of track (still present in alpha-709 build)

Recommended Posts

When I start a track, the first ~half second doesn't play due to a fade-in. I have many songs that start immediately with a drum hit or a loud note, but Poweramp has an aggressive fade-in at the beginning of a track (even the fade/cross-fade settings disabled), so the very first part of the track is missed. (I reported this for v2 here and was asked to test it on alpha.)

On the Audio -> Crossfade and Fade screen, there are two relevant options:

  • Fade play/pause/stop - This is off
  • Play/pause/stop fade length - This cannot be set to zero

Even Fade play/pause/stop disabled, the fade length setting is still honored. I can improve the situation by changing the length to 50 ms, but this value cannot be set to zero.

A good way to illustrate this is to set the fade length setting to 1000ms and then play a track that is immediately loud; you will hear the very noticeable fade in, even with Fade play/pause/stop disabled.

Seems like the fix for this would be to honor the Fade play/pause/stop setting and/or allow the fade length value to be set to 0.

 

I have purchased the full version, but this setting is so important to me I'd be happy to donate extra $$ to see it resolved :)

Versions:
alpha-build-709-play (Full Version)
Samsung Galaxy S7
Android version 8.0.0

Share this post


Link to post
Share on other sites

Replied on that post. None of the settings mentioned in that post are relevant, and I also already had them set the way you suggest.

Share this post


Link to post
Share on other sites
On 7/19/2018 at 3:08 PM, danhash said:

When I start a track, the first ~half second doesn't play due to a fade-in.

Check out the new version 792, I tested "An Autopsy" by Faceless several times, seems to place correctly now.

Share this post


Link to post
Share on other sites

@djdarko,

Just installed 792 and playing with it. So far, Last.fm scrobbling isn't working, I can't disable swiping to change tracks, and there doesn't seem to be a normal seekbar. Even if the fade is fixed, all three of these issues are dealbreakers for me, so I may have to switch back to the last stable version. I'll still test fade before switching back though. Thanks.

 

Share this post


Link to post
Share on other sites

I just tested the fade-in again with In Your Words by Lamb of God, and the problem isn't even close to fixed. If I start on the previous track and hit next track, there's a fade-in. Also, if a different track is playing and I tap on the track to play it, there's a fade-in. Poweramp is simply not honoring the settings, still.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...