Jump to content
Poweramp
danhash

Fade-in at beginning of track

Recommended Posts

When I start a track, the first ~half second doesn't play due to a fade-in. I have many songs that start immediately with a drum hit or a loud note, but Poweramp has an aggressive fade-in at the beginning of a track (even with all fade/cross-fade settings disabled), so the very first part of the track is missed.

Versions:
2.0.10-build-588-play (Full Version)
Samsung Galaxy S7
Android version 8.0.0

Share this post


Link to post
Share on other sites

Try the test build of Poweramp v3 (build 709) and see if you get the same problem there, it's not something I've ever noticed anyway (well, as long as all the crossfade options are off).

Andre

Share this post


Link to post
Share on other sites

I just tested build 709, and it still has the problem. Here are more details:

On the Audio -> Crossfade and Fade screen, there are two relevant options:

  1. Fade play/pause/stop - This is off
  2. Play/pause/stop fade length - This cannot be set to zero

Even "Fade play/pause/stop" disabled, the "fade length" setting is still honored. I can improve the situation by changing the length to 50 ms, but this value cannot be set to zero.

A good way to illustrate this is to set the "fade length" setting to 1000ms and then play a track that is immediately loud; you will hear the very noticeable fade in.

Seems like the fix for this would be for the "Fade play/pause/stop" setting to be honored instead of ignored.

Share this post


Link to post
Share on other sites

@andrewilley,

Since I'm seeing the same issue on v3 alpha, I posted to the alpha forum here: 

It seems that the settings are slightly different, so on the alpha forum I gave details specific to the alpha release.

Share this post


Link to post
Share on other sites

Roll back to build 588 (build 709 definitely has fading issues)

Are you overlooking the top two options?

Auto-advance Fading: No fading

Manual Track Change Fading: No fading

Crossfade Length: This should have no effect with the fading options disabled.

Fade play/pause/stop: Off

Fade on seek: Off

Cut Silence: This should have no impact on the fading.

These are my own settings:

Screenshot_2018-07-19-21-47-48.thumb.png.6eab9ac30b57c610b210aa33ea22f7c9.png

Share this post


Link to post
Share on other sites
41 minutes ago, andrewilley said:

The OP did say "even with all fade/cross-fade settings disabled" so I assume he's tried the above.

Andre

True, but he goes on to say that there are only two relevant options, and never mentioned the top two in any of his posts.

11 hours ago, danhash said:

I just tested build 709, and it still has the problem. Here are more details:

On the Audio -> Crossfade and Fade screen, there are two relevant options:

  1. Fade play/pause/stop - This is off
  2. Play/pause/stop fade length - This cannot be set to zero

Even "Fade play/pause/stop" disabled, the "fade length" setting is still honored. I can improve the situation by changing the length to 50 ms, but this value cannot be set to zero.

A good way to illustrate this is to set the "fade length" setting to 1000ms and then play a track that is immediately loud; you will hear the very noticeable fade in.

Seems like the fix for this would be for the "Fade play/pause/stop" setting to be honored instead of ignored.

On a side note, I tested build 709 and definitely ran into the problem he was having, I would suggest to roll back to build 588.

Share this post


Link to post
Share on other sites

@djdarko,

The reason I didn't mention these settings is that they aren't relevant to fading at the very beginning of a track when I tap it to play. I had each of those settings set to the values you mentioned, but "crossfade length" and "fade on seek", for example, aren't relevant here.

Share this post


Link to post
Share on other sites
1 hour ago, danhash said:

@djdarko,

The reason I didn't mention these settings is that they aren't relevant to fading at the very beginning of a track when I tap it to play. I had each of those settings set to the values you mentioned, but "crossfade length" and "fade on seek", for example, aren't relevant here.

"Manual Track Change Fading" is definitely relevant, unless you are only "tapping to play" while the player is paused. If build 588 doesn't work correctly with all of the settings mentioned, it's most likely a bug in relation to your phone, I'm on Android 8.1.0 here and it's working correctly with absolutely no fading.  You should go back to build 588, double check the settings one last time before giving up on it.

Share this post


Link to post
Share on other sites

Yes I am primarily tapping to play while the player is paused. This has been an issue with my Galaxy S7 since at least Android 7.x, and I have checked and rechecked the fade settings many times. Here are detailed steps to reproduce the issue:

  1. Ensure no music is playing
  2. Navigate in the media library to a song that is immediately loud (such as An Autopsy by The Faceless or In Your Words by Lamb of God)
  3. Tap the song to play it

Are you following these exact steps?

Based on your advice, I left the Beta program on Google Play. It can take a while for the non-Beta version to become available again but I will recheck the settings you mentioned and report back.

Share this post


Link to post
Share on other sites

I double-checked all the settings you mentioned and set them exactly according to your recommendation. There's still a fade-in at the beginning of the track.

 

 

Screenshot_20180720-110506_Poweramp.jpg

Share this post


Link to post
Share on other sites
1 hour ago, danhash said:

I double-checked all the settings you mentioned and set them exactly according to your recommendation. There's still a fade-in at the beginning of the track.

You're right, I tested it with the song "An Autopsy", for me it's not consistent, it seems to do it either random, or based on the timing of pressing play button after selecting the track.

On another note, if you have "-->" advance list mode set it does the same thing when playing from the end of the previous album.

I'll do some more testing, if I find anything out, I'll bump the thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×