Jump to content
Poweramp
maxmp

Poweramp alpha build-709

Recommended Posts

@maxmp Finally, an update that was actually needed! Thanks! Works well on the V30.

Could you please consider adding an option for automatic bit depth and no resampling at all? That is, the file is passed "as is" to the DAC, bit perfect, at original bit depth and sampling frequency? 

Share this post


Link to post
Share on other sites

The only hi-res output option I am getting is direct HD and not opensl HD on my V30 with Android Oreo. I know that they are likely equivalent except for opensl HD having 32 bit float sample format but I am just curious as to why this is happening. Max said that opensl HD is supported on the V30 so I don't get why the option is not present. I also have a feature request, can you add the ability to have Poweramp follow the sample rate of music that is currently playing, it is annoying to keep having to change it manually.

Share this post


Link to post
Share on other sites

My Hi-Res Output 24bit not working! 

It's playing only 16-bit 192khz. How to enable 24-bit?

Poweramp alpha v705

Redmi Note 3 (kenzo) Nitrogen OS 7.1.2

Snapdragon 650 SOC

 

Screenshot_20180604-124234~3.png

Screenshot_20180604-124541~3.png

Share this post


Link to post
Share on other sites
28 minutes ago, Ajendrasinh said:

It's playing only 16-bit 192khz. How to enable 24-bit?

Poweramp alpha v705

Redmi Note 3 (kenzo) Nitrogen OS 7.1.2

 

Try 709 rather than 705. It may be that High-Res output (as opposed to internal processing in PA) isn't happening at all with your ROM.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Try 709 rather than 705. It may be that High-Res output (as opposed to internal processing in PA) isn't happening at all with your ROM.

Andre

It has also changed the build.prop, the line lenovo hi-fi has been added directing the audio stream in deep_buffer.

 

2 hours ago, Ajendrasinh said:

My Hi-Res Output 24bit not working! 

It's playing only 16-bit 192khz. How to enable 24-bit?

 

 

 

Deep_buffer has a limit of 16-bit, as well as your mp3 file 16-bit.😂

Share this post


Link to post
Share on other sites
1 minute ago, Seve-s said:

It has also changed the build.prop, the line lenovo hi-fi has been added directing the audio stream in deep_buffer.

 

Deep_buffer has a limit of 16-bit, as well as your mp3 file 16-bit.😂

So,.how other people are using 24bit 192khz audio in PA? I also tried playing 24bit 192khz hi-res Audio file, but no change! 

Please give me a solution... 

Share this post


Link to post
Share on other sites
37 minutes ago, Ajendra25 said:

Please give me a solution.

 

40 minutes ago, Seve-s said:

build.prop, the line lenovo hi-fi

Remove the lines of the lenovo hifi from the build.prop file.

Share this post


Link to post
Share on other sites
2 hours ago, Seve-s said:

 

Remove the lines of the lenovo hifi from the build.prop file.

Thanks for reply buddy.

I haven't added lenovo hifi to build.prop, No line is there!

I'm using Arise sound mod. That may be the reason!

Share this post


Link to post
Share on other sites
22 minutes ago, Seve-s said:

OMG! Arise is a big, huge, great trash can.😵

I've also tasted Poweramp 704 without Arise a long time ago. It was throwing error "Failed to load Hi-res audio". 

Now, I'm able to use 705 & 709 versions, but it loads just 16bit. :(

 

 

Share this post


Link to post
Share on other sites
17 minutes ago, Ajendra25 said:

but it loads just 16bit. :(

you need to fix system / build.prop.
  Delete the strings ro.lenovo.hifi_support = true.

Share this post


Link to post
Share on other sites

As build 709 is part of the feature-complete alpha releases and suitable for daily testing, I've added it to the Downloads tab here too (there were some technical issues which were preventing that, which now seem to be resolved).

Andre

Share this post


Link to post
Share on other sites
2 hours ago, Seve-s said:

you need to fix system / build.prop.
  Delete the strings ro.lenovo.hifi_support = true.

Already checked! No string available there in build.prop 

That's what I'm thinking about.. how it detects Lenovo HI-FI !!! 

Share this post


Link to post
Share on other sites
10 hours ago, andrewilley said:

Try 709 rather than 705. It may be that High-Res output (as opposed to internal processing in PA) isn't happening at all with your ROM.

Andre

Currently using 709! But same, it's just processing 16bit PCM

What should I do to enable 24 bit? :(

Share this post


Link to post
Share on other sites
1 hour ago, Ajendra25 said:

No string available there in build.prop 

You should search where Arisesound_setprop files are.

Share this post


Link to post
Share on other sites
1 hour ago, Seve-s said:

You should search where Arisesound_setprop files are.

Thank you very much bro. Finally found that string in Arisesound_setprop.

But, it's still processing just 16bit using Direct HD Hi-Res Output.

Screenshot_20180605-020726~3.png

Screenshot_20180605-020711~2.png

Share this post


Link to post
Share on other sites

@Ajendra25 Which device are you using and which custom rom? Are you using a kenzo running an oreo rom? (If you are, go and check the audiophile discussion thread on xda. The only working combo I can think of is NOS O+latest alpha build of PA)

Share this post


Link to post
Share on other sites
16 hours ago, Ajendra25 said:

My Hi-Res Output 24bit not working! 

It's playing only 16-bit 192khz. How to enable 24-bit?

Poweramp alpha v705

Redmi Note 3 (kenzo) Nitrogen OS 7.1.2

Snapdragon 650 SOC

I don't think this ROM supports Hi-Res properly, or at least Poweramp (any build) supports this weird ROM (lenovo hi-fi variant on Xiaomi device? messed/mixed up build props, configs, and libraries?)

Even some ROM displays some "hi-res" numbers (24+ bits, 96+khz), it should be verified by capturing audio, as SOC still can force this back to 48khz.

Stock Xiaomis on Snapdragon 6xx series support Hi-Res in Poweramp just fine. 

Share this post


Link to post
Share on other sites
4 hours ago, Ajendra25 said:

But, it's still processing just 16bit using Direct HD Hi-Res Output.

I see that there is now a forced audio output 16/48, this is a highly likely primary output.
  This is A.R.I.S.E. !!!

This player can OpenSL HD?

Share this post


Link to post
Share on other sites
4 hours ago, maxmp said:

I don't think this ROM supports Hi-Res properly, or at least Poweramp (any build) supports this weird ROM (lenovo hi-fi variant on Xiaomi device? messed/mixed up build props, configs, and libraries?)

Even some ROM displays some "hi-res" numbers (24+ bits, 96+khz), it should be verified by capturing audio, as SOC still can force this back to 48khz.

Stock Xiaomis on Snapdragon 6xx series support Hi-Res in Poweramp just fine. 

Thanks for reply.

It was showing Lenovo hi-fi because I've Installed A.R.I.S.E sound mode! Now, I have removed that. 

Still, it's processing Direct HD hi-fi 16 bit. :(

 

Screenshot_20180605-020726~3.png

Screenshot_20180605-020711~2.png

Share this post


Link to post
Share on other sites
3 hours ago, Seve-s said:

I see that there is now a forced audio output 16/48, this is a highly likely primary output.
  This is A.R.I.S.E. !!!

This player can OpenSL HD?

Means what should I do now?

In, PA Beta 790 (New UI), Open SL HD working perfectly. 

But, Hi-res audio not working! It's automatically switches to Open SL, when enabling Hi-res audio output.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×