Jump to content
Poweramp
maxmp

Poweramp alpha build-709

Recommended Posts

 

 

21 hours ago, Evan_989 said:

I do get the same thing on my HTC U Ultra, it doesn't appear as Snapdragon 24-bit PCM which can overrides my USonic. Any solution max ?

I use my usonic headphones with hi res and it says 24bit and i can adjust sample frequency 44-384khz, it does seem to disable the usonic audio profile but i dont mind because it sounds much better in hi res audio mode audio output. I think i remember reading that you can only have one or the other because the hi res overides the audio path for usonic audio noise cancelling.

 But yeah still wondering if we can get a fix for Bluetooth using speakerphone output.

Share this post


Link to post
Share on other sites

Sorry about the above "message" apparently moving car is not optimal place to try and make forum posts. 

But anyway my issue is that for some reason on my Nokia 8 with 8.1 oreo double clicking on the hf button works fine when I'm using the phone and the screen is on. 

 

However soon as the screen goes completely off Poweramp starts to skip into the next album instead of the next song. 

This makes it almost impossible to use, thus making the whole app useless. 

I have checked the battery optimization options and that didn't have any effect on the Poweramp at all. 

What options should I try to get it fixed. 

I'm currently using the 709 alpha version of the app. 

Share this post


Link to post
Share on other sites

I just noticed that the app responds to the hf buttons differently depending if the screen is on or off. 

Basically when the screen is on and the phone is on use, it goes to the next song no matter how fast you double press the button. 

However if the screen is off I have to do slow double click (basically 0,2 seconds apart) otherwise it will skip to the next album. 

If this is intentional feature on your part, then may I suggest that you make it optional. The current way makes accidental album skipping too easy to happen. 

I personally rather take my phone out of the pocket and then change the playing album, but I can see that it is option that someone may find useful. 

That's why I am hoping to see it as a option, rather than just a forced "feature" 

Share this post


Link to post
Share on other sites

First of all sorry for the frequent replies to this thread, but I found out what was causing the problem. 

It was that option under the headset settings on Poweramp. 

It was on the double /triple press option. 

Was it naive for me to assume that when I wanted the double click to next song feature to work, naturally I would select double click option. 

When I selected the single press (fast) option, there is no longer issues when I double click on the hf button when the screen is off. 

It goes to the next song like it should. 

 

If this was not a bug, then it would be a good idea to rethink the terms used for these options. 

It was just as confusing in my native language (Finnish), and if guy who has been playing around with different computers for the past 25 years can't understand them. 

Then maybe there is good place to rethink the term of that option. 

Screenshot_20180602-183934.png

Share this post


Link to post
Share on other sites

The amount of clueless people using resampling and claiming to hear better sound just makes me cringe! People, do yourselves favour, turn off any resampling, it actually makes audio worse and puts utterly unnecessary strain on the CPU. Also, unless your files are native 24 bit, leave the setting at 16 bit. I would imagine with so many people chattering about Hi Res in these forums, some would have a clue about how digital audio actually works...

Share this post


Link to post
Share on other sites
44 minutes ago, spacebar2011 said:

The amount of clueless people using resampling and claiming to hear better sound just makes me cringe! People, do yourselves favour, turn off any resampling, it actually makes audio worse and puts utterly unnecessary strain on the CPU. Also, unless your files are native 24 bit, leave the setting at 16 bit. I would imagine with so many people chattering about Hi Res in these forums, some would have a clue about how digital audio actually works...

 The amount of clueless people who believe that they understand digital sound, and sampling, and bit width, for some reason do not know how to watch system files on their smartphone. They can not understand that any modern smartphone can provide digital sound without changes, without undue oversampling, which creates an application of a third-party player.

Share this post


Link to post
Share on other sites

No OpenSl HD output here on my nexus 6...

Anyone know why? I think nexus 6 shamu snapdragon can output high res...

Any help?

Share this post


Link to post
Share on other sites
On 5/16/2018 at 9:04 PM, freedspsp said:

Lenovo X3 user, big thanks for reenable 24bit:D:D:D

Yours x3 works okay with 709?

Share this post


Link to post
Share on other sites
1 hour ago, ringxxx said:

Yours x3 works okay with 709?

No, turbo hi-fi does not work. This on my x3a40 also does not work.

Share this post


Link to post
Share on other sites
On 5/29/2018 at 10:41 AM, kaotic_zeus said:

Great job on the 708/709 max i vastly prefer it to the 790 thats in the works, felt too funky to me. 

The only one problem im having is output device is always set to speaker when using a bluetooth device of any kind. This has been a problem with all verisions, i have a feeling its meant to be intentional.

Device is HTC U11 stock rom android 8.0

Same here ,?

Share this post


Link to post
Share on other sites

@maxmp Finally, an update that was actually needed! Thanks! Works well on the V30.

Could you please consider adding an option for automatic bit depth and no resampling at all? That is, the file is passed "as is" to the DAC, bit perfect, at original bit depth and sampling frequency? 

Share this post


Link to post
Share on other sites
6 hours ago, pyaganti said:

@maxmp @andrewilley @clever_man do we have any link which explains the effects of dithering, Replay_gain and other audio settings? It helps to understand the Noobs like me

Yes, readily available with a simple Google search.

Share this post


Link to post
Share on other sites

The only hi-res output option I am getting is direct HD and not opensl HD on my V30 with Android Oreo. I know that they are likely equivalent except for opensl HD having 32 bit float sample format but I am just curious as to why this is happening. Max said that opensl HD is supported on the V30 so I don't get why the option is not present. I also have a feature request, can you add the ability to have Poweramp follow the sample rate of music that is currently playing, it is annoying to keep having to change it manually.

Share this post


Link to post
Share on other sites

My Hi-Res Output 24bit not working! 

It's playing only 16-bit 192khz. How to enable 24-bit?

Poweramp alpha v705

Redmi Note 3 (kenzo) Nitrogen OS 7.1.2

Snapdragon 650 SOC

 

Screenshot_20180604-124234~3.png

Screenshot_20180604-124541~3.png

Share this post


Link to post
Share on other sites
28 minutes ago, Ajendrasinh said:

It's playing only 16-bit 192khz. How to enable 24-bit?

Poweramp alpha v705

Redmi Note 3 (kenzo) Nitrogen OS 7.1.2

 

Try 709 rather than 705. It may be that High-Res output (as opposed to internal processing in PA) isn't happening at all with your ROM.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Try 709 rather than 705. It may be that High-Res output (as opposed to internal processing in PA) isn't happening at all with your ROM.

Andre

It has also changed the build.prop, the line lenovo hi-fi has been added directing the audio stream in deep_buffer.

 

2 hours ago, Ajendrasinh said:

My Hi-Res Output 24bit not working! 

It's playing only 16-bit 192khz. How to enable 24-bit?

 

 

 

Deep_buffer has a limit of 16-bit, as well as your mp3 file 16-bit.?

Share this post


Link to post
Share on other sites
1 minute ago, Seve-s said:

It has also changed the build.prop, the line lenovo hi-fi has been added directing the audio stream in deep_buffer.

 

Deep_buffer has a limit of 16-bit, as well as your mp3 file 16-bit.?

So,.how other people are using 24bit 192khz audio in PA? I also tried playing 24bit 192khz hi-res Audio file, but no change! 

Please give me a solution... 

Share this post


Link to post
Share on other sites
37 minutes ago, Ajendra25 said:

Please give me a solution.

 

40 minutes ago, Seve-s said:

build.prop, the line lenovo hi-fi

Remove the lines of the lenovo hifi from the build.prop file.

Share this post


Link to post
Share on other sites
2 hours ago, Seve-s said:

 

Remove the lines of the lenovo hifi from the build.prop file.

Thanks for reply buddy.

I haven't added lenovo hifi to build.prop, No line is there!

I'm using Arise sound mod. That may be the reason!

Share this post


Link to post
Share on other sites
1 hour ago, Ajendra25 said:

Arise

OMG! Arise is a big, huge, great trash can.?

Share this post


Link to post
Share on other sites
22 minutes ago, Seve-s said:

OMG! Arise is a big, huge, great trash can.?

I've also tasted Poweramp 704 without Arise a long time ago. It was throwing error "Failed to load Hi-res audio". 

Now, I'm able to use 705 & 709 versions, but it loads just 16bit. :(

 

 

Share this post


Link to post
Share on other sites
17 minutes ago, Ajendra25 said:

but it loads just 16bit. :(

you need to fix system / build.prop.
  Delete the strings ro.lenovo.hifi_support = true.

Share this post


Link to post
Share on other sites

As build 709 is part of the feature-complete alpha releases and suitable for daily testing, I've added it to the Downloads tab here too (there were some technical issues which were preventing that, which now seem to be resolved).

Andre

Share this post


Link to post
Share on other sites
2 hours ago, Seve-s said:

you need to fix system / build.prop.
  Delete the strings ro.lenovo.hifi_support = true.

Already checked! No string available there in build.prop 

That's what I'm thinking about.. how it detects Lenovo HI-FI !!! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×