Jump to content
Poweramp
maxmp

Poweramp alpha build-709

Recommended Posts

Poweramp-alpha-build-709-uni.apk
Poweramp-alpha-build-709-play.apk (no website purchase support, no other functional differences vs. uni version)

Build-709 (Play beta channel release):
https://play.google.com/apps/testing/com.maxmpz.audioplayer

Build-709:
• fixed some dither options causing no audio

Build-707/708:
• Android 4.3/4.4 support restored

Build-706:
Adjusted hi-res output on various devices - big thanks for the community feedback!
• Snapdragon 845 devices (e.g. Sony XZ2) - improved Hi-Res Output detection
• Sony XZ/XZ1 - improved Hi-Res Output detection
• Lenovo X3 - reenabled 24bits
• OnePlus (1st edition) - disabled DVC for Hi-Res output due to forced speaker playback
• added new per-output option - No Duck - for cases when notification causes issues. Activated by default for Hi-Res output for some Snapdragon 625 devices (Asus Zenphone 3)
• HTCs @ 7.0 - improved Hi-Res Output stability
• Nexus 6P - fixed notification coloring

 

 

Share this post


Link to post
Share on other sites

I still don't have any Hi-Res output on Axon 7 (AEX 5.5 + Ainur Sauron) nor do I have any wired headphone option in the OpenSL HD section. Music doesn't play at all as well after messing with the output settings. I've got some screen shots of what it looks like when I play music and the missing settings.

Screenshot_Poweramp_20180516-144116.png

Screenshot_Poweramp_20180516-143948.png

Screenshot_Poweramp_20180516-143939.png

Share this post


Link to post
Share on other sites
3 hours ago, maxmp said:

I'm continuing the beta now :)

This is good news and keep it up.🍻

3 hours ago, maxmp said:

Adjusted hi-res output on various devices - big thanks for the community feedback!

Max would like to know or clarify the situation with the phone Huawei P9. Specifically, this smartphone with Kirin processor is equipped with a sound chip of its own production Huawei, which is capable of playing music in the Hi-Res Audio standard 24 bit 192 kHz. And in Huawei P9 is installed just such a chip.

However, from version to version, setup and playback Hi-Res is only through USB. There is no speaker, no wired headset. What is wrong with this device? 😀

Share this post


Link to post
Share on other sites

I'm going to remove non-relevant comments such as ETA requests, skin questions (yes, but not until closer to v3's official release), etc.

Andre 

Share this post


Link to post
Share on other sites
2 hours ago, Sachin Godara said:

Can i install it over 705?

Yes. But if you do happen to get any issues, clear cache/data or do a clean uninstall/reinstall.

Andre

Share this post


Link to post
Share on other sites

Hey hi res option is showing up in mi a1

But when I active it through the aux 

The aux is connected but hi res plays through the device speakers ??

Plz help

 

Share this post


Link to post
Share on other sites

This version also working flawlessly on Redmi Note 4 like the previous version but I will continue use 790 version for me it sounds better specifically the sound stage I'm getting is unreal I've never heard anything like this before it's just amazing

Share this post


Link to post
Share on other sites

On my LG V10 (android 7.x) the hi-res-output fails with the build 706 or 705, just the default output (OpenSL ES Output, 16bit/48Khz) works.

Will the build 790-alpha work with the DAC-Chip (ESS 9018C2M) inside this phone?

Thank you, Angelo

 

Share this post


Link to post
Share on other sites
3 hours ago, Sylvo said:

Hey hi res option is showing up in mi a1

But when I active it through the aux 

The aux is connected but hi res plays through the device speakers ??

 

Try turning DVC mode off for that output method. That solved the same problem for me in my Galaxy Note 3 Marshmallow device. Although it also seems to come and go on its own sometimes, it's not a consistent bug (on my device at least)

Andre

Share this post


Link to post
Share on other sites

One thing I have noticed in 705/706 (which didn't happen in 704) is that whatever internal flag or event that Android uses to indicate that audio is currently playing, doesn't now seem to be getting set correctly.

I use an app ("PBMC Key Chains") that has a 'Music Playing' option, which is used to determine whether a given task should currently be triggered or not. With 704 I'm pretty sure that even when using High-Res output, this app correctly detected whether audio playback is taking place or not, but in 705 & 706 it cannot detect if music is playing and so does not trigger when I want it to. It works fine with PA in non High Res modes.

Andre

Share this post


Link to post
Share on other sites

706 does not work on tablet. samsung tab 3 8.0 Lineage 14.1(703 woking)
i have tried reinstall clean install and so one. nothing. black screen. wait or close notification can be seen after some time.

Share this post


Link to post
Share on other sites

Hello, and for phones with the processor Kirin will be available Hi-Res output?

Edited by andrewilley
Translated to English

Share this post


Link to post
Share on other sites
38 minutes ago, andrewilley said:

Try turning DVC mode off for that output method. That solved the same problem for me in my Galaxy Note 3 Marshmallow device.

Andre

Thx man it works 

BTW how do u know that the audio is playing in hi res ?

Share this post


Link to post
Share on other sites
25 minutes ago, Sylvo said:

BTW how do u know that the audio is playing in hi res ?

In the EQ/etc menu (drag in from right edge of screen) tap on the info (i) icon.

Andre

Share this post


Link to post
Share on other sites
4 hours ago, dantedakilla said:

I still don't have any Hi-Res output on Axon 7 (AEX 5.5 + Ainur Sauron) nor do I have any wired headphone option in the OpenSL HD section. Music doesn't play at all as well after messing with the output settings. I've got some screen shots of what it looks like when I play music and the missing settings.

I got the same issues, OnePlus One running AOSP 8.1. Also with beta 790, running dumpsys media.audio_flinger shows that the output is actually 16bit PCM. Hi res used to work in OnePlus One, Snapdragon 24bit variant.

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Yes. But if you do happen to get any issues, clear cache/data or do a clean uninstall/reinstall.

Andre

It's working as expected thnx

Share this post


Link to post
Share on other sites
4 hours ago, Rollers said:

Max would like to know or clarify the situation with the phone Huawei P9. Specifically, this smartphone with Kirin processor is equipped with a sound chip of its own production Huawei, which is capable of playing music in the Hi-Res Audio standard 24 bit 192 kHz. And in Huawei P9 is installed just such a chip.

Many Huaweis - they are all on Kirin - support hi-res (for example, P20 series, Honor 8 Pro). If it doesn't detect it on your device, it means something differs there. You can try to extract build.props, and any of: /etc/audio_policy.conf, /vendor/etc/audio_policy.conf, /vendor/etc/audio_output_policy.conf and PM me with them - I can take a look and compare it with the Huaweis known to produce Hi-Res on internal DAC. 

19 minutes ago, whiplash1 said:

I got the same issues, OnePlus One running AOSP 8.1. Also with beta 790, running dumpsys media.audio_flinger shows that the output is actually 16bit PCM. Hi res used to work in OnePlus One, Snapdragon 24bit variant.

As far as I can tell, (esp. based on pure AOSP) custom ROMs rarely support Hi-Res. Quite specific patches (qualcomm caf in this case) are required - per specific SOC + all the mixer, DSP, DAC configs. 

build.props, and any of: /etc/audio_policy.conf, /vendor/etc/audio_policy.conf, /vendor/etc/audio_output_policy.conf can make it a bit more clear, but even with these existing and being OK, these said patches should be in the system - as configs just don't work without appropriate code integrated into ROM.

1 hour ago, andrewilley said:

One thing I have noticed in 705/706 (which didn't happen in 704) is that whatever internal flag or event that Android uses to indicate that audio is currently playing, doesn't now seem to be getting set correctly.

Andre, what is the exactly device/Hi Res variant?

Share this post


Link to post
Share on other sites
28 minutes ago, marcenandu22 said:

This new updates are going to be available in Play Store next time? 

Please read first post again. Thank you.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×