Jump to content
Poweramp
maxmp

Poweramp v3 beta-preview-build-790 - Not yet feature-complete, read first post before commenting

Recommended Posts

+    14. the ability to go back in time 4 days like dvvmvp can. 

Share this post


Link to post
Share on other sites

Tons of requests in there which I won't tackle now (most of which I think are very sensible by the way) but a few anwers:

24 minutes ago, dvvmvp said:

1. General Poweramp question (it also applies to the previous versions): What's the difference between "Shuffle Songs/Lists" and "Shuffle All"? According to my experiments, the only difference is the name as their behavior is identical. 

2. "Repeat song" is the 'repeat' option I'm using most. @maxmp, can you make it activate on a single tap instead of having to tap 3 times? In a perfect universe, there is an option in settings that allows users to customize this as they please. 

Another thing that would be nice to have is reducing the number of icons in the same bottom bar by moving "equalizer" in the "3 lines" menu. I don't know about you guys, but once I set up the equalizer the way I like it (which I do after a clean install) I never touch it again. So, it would make all the sense in the world to me to have "equalizer" in the "3 lines menu" instead. 

1. All is completely random in whole library, any song could come next. Shuffle Songs/Lists first finds a random Album/Folder/etc and plays all of that album's songs in a shuffled order. Then it finds a new random Album/Folder/etc, and plays that whole album in shuffled order, and so on.

2. I've suggested for ages that the Shuffle and Repeat icons ought to be on/off toggles, with a long-press used to change the actual mode. I too just want to turn my desired Shuffle mode on or off without having to go through halt a dozen extra options first.

3. I've already challenged the need for the three-lines hamburger icon anyway; it only contains "Settings", "About PA", and "Get Support" - and the latter two are already in the first screen of Settings anyway. So I suggested just placing the only useful one, Settings, at the end of the three-dots context menus and make it simpler.I doubt that will happen though, as despite it making much more sense from a usability point of view, it goes against Google's Material Design dictates.

By the way, does anyone else find their device's physical/capacitive Menu button is not working? I always use that as a much easier way to open content menus (I refuse to call them Overflow Lists, bleugh) rather than hunting around each screen for a different three-dots icon.

Andre

Share this post


Link to post
Share on other sites
2 hours ago, daveaspec said:

do the focus audio channels work well when you receive notifications 
while listening to music?

Yes, they do. No problems whatsoever. 

Side note: "resume playing" when headset is connected is not working in the beta preview. Hopefully, Maxim will address this with the next update.

Back to your issue, updating the firmware didn't fix the bug you reported a few pages back? If you ask me, this is a firmware/ROM issue. It has nothing to do with Poweramp. If the new firmware didn't do the trick, report the bug to the forum where you got your ROM from. 

In the meantime, just put your phone on silent or vibrate while commuting.

 

Later edit: Upgrade to LineageOS 15.1. Just like you, I've got a Xiaomi device. My device is running on LineageOS 15.1 and the audio channels work flawlessly.

Share this post


Link to post
Share on other sites
16 minutes ago, dvvmvp said:

Si lo fanno. Nessun tipo di problema. 

Nota a margine: "riprendi la riproduzione" quando la cuffia è collegata non funziona nell'anteprima beta. Spero che Maxim si occuperà di questo con il prossimo aggiornamento.

Tornando al tuo problema, l'aggiornamento del firmware non risolveva il bug da te segnalato di poche pagine indietro? Se mi chiedi, questo è un problema di firmware / ROM. Non ha nulla a che fare con Poweramp. Se il nuovo firmware non ha funzionato, segnala il bug al forum da cui hai ricevuto la tua ROM. 

Nel frattempo, basta mettere il telefono in modalità silenziosa o vibrare mentre si è in viaggio. 

ok , but,why in power amp 704alpha no problem?

Share this post


Link to post
Share on other sites
30 minutes ago, dvvmvp said:

Yes, they do. No problems whatsoever. 

Side note: "resume playing" when headset is connected is not working in the beta preview. Hopefully, Maxim will address this with the next update.

Back to your issue, updating the firmware didn't fix the bug you reported a few pages back? If you ask me, this is a firmware/ROM issue. It has nothing to do with Poweramp. If the new firmware didn't do the trick, report the bug to the forum where you got your ROM from. 

In the meantime, just put your phone on silent or vibrate while commuting.

 

Later edit: Upgrade to LineageOS 15.1. Just like you, I've got a Xiaomi device. My device is running on LineageOS 15.1 and the audio channels work flawlessly.

I'm sorry for the partial OT
but I have a bit of confusion.
I downloaded the 14.1 for my phone version of 20180325
is this the firmware? are there any other firmware and where can 
I find and download them?

Share this post


Link to post
Share on other sites
1 minute ago, daveaspec said:

ok , but,why in power amp 704alpha no problem?

That's a good question. When I was having the same bug, 790 hasn't been released yet, so I was using 704. I updated the firmware and the bug vanished. After that, no issues with 704. Now I'm on LineageOS 15.1. No sight of that bug with 704 and 790.

Share this post


Link to post
Share on other sites
2 minutes ago, daveaspec said:

I'm sorry for the partial OT
but I have a bit of confusion.
I downloaded the 14.1 for my phone version of 20180325
is this the firmware? are there any other firmware and where can 
I find and download them?

I'll PM you so we don't spam the Poweramp forum with LineageOS thingies. 

Share this post


Link to post
Share on other sites
13 minutes ago, dvvmvp said:

Ti PM in modo che non invadiamo il forum di Poweramp con le cose di LineageOS. 

^_^

Share this post


Link to post
Share on other sites
13 hours ago, xander71 said:

 

Screenshot_2018-05-03-16-39-12.png

V4A clearly shows that the Hi-res not works, but I can listen it with Hi-res output for a half day stable, without any problem and it sounds good. Just weird, anyways I'm happy with it's sound.

 

Hi mate you cannot judge/measure Poweramp's hi res output using viper

Because viper never showed anything more than 44100/48000 since the day it was released a thousand years ago you should ask zhuhang about this if you are not sure or you don't believe me.

One more thing I want to mention if you use viper4android it will down sample your Poweramp's hi res output to 44100/48000 even if you're playing a 24bit 192khz file using Poweramp it will be down sampled.

 

Share this post


Link to post
Share on other sites

Thank you for the beautiful update Max! Anyway, does anyone notice a degrade in sound quality? Now it give audible crackling noise especially in mid frequency. I notice that High Res support still active. However the change in Sound Quality is really noticable. Anyone else?

Share this post


Link to post
Share on other sites
10 hours ago, gaberad said:

Would it be possible to split the album & artist on the now playing screen into separate lines? Sometimes a long album name will mean the artist name gets cut off. I see there is an option to show/hide Like/Unlike, maybe the artist name can go there?

 

Also, non-square album art is being cropped into a square e.g. concert posters being used for album art. Can there be an option for 'fit-centered'?

 

+1 for the next/previous buttons and 'normal' seek bar.

I agree

Share this post


Link to post
Share on other sites
6 hours ago, andrewilley said:

Assuming you use lock screens of course, which I don't. As long as I'm in a trusted location, mine unlocks directly to normal screen.

Anyway, I think all that's needed is the option to use regular controls and/or gestures, not to remove either completely. 

Andre

That would be nice too.

Share this post


Link to post
Share on other sites
1 hour ago, dvvmvp said:

Ti PM in modo che non invadiamo il forum di Poweramp con le cose di LineageOS. 

ok


I update you and I hope that Max reads or is brought back to him.

despite the successful firmware update (thanks a lot dvvmvp) the problem persists.
I tried another player and no problem.
I tried to remove the HIRES and use OpenSL and the problem disappears.
so I deduce that the problem is something related to the HIRES of PA
I hope it is useful
Dave

Share this post


Link to post
Share on other sites
Just now, someguyontheinternet said:

Not sure if it has been mentioned but connecting wired headphones does not resume music despite "Resume on Wired Headset" being enabled.

I'm on Android 8.1.

I'm on 8.1 as well. This doesn't work for me either.

It works on Android 8.1 with Poweramp 704 alpha but it doesn't with 790 pre beta. 

I suppose Max hasn't ported this option yet. I'm confident he'll do it in one of the future versions. 

Share this post


Link to post
Share on other sites
13 minutes ago, dvvmvp said:

Sono su 8.1 pure. Questo non funziona neanche per me.

Funziona su Android 8.1 con Alpha Poweramp 704 ma non con 790 pre beta. 

Suppongo che Max non abbia ancora portato questa opzione. Sono sicuro che lo farà in una delle versioni future. 

 

on nougate (lineage 14.1) works, but volume control from headset to off screen does not work

Share this post


Link to post
Share on other sites
5 hours ago, andrewilley said:

What a good idea, best of both worlds! A full-track wavebar could use the same visual format as the new one (which looks lovely) but just have a moving positional indication rather than one locked to the middle of the screen. It would need to be long-press to toggle though, as otherwise how could you tap somewhere along the bar for a new playback position when you are in the full-track view? But then, long-press functionality might mess up easy dragging in the new 790 style wavebar...

Now just got to convince Max that he wants to write that...

Andre

A togglelable full track wavebar is a great idea coz this full track idea is only worthy for short tracks... In long tracks it will cramp up the sound signature to fit it into the width of the screen which would lose the purpose of the wavebar

Share this post


Link to post
Share on other sites

Max, please, hear me. You can add this feature, which make which makes the sampling frequency equal to the sampling frequency of the source (file)

Share this post


Link to post
Share on other sites

First of all i'm happy to see that Poweramp is not dead yet and after everything i saw, the new UI looks very promising.

Is there an option to set the time for the player UI to fade out for the visualization?

Share this post


Link to post
Share on other sites

Max, can I ask you please differ internal name of Poweramp of 704 and further builds after 790 (i.e. separate settings)? I want them BOTH installed side-by-side - 790+ are for bugging/testing + being able to play music with 704.

PS. all of the 790's bugs are known for me and pointed in this thread, so I won't annoy you with any reports for now.

-----

Максим, можно ли попросить разделить настройки 704-го и будущих тестовых билдов после 790-го (то есть чтобы они были с разными настройками (папками))? Хочется, чтобы обе версии были установлены, но 790 для тестов (поглючить :)), а 704 для основного использования.

PS. все баги, проявившиеся в 790 билде, уже и так известны в данном треде, так что не буду щас беспоикоить лишними (и бессмысленными) репортами.

Share this post


Link to post
Share on other sites
23 hours ago, Rainsky said:

It's really awesome! The best UI design I have seen ever on android. The High-Res support is back and works well with my Redmi 5 Plus on Android 7.1 (MIUI) now, while the 704 preview alert a fatal error on loading Highres. I'm really excepting for the complete v3 release.

 

Still find some small bugs.

On my Android 7.1 MIUI9 the notification bar is completely broken, only the track counter is displayed. It is probably caused by the MIUI custom so later I will check it on another phone with AOSP system on Android 7.1 .

Screenshot_2018-05-04-00-16-43-003_org.mozilla.firefox.thumb.png.b80311b085bd07c4a2c4cad944d6de86.png

The new navigation bar sometimes seems to have missed the last few seconds of the song, and the displayed total length is also incorrect. Probably it is designed to behave like this, or a small bug.

IMG_20180504_001823.thumb.jpg.73ec123cf0d9bb9a6740fbfb8a39cfc9.jpg

I checked it on another device running Android 8.1 AOSP based system.The notification bar just works well as the built in music player.So I guess it is possible that Poweramp consider my MIUI based android7.1 as Oreo and use the oreo notification bar so it did not work anyhow. This can be proved by the OpenSL HD output method, which is originally for Android 8+, available on my phone. So I consider it is probably a bug related to some customed ROM.

 

However as I uses more I noticed more the buggy progress bar. Although the display effect is good, it is full of small bugs when it comes to seeking forward/back. It is possible it displays you seek 30sec forward but actually only about 20sec.That's why the time is displayed incorrectly. And actually the seeking is more tiring. By swiping from right to left once you can only seek about 30 percent of it. Hope it will be fixed in the release ver.

I would prefer a fixed length progress bar, or a better way to seek more faster.(I know the origin is to make click and drag v2 progress bar more easy. I almost never use v2 seek par because it's small and hard to seek accurate.)

Share this post


Link to post
Share on other sites
10 hours ago, koolicecream said:

I am getting like this... How to get Hi Res..? 

Screenshot_20180504-121222.jpg

Are you playing the audio via phone speaker? Hi Res output is available only with Headphones/External Speakers connected via 3.5mm jack and with USB DAC. 

It is not supported for phone speaker. Connect headphones and check. Before connecting headphones pls make sure you have enabled hi res output for headphones / aux. 

Screenshot_2018-05-04-23-01-44-414_com.maxmpz.audioplayer.png

Share this post


Link to post
Share on other sites
5 hours ago, Prosenjit said:

Hi mate you cannot judge/measure Poweramp's hi res output using viper

Because viper never showed anything more than 44100/48000 since the day it was released a thousand years ago you should ask zhuhang about this if you are not sure or you don't believe me.

One more thing I want to mention if you use viper4android it will down sample your Poweramp's hi res output to 44100/48000 even if you're playing a 24bit 192khz file using Poweramp it will be down sampled.

 

Oh, so that's why it looks like the PA using the Hi-res output, but because of V4A it plays just only 16-bit 44.1khz. Ok, so I understand now why i can use Hi-res, and why stable even it is not supported. For now I uninstalled the V4A for test it only with XtremeMusic. The result was shocked me. Now the XtremeMusic shows that it plays 32-bit 384k ultra Hi-res, but I think it just still 16-bit 44.1k

Screenshot_2018-05-04-13-42-40.png

Screenshot_2018-05-04-13-41-19.png

Screenshot_2018-05-04-13-41-54.png

This gonna be more weird and weird everytime I try to do anything else to test the Hi-res output. Lol..

Share this post


Link to post
Share on other sites

Does Xiaomi Mi5s support Hi - res in LineageOS 15.1? My best option is OpenSL ES HD.Is this the Hi - res option we are talking about?

Screenshot_Poweramp_20180504-210629.png

Screenshot_Poweramp_20180504-210641.png

Share this post


Link to post
Share on other sites
23 minutes ago, xander71 said:

Oh, so that's why it looks like the PA using the Hi-res output, but because of V4A it plays just only 16-bit 44.1khz. Ok, so I understand now why i can use Hi-res, and why stable even it is not supported. For now I uninstalled the V4A for test it only with XtremeMusic. The result was shocked me. Now the XtremeMusic shows that it plays 32-bit 384k ultra Hi-res, but I think it just still 16-bit 44.1k

 

Let me tell you one thing that so called Xtreme music's 384k & bla bla bla is nothing but a gimmick you can edit it 44.1-384k or whatever you want with a simple build prop editor

A year ago I had a Samsung galaxy S3 indian model GT I 9300 I also get the same out put as you mentioned here using Xtreme music mod 

My galaxy S3 has Wolfson face chip which supports 16bit 44khz so how can it possible?

I am not saying Xtreme music or arise or any other sound mod is not or they sound bad but I do say that the out put your getting 100% fake unreal science fiction like aliens caught in camera or ghost caught on camera videos.

If those mods sound good to you and give a better music out (which they really do I can tell from my 6 years experience in XDA) you can use them

But please don't measure your audio output using those apps.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×