Jump to content
Poweramp
johnbyebye

Poweramp not working on S8/Note8 Oreo

Recommended Posts

Hello everyone,

I was a member of the Oreo beta program for the Galaxy S8 in the U.S. Throughout the beta program Poweramp v704 was working fine with the occasional crash. However, suddenly Poweramp no longer works at all. I have done everything I can think of including a factory reset, but it opens to a blank screen and ends up crashing. I picked up a Note 8 and am having the same issue after flashing an Oreo build. Installing the Play Store version yields the same results. I am at a loss and at this point I don't think there's anything I can do to get it working, but I was hoping smarter minds might have some ideas. 

Thanks.

Share this post


Link to post
Share on other sites

There are issues in 8.1 with notifications, but the basic app itself (both the stable and alpha builds) should run fine. Are you running a stable release version of Oreo on both of these devices? Have you tried a clean re-install of the app?

Andre

Share this post


Link to post
Share on other sites

They are both Beta builds at the moment so I'll have to wait a week or two until the final release is out to see if that resolves it. Both builds are certified though.

I uninstalled and reinstalled the app if that's what you mean. How do I perform a clean install?

Share this post


Link to post
Share on other sites

That's what I meant, uninstalling rather than trying to install the alpha over the regular version for example.

Andre

Share this post


Link to post
Share on other sites
1 minute ago, andrewilley said:

That's what I meant, uninstalling rather than trying to install the alpha over the regular version for example.

Andre

Ah gotcha. Yeah, I tried that. I'll report back after I receive the official build. Strange that it was working then suddenly broke though.

Share this post


Link to post
Share on other sites

I just received official Oreo build on my Verizon S8+. I finally tried to use the 703 abd 704 Alpha version and it freezes. I see the Poweramp logo and it sits there. 

Deleted and reloaded... No success. Had to revert to removing myself from the Beta program, and load the regular Playstore version with unlocker. 

Maybe the new version due April 2018 will work. 

 

Share this post


Link to post
Share on other sites
1 hour ago, Ohaness said:

I just received official Oreo build on my Verizon S8+. I finally tried to use the 703 abd 704 Alpha version and it freezes. I see the Poweramp logo and it sits there. 

Deleted and reloaded... No success. Had to revert to removing myself from the Beta program, and load the regular Playstore version with unlocker. 

Maybe the new version due April 2018 will work. 

 

Thanks for replying. I figured the beta Oreo software had nothing to do with it. You're still having the issue on the official build. I think it's an issue with Samsung's Oreo in general. As soon as I receive an official build I will try to get it to work again.

Share this post


Link to post
Share on other sites

Just to confirm, I have a T-Mobile S8+ with Oreo. I have noticed the same, but just a little information that might help.

If I have just turned on the phone from being powered off, Poweramp v3 build 703 will start up fine as long as it is not trying to start with headset/Bluetooth attached. After it starts I can connect either and hit play and it will work fine for that session. Once the app goes into sleep mode or is closed with the "all apps" feature, it will freeze up and force me to power down and restart the phone.

Share this post


Link to post
Share on other sites

I finally got it to work! 

Here's what I did:

I used the APKs as I was still getting the blank screen with the play store version.

I did not uninstall each version prior, I just installed them on top of each other.

1) Install V2 588/589

2) Install V3 703 Alpha

3) Install V3 704 Alpha

Now it works, but I still run into the occasional problem where I have to restart to get it working again like others stated.. However, I'll take this over it not working at all. 

Share this post


Link to post
Share on other sites
On 4/2/2018 at 2:16 PM, Kamau54 said:

Having the same issue on my Note 8 after the Oreo update. 

Did you follow the instructions I had above? I got it working on my Note 8.

Share this post


Link to post
Share on other sites
2 hours ago, Martin Medrano said:

Does he mean to install apk for both from the website

They are only available from the website.

Andre

Share this post


Link to post
Share on other sites
6 hours ago, jenluvs2sing said:

I have a Note 8 with the Oreo update and am having the same issue, will not open at all. What is the official fix for this? 

Have you tried the advice a couple of posts before yours?

Andre

Share this post


Link to post
Share on other sites
On 3/28/2018 at 9:09 PM, johnbyebye said:

You can try these apks.

Best advice I have at the moment is to keep trying or stick with v2 for now. 

Poweramp apks.zip

 

17 hours ago, jenluvs2sing said:

I have a Note 8 with the Oreo update and am having the same issue, will not open at all. What is the official fix for this? 

Use the attached APK's and follow the instructions I had above. There is no "official" fix at the moment, I just kept fiddling with different combinations until I got it to work. It was working on the beta software. I just performed the same steps on the official Oreo and it works as well.

Share this post


Link to post
Share on other sites

Strange that you are having problems,I have note8 and s8 with oreo on both and PA is working fine but I don't have option for hires on both.

Share this post


Link to post
Share on other sites

I'm on a clean note 8,with OREO, and every time I open version 3 beta it locks device and screen. It did not do it it on 7.1.1 nougat. This needs attention. I love the player, but one that works with note 8 Oreo. 

Share this post


Link to post
Share on other sites
22 hours ago, Icarus said:

I'm on a clean note 8,with OREO, and every time I open version 3 beta it locks device and screen. It did not do it it on 7.1.1 nougat. This needs attention. I love the player, but one that works with note 8 Oreo. 

Have you tried doing a full uninstall and then installing 588 (some people have reported it's worth trying with 585)?

Andre

Share this post


Link to post
Share on other sites

where to find 588

the one that crashes is v3 beta  that has the visual animated graphics. all worked on nougat but freezes device  regardless of uninstall reinstall.  my device  is a  new note 8. yes note 8 fully functional' 

strange thing is when i clear cache and force stop v3 beta, it works until i close it , then opening again it locks up and wont work till  i clear and force.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×