Jump to content

Lockscreen in Oreo 8.1 (Pixel)


Recommended Posts

  • 3 weeks later...

Just got 8.1 OTA on my Pixel XL.   Yup. Lock screen and drop down notification useless. also all white with white text and white icons, even when set to auto or black.

I can enable the Poweramp Lockscreen (instead of the "Android Lock Screen" and that does work fine. However, Direct Unlock does not work, cause Fingerprint unlock require PIN/Pattern to be set.

Other than that, player still plays fine. EQ and all. My USB DAC still works the same (as long as the audio output mode in Poweramp is set to use "Default Android audio API"

Link to post
Share on other sites
On 12/15/2017 at 2:17 PM, andrewilley said:

Max is aware of these Oreo issues and they should be fixed for the next beta release. The one possible short-term issue is that none of his test devices have yet updated as far as 8.1.

Andre

Stop making excuses and buy him a new phone. And fix the bugs. We didn't pay for these 'effing bugs. Fix and give us update asap 

Link to post
Share on other sites
On 12/17/2017 at 7:57 PM, andrewilley said:

They should hopefully be fixed in the next release. Do any of these problems affect the actual core app by the way? I've seen reports of issues with the lockscreen interface, and notification pull-down buttons, but not in the app itself.

Andre

You can't skip or pause a song, or close the player without having a widget or going into the app  itself since the notification is broken.

 

Also don't know about anyone else, but on Bluetooth now when I get a notification it bugs out. The volume adjust bar drops down to lower volume, and then does it again when the notification tone ends to turn the volume back up 

Link to post
Share on other sites
1 minute ago, Duarian said:

You can't skip or pause a song, or close the player without having a widget or going into the app  itself since the notification is broken. 

Yes, that's what has been reported in 8.1, it's a known issue. So the app itself is OK for you, it's just the notification pull-down controls that you can't use.

Andre

Link to post
Share on other sites

Adding a little more than 'me too':

Notification controls are grey/invisible and unresponsive as shown by others. Pausing and resuming the same track, either from the app, a widget or via a Bluetooth device hardware play/pause button fixes the notification until the track changes. Skipping back to the beginning of the same track then does not break it again; only skipping to the previous or next track.

Also noticed that if you pull down the notification shade and skip tracks with a Bluetooth device, the notification buttons and track information appear correctly for a split second (and actually work if you're fast enough) until the album art appears, then disappear.

Pixel 2 XL. Received with 8.0 and now running 8.1. I can't actually remember if it affected 8.0 or not...I don't think so. 'Internet Speed Meter' shown in my screenshots no longer respects its notification priority setting since the 8.1 OTA though, so Google definitely screwed with notifications somehow.

 

poweramp.jpg

Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...

This does work, and I commend the developer for creating this workaround, but any idea when we can expect a fix in Poweramp? I appreciate that Poweramp has always favoured a slower development pace and stability rather than rapid updates and new features, but it's been 2 months now and this is a significant bug.

I've switched to Neutron in the meantime, which despite an otherwise atrocious UI, does have working notification/lockscreen controls on 8.1, which kinda contradicts the "it's Google's fault" narrative.

Link to post
Share on other sites

I've contacted the dev about this (a few other people have too) and he says it will be fixed in the next beta-test build of Poweramp v3. Please note that it will not be fixed in the v2 builds though, as those are going to be classified as legacy products for Android 4.x and below only so Android 8 issues are not considered relevant to that fork. I'm sorry that there is no easy solution in the meantime though and both the v2 and current v3 alpha builds are affected by this Google problem.

Andre

Link to post
Share on other sites
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...