Jump to content
Poweramp
Sign in to follow this  
Testfahrer

Cant disable autostart in car ?

Recommended Posts

Hi,

whenever I connect my phone with usb to my autoradio, Poweramp starts to recognize and is gonna play music. The phone itself first trys to autorize the usb connection which i have to admit but in the same time Poweramp acts and I get some kind of refuse. i cant do nothing and getting this in an endless loop stucking on wether to admit the usb connection (when i admit, it starts reconnecting in a loop same procedure) or just let the music play that will come but without the option to change anything on my mobile phone because i have to agree the usb connection (and when i do, i get the loop on it again). 

The problem is not existing when i deinstall Poweramp, it works. I think I disabled everything I can disable in settings (several times checked) but i cant get past this :( . Any suggestions? It does not happen when I connect the phone with headphones or something else.

 

Greetings

Share this post


Link to post
Share on other sites

Poweramp cannot play through a USB connection to a car stereo, although it might be detecting it as some kind of external DAC and trying to use that? Please use either bluetooth or a wired AUX connection.

Andre

Share this post


Link to post
Share on other sites

Hi,

I didnt mean to "connect" Poweramp with my Car Stereo i never did this - but just connect with it as a source. Im using my mobile to control everything, car hifi just works as a speaker and has no function else.  I was using this for like 3 years now flawlessly without a problem ever. It still works with Android <7, but since new Android wants always to autorize the usb and Poweramp always tries to play music instant without waiting for it to get released, I have this problem.

Thing is, I simply cannot disable this "Usb access" from Android, and I dont know how to make Poweramp NOT start playing music instantly when I connect the usb with it (if you can tell me how to not make it start at all when it gets the usb connection, it will work i think). As said, when I deinstall Poweramp, I get into this "Handmode" (means phone is connected to the car-hifi with usb but it has no function but being a speaker) and I can use it properly. 

atm I cannot even use my phone as a speakerphone to make calls or anything (or even check something in whatsapp) because it does not give me permission for it to control the phone.

Mustnt be a bug, but i didnt knew where to put this topic into. 

Ps: Audio Fokus is everything disabled, and I tried to disable everything else that I could find in settings. And i played around a lot with settings trying to figure out something. I CAN stop the services and everything from Poweramp in android so it works as well when the phone got access and i start it because it does not start music instantly, but this is not an option. 

Share this post


Link to post
Share on other sites

So the car is acting as a USB DAC then (or should be anyway)? I didn't even know that was possible, all call stereos with USB that Iv'e come across simply expect a memory stick (or USB flash drive) to be present and then the car stereo handles the audio playback of any files it finds there. 

Andre

Share this post


Link to post
Share on other sites

Hi,

not quite sure what USB DAC is. Im not using mass memory at all. I plug in the mobile - it asks if I want to start the app (then I would control it via radio  and get infos for title/interpret/albums ect on the radio display, but could not use Poweramp, only the app for the radio will play music then) and when I deny, I have this free mode where I can go free ride whatever I want. Poweramp, Spotify, speakerphone for Calls and so on or everything at the same time. The function itself seems to be the same as if I would connect AUX with it. With the difference, that I need it to access, bc its usb plug, and I am able to change the title with +- straight on the radio when I activate this option in Poweramp, but thats it, no info or anything. And with a much better quality of course! Using .flacs with Poweramp is unbeatable so I would never go back to anything else. The radio came with "android" ads on it, having "AOA2.0 = Android Open Accessory Protocol Version 2" - maybe this is the function for it that explains why it works, I dont know much about those shorthand symbols and their meanings. 

Besides that, the problem stays the same. Do you have any suggestions why this is happening or how it could be fixed? Music starts playing altough it should not (everything is disabled) and for me this is the reason why I get stuck in that loop of access/autorize and decline the same time, which repeats. Is there anything I can try or you want me to try, or should I leave the beta and get back to the standard version? Ps: Music does not start automatically when I plug in earphones or aux, it just starts on my car radio and it instantly comes out of the car speakers. 

Share this post


Link to post
Share on other sites

Sounds strange, and beyond my knowledge of car audio systems too. Do you get an albums/songs list on your car headunit display, or just current track info? If it's more than current track then it's unlikely to the PA doing the playing but instead the car stereo is finding the songs on your phone as external storage.

Andre

Share this post


Link to post
Share on other sites

Hi,

nah, as previously said in "handmode" I can only change titels with +/- on the radio (when activated in Poweramp in those headset settings). There is no info or anything. This would not work with Poweramp or any other app besides the app that was made for the radio which is a pretty simple and a bad one. 

"Handmode" display looks like this one I attached and it stays and does not change (its not my radio but same brand and mode). To get in Handmode, it has to "read" the phone, then I have to acceppt the usb access on my phone. Meanwhile Poweramp starts playing music and messes this process up, which means the radio starts again with "reading", then the phone asks for access on it, meanwhile Poweramp starts playing music, messing it up.... loop

 

maxresdefault.jpg

Share this post


Link to post
Share on other sites

Can you not just plug in into an AUX socket? :) I have no idea what 'HandMode' is, it must be a Kenwood thing? It does sound like the Kenwood is trying to behave like an external DAC of some sort though (a box which you plug in via USB and which handles the analog audio generation process for high-end audio systems).

Andre

Share this post


Link to post
Share on other sites

Aux has bad quality. If I would chose Aux, I could chose to deinstall Poweramp and use the given app as well. But that is not an option. I am not listening to bad mp3's in combination with a bad car hifi where it would not matter due to the low spectrum. 

I got here simply for the reason bc I think Poweramp is the most powerful player and Im telling you this bc I am sure I wont be the only person having this issue in the future and it might be some help. And it is really annoying as hell for someone who has no clue why it happens. Easiest thing is just leave the beta and use the normal version of the player, because this problem did not exist there. So you need to tell me if you are interested in trying to figure out this interference and if I should/can do anything specifically to help, or not. 

5.JPG.01e294dc7e34ac3b271f60b78c82fcf6.JPG Thats it. Nothing special and common to most new car radios on the market that support android...

Share this post


Link to post
Share on other sites

You also said it worked prior to you installing Android 7 on your phone, so as Nougat seems to cause problems with the alpha test version of PA v3 on a number of devices (and please do remember that this is an alpha test, not a released or supported product) then you probably should either roll back to your previous ROM or go back to using the stable release version of Poweramp - assuming you don't still have the same problem with Android 7 on that of course.

Keep an eye on the testing forum and when the next (beta) release occurs give that a try and see if it solves your issue as Max has been making a number of background changes to better support the latest OS releases.

Andre

Share this post


Link to post
Share on other sites

I'd like to pick up this topic... whenever I connect my smartphone (OP 5, Oreo 8) to my car's bluetooth, Poweramp starts and starts playing anything. That say, despite the fact, that I disabled

"continue on start" in Audio settings
"play on headset", "play on bluetooth" in headset/bluetooth

I do not need it in the car and especially I do not want autostart.

Any hint to stop this (latest version 703 alpha build play)?

Share this post


Link to post
Share on other sites

The head-unit is probably sending a Start Playback command after it has connected to a media device. You could try simply disabling Media Audio in the Android Bluetooth settings page for that Bluetooth device, allowing only Call Audio for your car head-unit if that is all you want to use the connection for.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×