Jump to content

Remote share feature is completely broken

Recommended Posts

Hello, I'd like to report this pretty huge bug (to me at least! ^^).

I have all my music collection on PC, I mount the main music folder to Android using the Remote share feature.

So my PC "MP3" folder is mounted as /storage/remote/Mp3

In Poweramp, I can see this path, with all subfolders, all seems good. So I select the root folder (Mp3) and press the "Select Folders" button.

Strangely the analysing is very fast (maybe 1 second), and then the bug is that the albums are never added to Poweramp library which stays very unfortunately empty!

I tried absolutely everything, reset all Android settings to factory state, I spent many many hours trying to understand the issue.

In all other programs, for exemple Sony Album app or ES Explorer, I can navigate to this mount [ /storage/remote/Mp3 ] and play my MP3s without issues. (I can even open them in Poweramp, but in this case only one by one :S).

I would seriously appreciate any help for this issue that has been 90% of my week-end ^^;



  • Poweramp v2.0.10 build 588
  • Sony Xperia Z1C
  • Android 5.1.1
  • My rom is not custom.



Edit: to make sure it wasn't a problem of compatibility with the file format or the path length, I tried one specific mp3 that I placed in internal memory. Poweramp plays it perfectly. Then I placed this same mp3, alone, in a folder and mounted it from PC: Poweramp sees the folder but doesn't add the file to the Folders/Library !!

Edit2: Also I became a beta tester on Google Play store to try the Poweramp v3, the exact same bug happens :S

Link to comment
Share on other sites

Ok, I attached a logcat to this message.

I think I found something interesting in it, maybe the reason of the bug..


06-12 17:26:31.769 W/ScanDispatcherService(12424): Scan requested: pref rescan_folders
06-12 17:26:31.769 W/RestStorages(12424): Using folders=/storage/remote/Mp3/
06-12 17:26:31.912 W/RestStorages(12424): Detected mount point=/storage/emulated/0
06-12 17:26:31.913 W/RestStorages(12424): Detected mount point=/storage/emulated/legacy
06-12 17:26:31.913 W/RestStorages(12424): Detected mount point=/storage/remote/Mp3
06-12 17:26:31.913 W/RestStorages(12424): Available mounts=[/storage/emulated/0, /storage/emulated/legacy, /storage/remote/Mp3]
06-12 17:26:31.915 W/RestStorages(12424): unmountedStorages=[/storage/usbdisk/, /storage/sdcard1/, /storage/remote/]
06-12 17:26:31.915 W/FolderScanner2(12424): Starting scan=/storage/remote/Mp3/ fastScan=false
06-12 17:26:31.932 E/FolderScanner2(12424): got unmounted match mount=/storage/remote/ path=/storage/remote/Mp3/
06-12 17:26:31.932 E/FolderScanner2(12424): root=/storage/remote/Mp3/ is on unmounted storage, skipping scan
06-12 17:26:31.933 E/FolderScanner2(12424): has nothing in batch!
06-12 17:26:31.937 W/FolderScanner2(12424): Old files/folders deleted from DB=0/0
06-12 17:26:31.938 W/FolderScanner2(12424): Scanned dirs: 0, files: 0 in 13ms, 0.0 files per sec, 0.0 folders per sec


It seems because /storage/remote/ is not mounted by itself, Poweramp just skips the scanning of /storage/remote/Mp3/ completely!


Link to comment
Share on other sites

Thanks for your reply Andre.

Nice to see I'm onto something!

I'm not sure how to do that, mount /storage/remote/ on its own.

I can browse the path with ES Explorer so it seems already mounted to me..?

From the logcat, can you see if it's the system that reports this path is not mounted or if it's PA detection system that's possibly buggy?

Edit: I found another player called Mortplayer. With it and the exact same remote share settings, I have access to all my music files in the program! So I think it is definitely a mismatch or bug in PA.

About this: unmountedStorages=[/storage/usbdisk/, /storage/sdcard1/, /storage/remote/]

This is likely the root of the issue indeed, why does it see /storage/remote/ as unmounted?

What does the program check to define that?

I hope that maxmp sees those messages. ^^

Link to comment
Share on other sites

Yes, it would need to be Max that looks into this, and I can't really see that happening before the next beta release is done.

Networked music is not supported by PA anyway of course, but the work-around of mounting a folder into the local file system ought to work (which app are you using by the way?).


Link to comment
Share on other sites

Maybe can you ask Max if he could take a quick look? I have a feeling that this could be super trivial to fix. ^^;

Yes, I think mounted-folder support used to work OK in PA v2.0.5 series (if my memory recalls OK), and broke later.
(I hadn't used for a while.) But now in 2.0.10 it's broken for sure.

I don't use a special app to mount, it's a built-in feature of Sony OS / Xperia Z1C, it's called "Remote Shares" in the general Settings.

Thanks for your help.

Link to comment
Share on other sites

I have asked Max to take a quick look at a lot of things over the years, and generally unless it's something that has broken the app he prefers to concentrate on his main overall project rather than getting distracted by lots of little quick items.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...