Jump to content

Poweramp v3 Project Update (please read first post for latest info before commenting)


Recommended Posts

2 hours ago, Mübaşir Mehmet Ali said:

Anyone knows why does the seek error happen?

Hello,

Is it a file downloaded from youtube?

If so, the internal decoder may fail because of possibly wrong file headers.

You should be able to transcode it into mp3 files so Poweramp and other players can read it properly.

Link to post
Share on other sites
  • Replies 2.6k
  • Created
  • Last Reply

Top Posters In This Topic

5 hours ago, karry said:

Hello,

Is it a file downloaded from youtube?

If so, the internal decoder may fail because of possibly wrong file headers.

You should be able to transcode it into mp3 files so Poweramp and other players can read it properly.

Thank you.

It was extracted from a pendrive.

The Samsung Music App plays it perfectly, though

.aac/.m4a & .amr types are recently buggy with Poweramp.

Should be fine in the next release

 

Link to post
Share on other sites
8 hours ago, Mübaşir Mehmet Ali said:

The Samsung Music App plays it perfectly, though

You still haven't said what the problem actually is. Is music skipping, or briefly glitching during playback, for example?

Andre

Link to post
Share on other sites

AMR doesn't really surprise me, it's a low bitrate frequency-limited speech encoding system only really designed for recording speech from a phone's microphone, not exactly what PA is designed for.

Personally I tend to avoid AAC completely wherever possible (I avoid anything Apple sponsored!) but I think it should play back reasonably well on the current alpha releases as a lot of people use iTunes, and that uses AAC. Try increasing the audio buffer size in PA Settings > Audio > Output > [choose desired output method and device and tap the Settings icon] and see if that helps.

I've seen issues with total running time before, and with moving around along the timebar on the same files, when there is a largish cover art embedded and the length/VBR information isn't included in the ID3 tags the way Poweramp expects it to be. Could you try removing any embedded artwork from a sample MP3 file that gave you this problem and see if that makes the timings work better? (a PC program such as TagScanner is perfect for doing this)

Andre

Link to post
Share on other sites
5 hours ago, andrewilley said:

AMR doesn't really surprise me, it's a low bitrate frequency-limited speech encoding system only really designed for recording speech from a phone's microphone, not exactly what PA is designed for.

Personally I tend to avoid AAC completely wherever possible (I avoid anything Apple sponsored!) but I think it should play back reasonably well on the current alpha releases as a lot of people use iTunes, and that uses AAC. Try increasing the audio buffer size in PA Settings > Audio > Output > [choose desired output method and device and tap the Settings icon] and see if that helps.

I've seen issues with total running time before, and with moving around along the timebar on the same files, when there is a largish cover art embedded and the length/VBR information isn't included in the ID3 tags the way Poweramp expects it to be. Could you try removing any embedded artwork from a sample MP3 file that gave you this problem and see if that makes the timings work better? (a PC program such as TagScanner is perfect for doing this)

Andre

You can also use an app like Automatag, or just edit the tags in power amp, which was in my opinion made very easy to do

Link to post
Share on other sites
3 minutes ago, Fetiz said:

The 704 build has notification bar bug on 8.1 beta, after change the song, the buttons become invisible and no functional. So sad.

It is so sad.  704 build's days are numbered.  And if we don't get a update soon we're screwed.  And now that there's more bugs there goes another 6 months to a year added to the next release date.

Link to post
Share on other sites
On 11/1/2017 at 8:15 PM, Fetiz said:

The 704 build has notification bar bug on 8.1 beta, after change the song, the buttons become invisible and no functional. So sad.

You have to exit the app and press the x on the notification player after you change the color, it will stay the same until you do

Link to post
Share on other sites
3 hours ago, Filip777 said:

Give us some screenshot of the development version, something to see how it's going, anything. Why are you so quiet and secretive about this Max ?

Hopefully November treats us well and we get a release, been looking forward to this new version for a while now

Link to post
Share on other sites

Oh, good God, not Material Design. Material Design is effing HORRIBLE!!!! And gesture based? Well, this is going to suck. Swiping and gestures are annoying as hell, too. Why do developers feel the need to ruin things that work just fine and refuse to fix things that don't work properly.

I've been teetering on the brink, but if this new MD version is as bad as every single other MD app ever developed, I'll likely abandon PA, altogether.

NO TO MATERIAL DESIGN!!

Link to post
Share on other sites
6 minutes ago, Devin said:

Oh, good God, not Material Design. Material Design is effing HORRIBLE!!!! And gesture based? Well, this is going to suck. Swiping and gestures are annoying as hell, too. Why do developers feel the need to ruin things that work just fine and refuse to fix things that don't work properly.

I've been teetering on the brink, but if this new MD version is as bad as every single other MD app ever developed, I'll likely abandon PA, altogether.

NO TO MATERIAL DESIGN!!

And Max will almost certainly bring skins to the new Poweramp so the Material design doesn't have to be your only option, I don't think you would have said that if you knew this information first

Link to post
Share on other sites
  • andrewilley locked, unpinned and unfeatured this topic
Guest
This topic is now closed to further replies.

×
×
  • Create New...