Jump to content

Pause/Resume on Headset connect/disconnect not working


Recommended Posts

Is there an issue on Nougat or on Oxygen OS 4.0.3? Because most of the times I will plug in my headset into my OP3T's 3.5mm jack, the handset will recognize the headset but Poweramp will not resume my queue/playlist. Also, Poweramp will not pause playback when I unplug/disconnect my headset. Is there an issue with the Headset Micro Service on which Poweramp relies for this?

Is it just me or is anyone else experiencing this issue as well? Any workaround to this, does Max know about this?

Link to post
Share on other sites

I don't know about nougat (although more issues with it would not surprise me as it was still in beta when 704 was released) but just to check, you do have that option enabled in Settings > Headset /Bluetooth don't you?

Andre

Link to post
Share on other sites

Yes Andre, I checked. Also, it works sometimes, but doesn't work most of the times, so something seems to be broken. Maybe Nougat does not handle the Headset Micro Servie(that Poweramp lists as required for this feature) in the same way as it did before.

It worked flawlessly in my previous handset(N5), and in the OOS build based on Marshmallow on my OP3T.

Can anyone running Nougat confirm this?

Link to post
Share on other sites
4 hours ago, musick said:

Yes Andre, I checked. Also, it works sometimes, but doesn't work most of the times, so something seems to be broken. Maybe Nougat does not handle the Headset Micro Servie(that Poweramp lists as required for this feature) in the same way as it did before.

It worked flawlessly in my previous handset(N5), and in the OOS build based on Marshmallow on my OP3T.

Can anyone running Nougat confirm this?

My Xperia X with Nougat didn't have same problem .

Poweramp needs to run in background at first , if Poweramp is stopped , auto start/pause won't work.

Does your phone have task management app (that will stop Poweramp automatically)?

Does you using battery boost app (that will stop Poweramp automatically)?

 

 

Link to post
Share on other sites

@misakidavid@andrewilleyI am beginning to think this might be because of aggressive memory management on OP's part. The handset has 6gigs of RAM, just don't understand why they do this? I bought a KIS license the other day, and OOS even shuts down KIS.

I also tried using other players(went and bought BlackPlayer EX,Shuttle PRO), and am facing the same problem there as well. I knew, of course, that Poweramp didn't have any issues because it was working fine on OOS 3.5.x(based on Marshmallow). I thought this was due to much more aggressive Doze on Nougat.

So, the problem appears to be due to Doze or an enhanced form of it(just guessing!) implemented by the mighty G or by OP themselves. Maybe just OP pushing it a bit too far. I am not, however, using any battery booster/saver apps, and regarding KIS, I was having this issue even before I installed it :(

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...