Jump to content

Arka-9

Approved Members
  • Posts

    6
  • Joined

  • Last visited

Arka-9's Achievements

Newbie

Newbie (1/3)

  1. Update again. It was just a fluke. Skipping happens with Hi-Res DAC option turned off too. I bought another LG V20 so will test it on that.
  2. Yesterday I listed for about half an hour with no skips with the Hi-Res DAC option turned off. Will continue to test this but seems like a solid bet on the source of the issue so far
  3. Since making this post I have formatted my phone twice to start clean with nothing at all added on: (It is and was before a stock H915 rom.) Tried AutioTrack Tried OpenSL Tried Hi-Res Have wakelock turned on Ignore battery optimizations for Poweramp (and the unlocker just in case) Formatted the SD card and reloaded everything from music bee back onto it Tested SD card speed, getting ~95MBps read and write Tested turning off auto-play when plugged in, in case the aux cable was loose in the jack and was activating a pause and play. Tested on headphones in case there was an issue with the aux cable in my car where I mostly listen. Tested with screen on and Poweramp in foreground Since resetting the device the pattern of when it happens seems to have changed slightly and the frequency is less often than before. Some songs will play with no skipping. A common time for a stutter seems to occur within the first 20 seconds of a song. Just now I had Poweramp open testing it on my headphones. It was in the foreground and I played a song which previously skipped in the car to make sure the stuttering isn't in the song file itself. It stuttered during the intro so I started the track again and it did it again around the same point. Restarted the song again and no skip occurred. I am almost certain that I have not had any skipping over bluetooth but I don't use it often and I'm not sure what the implications of this could be. I could test this more to rule out a SD card or reader issue, as I assume the SD card has to be read at the same speed regardless of the output, but I could be wrong on this. I am running out of things to test and any help is most appreciated. Thanks
  4. Tested with HEBF and Naptime uninstalled (were previously disabled to test but uninstalled just to make sure there was no hidden optimization) and Aunir Narsil magisk DSP module disabled just in case. Still getting the skips/stutters with screen allowed to turn off. I will test with screen on if I get time before I go away, but even if that works and stops the skipping I'm not sure there's any other optimization settings I can change. The only setting there seems to be for this is the one I have already allowed which is Battery & power saving > Battery Usage > Ignore Optimizations > and then enabling ignore optimizations for Poweramp.
  5. I'm not sure how you can conclude that a larger buffer wouldn't solve the issue when the issue happens more often with a lower buffer. Does the fact that the stutters aren't constant give clues that it is a different issue, as the lower buffer skips are very fast and more regular? Poweramp (and the unlocker) were both set to not optimize but will test these suggestions today. Thanks guys.
  6. LGv20, Nougat rom, rooted, Aunir Narsil (seems unlikely but about to test with disabled), FLAC library is on a 512gb Sandisk Extreme Pro SD card playing through Poweramp, SoX resampler. Music library too big to put on internal storage. Tested with low buffer to test and skips happen all the time. Buffer is now at max, 100ms x 8 for 900ms latency and I still get a few skips every song. I'm dying to get Poweramp to work as the wifi sync to PC has been a dream feature and UAPP doesn't even have ratings so I'm dying to get this to work before I resort to neutron. Beyond what else could prevent these skips, If it's just a performance issue is it possible to just implement a larger possible buffer? I like Poweramp too much and wouldn't mind a massive buffer as once the music is playing it's playing. Thanks for any advice Also last second question, trying to play at 44.1 on hi res to avoid resampling to 48 sends out massive buzzing and slowed playback. Is this a limitation of the DAC in the v20? Cheers
×
×
  • Create New...