Jump to content

JohnnySapphire

Approved Members
  • Posts

    22
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Poweramp Knowledge Base

База знаний Poweramp

Poweramp知识库

Poweramp Equalizer Knowledge Base

База знаний Poweramp Equalizer

Posts posted by JohnnySapphire

  1. 6 minutes ago, Wgesh said:

    @JohnnySapphire

    So I'm not crazy! This WAS a thing before. I have the exact same issue where all my album art is gone since the titles aren't exactly the same. I'm going to keep poking around for another fix but I might go and write a Python script that sets all the songs' title metadata to whatever the filename is, excluding the extension. I'll update back here once I find some solution.

    Yeah, i only also noticed this when i re-copied songs to my phone. Only those in that copy had this issue. As soon as i did a "Full Rescan" as recommended in this thread, it created the problem for the rest of the 4,000 songs...

  2. Just had this same issue. After a full Rescan all of my 4,000 songs now don't show my selected custom artwork and for some reason this does not apply to songs with numbers in their filename. Do i have to do a batch rename of all my album artwork to include ".mp3" at the end? then manually go through and delete it for those songs with numbers in them?

    The old way was great where you could set it to display the filename, but ".mp3" was not shown in the lists or PA main screen song title.

  3. 59 minutes ago, andrewilley said:

    In PA, using the Delete Song feature in a folder or album view for example? Or in PA in the Playlist view (where you can select Remove from Playlist AND delete file at once)

    Yeah deleting songs from PA itself seemed to fix the issue on both .M3U and Internal playlists and removing all instances of that file in all playlists. 

    If the file is deleted from the phone (outside of PA), you will need to go back and remove the playlist entries manually it looks like, but this is totally fine for what i was doing and will always delete from PA (The file, not just the playlist entry). Previously i was always deleting from the phone or moving files off the phone.

    thanks

  4. 17 hours ago, andrewilley said:

    I suspect that the new 'resolve' feature only works with internal (database) playlists, it should not delete contents randomly from file-based lists. Try converting such a list to an internal playlist: Long-press on an .M3U playlist within the library, and select Add to Playlist. That will copy all of the entries from the file into a new internal playlist. Then you can see if the entries in that version are removed from the new playlist when you delete one of the contained files.

    Andre

    Just tried this and still the same problem with an internal playlist.

    1. Copied all playlist entries from .M3U playlist to new internal playlist
    2. Deleted one of those song files from the phone itself.
    3. Did rescan, and the resolve at the playlist library and folder library an ind. playlist and "missing entry" still remains.

     

  5. 2 hours ago, andrewilley said:

    Try going into the Playlists library category, tap on the three-dots menu icon, and choose "Rescan / Resolve Playlists". You can also set an option to do this during automatic scans too.

    I'm assuming your playlists are all internally created ones, not file-based ones (from .M3U files, etc)?

    Andre

    Thanks.

    • Playlists are .M3U files
    • Tried the Resolve/Rescan at playlist level and playlist overall library level (have this set to ON to auto scan already)
    • Tried Library rescan
    • All the auto scans and rescans are set to ON

    Deleted song file still remains in all playlists after this. Only started happening after build 824. Thanks again for your support. I love PA.

     

  6. Quote

    Build 824:

    • playlist entries now survive storage path changes
      Poweramp now keeps playlist entries even if Music Folders are changed/unchecked, Scoped Storage root changed, storage removed, etc.
      New Playlist menu action to Rescan / Resolve Playlist
    • new options:
      • Library / Playlists / Remove Playlist Entries On Track Deletion
      • Library / Playlists / Resolve Playlist Entries

    I've noticed ever since Build 824 that the above works as intended, but is sort of creating a headache.

    If i have a song in 5 different playlists and delete it from my phone, the non-resolving entry remains in all 5 playlists, unless i manually go through each of the playlists and remove it.

    Even with the following setting turned on, the empty missing song entries will still remain in the playlists after the song is deleted from the device. Is this intended, or an issue on my end?

    • Settings > Library > Playlists > Remove Playlist Entries On Track Deletion (ON)

     

  7. Quote
    • Library / Playlists / Resolve Playlist Entries

     

    Can anyone else confirm is this is working for them as far as moving a song to a new location and it updating the playlist entry for that song to the new location automatically?

     

    Whenever i move the song, the playlist entry remains, but never get re-linked after i do "Rescan / Resolve Playlists" or the "Rescan" options. Just receive a "Failed to play file! Missing Entry" message when trying to play the song.

  8. My apologies if i am missing a setting or something else here. I recall this working correctly in PA v2.

    If you press "Shuffle" or "Play" buttons while in a list, it simply starts playing/shuffling music and stays in the list, even if you have "Play and go to Main UI" selected under "Library > Lists > List Item Click Action" and does't seem to utilize that option for these because they are buttons. Would be super rad if we could have the option for those buttons the same as the "List Click Action" to start playing and go to Main UI like in v2.

    Thanks so much!

    • Poweramp 3.0 Build 816
    • Samsung Galaxy S7 Edgel
    • Android 8.0.0
    • Stock Rom
    • Poweramp 3.0 Build 816
    • Samsung Galaxy S7 Edgel
    • Android 8.0.0
    • Stock Rom
    • Submitted this in the form too

    When you add a song to a playlist (rather it be new or a duplicate song), it will display the same message of "Done" regardless if it is added or not added, due to it being a duplicate song with "Don't add duplicates" checked in the settings. There is no way knowing if the song was actually added or not added as the same message is displayed.

    In PA v2, the message would state: "0 files added" if it was a duplicate song and not added, and "1 files added" if the file was added. This was very helpful in knowing what files are not being added as new or if they already exist.

    Steps:

    1. Check "Don't add duplicates" (Settings>Library>Lists>Don't add duplicates)
    2. Add a song to a playlist that doesn't exist > Message will state "Done".
    3. Add that same song to the same playlist as a duplicate > Message will state "Done", even though the file wasn't added a 2nd time. Message should state "File was not added" or "0 files added" to let the user know it was not added.
  9. 56 minutes ago, JohnnySapphire said:

    You nailed it. This is why. I always made my playlists like you did above with relative links, thus they auto find/re-link once the playlist is imported.The reason my latest issue removes it is because i added those songs to the playlist inside Poweramp, which is why Poweramp does not relink them. It only relinked the songs i added to the playlists on my computer, not inside PW. Solves the reason behind this. 

    To add to this, i did some testing this morning. As soon as you add a file to a playlist inside PA, it completely wipes out the relative paths for ALL songs in that playlist. So the only way to keep that format intact is to never add a new songs to the playlist via Poweramp.

     

    Before:

    ../Disturbed - Are You Ready.mp3
    ../Disturbed - In Another Time.mp3
    ../Disturbed - The Best Ones Lie.mp3

     

    After: (added only Ice Cube song from inside Poweramp)

    /storage/4052-26FF/Music/All/Disturbed - Are You Ready.mp3
    /storage/4052-26FF/Music/All/Disturbed - In Another Time.mp3
    /storage/4052-26FF/Music/All/Disturbed - The Best Ones Lie.mp3
    /storage/4052-26FF/Music/All/Ice Cube - Arrest The President.mp3

     

  10. 13 hours ago, Absinthequ said:

    I found an easier way to make m3u's for Poweramp and no need to edit them after moving files. I used to create temporary folders and m3u playlists using winamp every time I added music and later I would move things around and I would redo the playlists to reflect the new locations, but I found Poweramp only needs a list of the files, the folders and all that other crap in the m3u don't matter.

    For example if you open your m3u playlist in notepad it will probably have a bunch of useless #EXTM3U info and the locations of the files something like this:
    ../sort/2018rock/Weezer - Zombie Bastards.mp3
    ../sort/P.O.D.-Circles-2018/P.O.D. - 11 Home.flac

    But all you need is to open notepad and save a list of the file names as a .m3u something like:
    ../Weezer - Zombie Bastards.mp3
    ../P.O.D. - 11 Home.flac

    If you move the files or rename the folders a full rescan or resync of the m3u repairs the playlist for the new file locations. No need to edit the playlists.

    The direction of the / \ doesn't seem to matter and my list requires ../ because my playlists are in Music/playlists/ and I need to tell it to jump back out of that folder and start looking for files at Music/

    You nailed it. This is why. I always made my playlists like you did above with relative links, thus they auto find/re-link once the playlist is imported.The reason my latest issue removes it is because i added those songs to the playlist inside Poweramp, which is why Poweramp does not relink them. It only relinked the songs i added to the playlists on my computer, not inside PW. Solves the reason behind this. 

  11. 1 hour ago, andrewilley said:

    As soon as you remove a song (OK copy it, but still removed from its original location) PA considers it deleted and will remove it from the library database (and thus any dependencies, such as playlists). The same title may reappear elsewhere, but PA has already removed the old entries by then.

    Thank you. This would explain why it links missing files in playlists to their new location on import, but not when they move AFTER the playlist is already on the device.

  12. Not sure if anyone has brought up this question already (looked through search).

    When you have a song in a playlist (.m3u) and move the song to a new directory on the phone, PA removes it from the playlist after the next scan. Is there any way for it to just keep and re-link the file in playlist to the new folder automatically, just like it re-links songs in a playlist when you import a Playlist into PA?

×
×
  • Create New...