Jump to content
Poweramp

tmz

Approved Members
  • Content Count

    21
  • Joined

Posts posted by tmz


  1. Hi @maxmp. The issue I have is when using the system navigation gesture at the bottom of the screen to switch between apps. Doing so often (but not always) is caught by Poweramp and treated as a track forward/rewind gesture. Usually this happens in addition to the system UI switching apps.


  2. I ran into this today as well on a Pixel 2 XL. I was quite surprised by the behavior. I never knew you could swipe anywhere other than on the album art to chance tracks.

    I think it's strange that if you swipe in between the play back controls that it can change tracks. I've probably done this inadvertantly in the past and not realized what had happened.

    I would be happy if the only active swipe area was the album art, but there are likely others who want it to work from everywhere.

    At the least, I think there should be a larger area at the bottom of the app that is ignored for swipes to support gesture navigation (and likely a little in the sides to ensure the back navigation gesture works).

    Thanks.


  3. Thanks for the reply @maxmp.

    I think it looks worse to crop the top and bottom off images than it does to pad the left/right areas of portrait artwork as is done for the top/bottom on landscape artwork.

    I suppose if someone adds artwork which is many times taller than wide, it will look like a narrow vertical strip.  But this seems true of artwork which is many times wider than tall too.  I guess I'm not sure why one is allowed and the other not.  Don't they both suffer similarly if the aspect is too far out of proportion?

    (As always, thanks for all your effort over the years!  Poweramp is one of the few -- if not only -- non-Google apps I have used since my Nexus One days.  It's wonderful that the only issues I have are so minor.  This is one.  The other wish I have is for non-rounded corners on the artwork -- but I solved that with a custom skin based on the samples.)


  4. 13 minutes ago, Laffer said:

    Interesting. To me, the artwork is still cropped, on 820-play.

    Yeah, I see the same issue even after a full rescan. Artwork with a portrait orientation is cropped at the top and bottom. Artwork with a landscape orientation is handled properly (where I'm defining "properly" as showing the full image, with transparent padding above & below).

    I've been meaning to post about this in the bug reports forum but have yet to get around to doing so. It may be that while the issue has been mentioned a number of times it simply hasn't been seen by @maxmp or it's just down the list still.

    I'd be happy to see it fixed but since I haven't posted any detailed report in the right thread, it's certainly not bugging me too badly. ;)

    Here's an example, followed by a view of the album art selection dialog showing the dimensions of the embedded artwork):

    Screenshot_20190201-163034.png

    Screenshot_20190201-163059.png


  5. I don't even think black bars are necessary.  In previous versions it was transparent.  As far as I can tell (or rather -- recall at the moment), only artwork where height is greater than width still suffers from this issue.  Perhaps this is already on @maxmp's list of bugs being diligently polished?  If not, I'm also in the group that would love to see it improved.

    I run into this most often on live recordings where the artwork is from the poster sold at the show.  The posters are almost always taller than they are wide.

    (I should also note that it's one of the only minor issues I've got.  I've been running v3 since the alpha days and it's been pretty solid.  I'm happy to see the regular updates polishing what must be a long list of smaller and smaller issues.)


  6. 2 hours ago, andrewilley said:

    I think it is related to specific files not scanning properly (special characters in tags or filenames for example). The problem is that it's hard to spot which ones are missing from the Library with that many songs.

    Yeah, I agree. I've seen that before.

    I was curious so I checked my library. I found a few files (less than 10 out of 12k) where Poweramp was unable to properly parse the length. It then excluded them as too short based on my setting for excluding songs less than 6 seconds.

    For anyone missing files, it's worth setting that option to include all tracks to see if the missing tracks show up.

    As far as finding missing files, I used a few commands in a terminal (I use termux, but I believe the built-in commands should work as well).  Here's a quick overview of the process I used.

    First I created a playlist of all tracks in Poweramp via Library -> All Songs, select all, add to playlist. Then I exported that playlist.

    Next, generate a list of all music files on the sdcard (add/adjust paths if you have music in other locations):

        find /storage/emulated/0/Music/ -name '*.mp3' -o -name '*.m4a' -o -name '*.mp4' | sort -u > all-files

    Then sort and filter the output of the exported Poweramp playlist:

        sort -u /storage/emulated/0/Playlists/all.m3u8 | grep /storage/emulated/0/Music/ | dos2unix > all-Poweramp

    Finally, list files on the sdcard and not in Poweramp library:

        diff -u all-{Poweramp,files} | grep ^+/ | sed 's,^+,,' | sort -u

    Maybe this will be helpful to someone else. At the least, it helped me find a few odd mp3's and confirm that Poweramp had done pretty well parsing my reasonably large pile of music.


  7. 51 minutes ago, cristi.neagu said:

    I'm not sure if it was version 708 or 709 (didn't use the player in that period) but the notification widget and the lock screen controls are finally working for me. They haven't been working since I upgraded to Android 8.1. Not sure what you changed, but don't change it back.

    That was one of the (very welcome) fixes in 705, backported from the 790 beta-preview.  The numerous fixes in 705-709 make waiting for a feature-complete beta much easier.

    The announcement for 705 is has a list of the changes.


  8. 12 minutes ago, snakefist said:

    Which V3 build got the most features as of right now. Since i bought it from google play will i be able to use these test builds with the google play version of Poweramp unlocker?

    The 70x builds are more complete in terms of features.  They're the alpha builds for 3.0 and lack the new UI.  That new UI is part of 790 which is a preview of the forthcoming beta for 3.0.  The 790 build lacks a number of features still, so it's not as suitable for daily use (IMO).

    All of these builds can be installed if you bought the unlocker from the play store.  If you plan to use the 708 build, you can likely just wait until the play store updates it.  It sounds like that's been uploaded by @maxmp already, so it's just waiting on whatever Google does before it's available in the play store.


  9. 8 hours ago, maxmp said:

    It was always there, in uni (==web site) versions, used to unlock full version for given account. Beta has no such permission as it requested when needed, but alpha doesn't have this code (and have lower target API).

    Ahh, thanks.  Now that you say it, I've probably seen the answer before.  It's been too long since I installed an update from the forum and my memory failed me.


  10. 12 hours ago, last resort said:

     

    You need to enable Scrobble via Official Last.fm app in in Poweramp. Also take care about battery saving features your smartphone may have. This could kill simple last.fm scrobbler when you disable your display.

    I've posted my complete settings here and I don't have any problems with scrobbling:

     

    There's clearly many factors at play here. I have no scrobbling options enabled in Poweramp and scrobbling is working well. Best of luck in finding settings which work for you Dan!


  11. 7 hours ago, DirtyDan said:

    my main problem is scrobbling is broken af in alpha but I'm using alpha because v2 doesn't have an option to lower volume on focus change, pausing is incredibly annoying when driving, especially with navigation.

    If you don't enable scrobbling in Poweramp and just let Simple Last.fm Scrobbler detect Poweramp and enable it there, scrobbling works fine. This was my only issue with the alpha initially, which is, thankfully, easy to avoid.

    Now it's the notification controls in Oreo which bug me the most (though clever_man does have a substitute app to provide those).

    Hopefully we'll see v3 before the next Android release exposes more issues.


  12. Here's hoping Max gets that OTA soon and can fix this sooner rather than later.  It's a real pain for usability.  It affects the lock screen controls as well, which I use as much or more than the notification controls.  When it started occasionally in 8.0 it wasn't so bad.  Now that it's permanently broken in 8.1, it's far more frustrating.  I'd bet that it's related to the setColorized() method that was added to NotificationCompat.Builder (and likely --hopefully-- a relatively easy fix).

×
×
  • Create New...