Jump to content
Poweramp

Ecksdee

Approved Members
  • Content count

    12
  • Joined

  • Last visited

About Ecksdee

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I can also confirm this. No go with 790, working good with 709. Axon 7, 8.1.0, latest AEX. by the way PA 709 reports "Variant: Direct HD" now. Hope 790 gets support later on...
  2. @Seve-s @SynekPablo You guys are making a mess. We know for sure that the AK4490 is working on custom ROMs and doesn't get switched to the "secondary DAC" (ZTE cust support reports it's the low power DAC inside the 4961 but it doesn't matter at all) even when running Atmos. Supposedly this makes the speakers worse since they should be using the low power DAC. Let's just cover the facts: -In Nougat (stock and custom alike) Neutron was able to get direct_pcm output. In Oreo stock it won't be able to. -Max achievable is 192/24, though they say it's truncated to 16 bit for some reason, but nobody really tried -Atmos switches to the low power DAC -AEX has a CAD driver specifically made to be able to change the DAC filters, i.e. it sounds (subjectively) better than stock. It's sort of a custom kernel. Try AEX-O. I'll try to dualboot some ROMs later and check if i can make Neutron or Poweramp work on them. Neutron doesn't seem to work on stock O-B01 even though i've tried with every output possible (including direct_pcm) @Seve-s Could you link me to the schematics you were talking about? Just curious... Btw I'm Choose an username... on XDA. We probably talked before lol
  3. then why exactly did you post on a hi-res request thread if you have hi-res working? ?
  4. Right now I'm on Stock Oreo (8.0), for the G version. It's never worked, even with the older version from here (709?) either on Marshmallow or Nougat. About a month ago the official Oreo 8.0 update got leaked and it also doesn't work with 709 or 790. 790 reports happily that it is working at 192k or whatever you input it, but dumpsys media.audio_flinger says otherwise (outputs through mixer at 48k) Also, hi-res audio works in Neutron, even in Nougat custom ROMs (All of them are patched to use the AK4490). One more thing: The stock ROMs have a switch, to select the lower power DAC that's in the AK4961 codec. I don't know if this would interfere with Poweramp at all, but since custom ROMs are seemingly hardcoded to avoid using the 4961, it shouldn't be the problem, right? I'd say it's pretty easy to get a new Axon7 on Europe, a friend almost bought one for 250 euros on Spain. And there are surely some used ones around. Any file that you need, or test, just tell me Edit: I've downloaded a 192khz test file (since i formatted a while ago) and took a screenie of media.audio_flinger. no idea if this would help at all Right when I select OpenSL HD as the output, the volume goes down significantly (I have to crank the volume up to almost full scale) so that might be an indication of the AK4961 kicking in or something, can't be sure at all.
  5. Actually, it was on /vendor/etc instead of just /etc... I don't know. @maxmp that'd probably be useful to have written somewhere in the OP, because I legit had no idea why I was missing the damn file ? Here it is. No wonder it supports 192k audio_policy.conf
  6. Axon 7, pretty please? AFAIK Poweramp has never been able to output to the AK4996 DAC at more than 48k. Neutron is able to output 192k/24 without too much trouble. I guess it'd not be easy to output hi-res properly on this phone because ZTE has these weird quirks here and there, but if you need any file from the system i can definitely fetch it for you. edit: on another note, i can't actually find audio_policy.conf under /etc... I have audio_effects.conf though. No idea why, maybe it's 8.0 related, or because i have V4A?
  7. Well, if you check here once a week you should know that he doesn't even respond Andre's emails from time to time
  8. There probably will be, so I'm checking every couple of days or so. It's not like I'll waste my time or whatever, it's just a 2 minute check. If you feel like 2 minutes of your life every 2 or 3 days are too valuable, then yeah, go put up with Neutron... As long as Max is alive and the update is not out I'll keep checking this thread
  9. Of course he can, he's not some Apple user, he can take one of those newer Samsung devices he has and slap LOS 15.1 on them. A bunch of devices have Oreo LOS ROMs and a dev wouldn't be afraid of flashing LOS... My father has a Moto G 2 and I've installed an unofficial LOS 15.1 on it, with MicroG. He gets 5 hours SOT over 2 days. my point is, it's not like custom ROMs are experimental stuff, and a dev could damn well use a custom ROM for testing an app. From the inhumane amount of phones that Max has, he surely has at least one with Oreo already. Have yoh ever seen the phones that he uses for testing? P.S. I read about 45 pages in like half an hour, then came here every couple days to see what happens. I don't believe there's anything wrong with leaving this as-is, but if you really want to get it clean, I believe the best way would be opening a new thread where we could start from zero (with Max's posts quoted) and close this one
  10. Sure. After he couldn't do it for the May deadline. Or all of the other deadlines... There's no way to know for certain, let's just hope we'll have it sometime around January
  11. Damn, thanks for saying that. I've been using Swift Black for ages and the only missing piece was a browser that rendered the background black. I've been using Firefox Nightly a lot too without even thinking about add-ons... I really don't care how Poweramp's UI will look like, as long as the Swift Black guys theme it all's good
×