Jump to content

MaxOfS2D

Approved Members+
  • Posts

    15
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Downloads

Poweramp Knowledge Base

База знаний Poweramp

Poweramp知识库

Poweramp Equalizer Knowledge Base

База знаний Poweramp Equalizer

Everything posted by MaxOfS2D

  1. No, I don't have File Access Legacy Mode enabled, and I've never touched that setting. EDIT: I've tried turning it on, selecting my music folder, and this interestingly this actually duplicated every file, even with a Full Rescan... I think it was seeing every file through the legacy mode AND the new mode. Had to temporarily disable Legacy Mode in order to remove the new mode's access there. And upon rebooting, Poweramp complained for a second that it couldn't see the files, but a couple seconds later, everything was fine! So, yeah, Legacy Mode actually works fine for me through reboots. The Poweramp app has all permissions granted already. "Remove permissions if app isn't used" is not enabled. I've attempted removing all permissions (including "external storage" ones) then granting them again, but this did not solve the issue. Through the log generation feature I see a bunch of errors identical to this one on rescan failure: 12-23 04:28:22.542 4325 7351 E dirscanner.c: native_readdir !fail errno=Operation not permitted The fact that the issue can get fixed simply by tapping "music folders" then immediately backing out, without changing any settings, is quite odd to me... I've sent the full log via email.
  2. ... until I go to Settings > Library > and hit "Music Folders". I don't have to change anything. I immediately back off of that menu and the files become visible to the app again! Other things I tried but which didn't change anything: regranting permission to the SD card, granting permissions to my SD Card/Music folder instead of the root, rescanning or full rescanning. Nothing besides accessing the "Music Folders" selection interface, and ONLY accessing it (no need to change anything selected in there) fixes the issue. This is why I've created a new thread since this doesn't seem to be the problem other people are having with the 1O to 11 upgrade that requires you to fix external storage permissions. I've already done that and it has no effect on this specific bug. This is on an Exynos S20+ whose apps and their settings were transferred over from another phone using Smart Switch (settings were therefore restored without the use of Poweramp's own feature), and which was then upgraded to Android 11 just a few hours after that. Video captures of the bug: BEFORE the reboot: AFTER the reboot:
  3. Chiming in with the same problem... I think it started happening around May for me After a while, Poweramp just starts using so much CPU that it noticeably heats up the phone. In my battery history screenshot, I plugged in my phone and went to sleep with music playing... 45-ish minutes later the battery temperature went up from the increased CPU usage The only fix I know of is force-closing Poweramp manually. My Galaxy S9+ (Exynos) will actually force-close Poweramp all by itself without asking (prompting the "Poweramp was killed!" message in the app) if it's not playing music after the bug starts happening. If there's any more information that I can give to help troubleshoot the problem I will gladly do so. The suggestions stickied at the top of this thread did not help.
  4. It did! Running a rescan while my file-based playlist is active is not pausing / restarting it / breaking shuffle anymore. Thank you :)
  5. As of 804 a rescan still exhibits this behaviour, however now it pauses when the track gets reset to the first one. (it still arrives at the same timestamp too)
  6. Yeah, I made a thread about it here:
  7. Yep, I can confirm that disabling "initial rescan" fixes it and that it is responsible for this issue on my device. Thanks for the speedy reply In case this is important info: I'm on a Galaxy S7 Edge (SM-G935F) with Android 8.0, and all of my music library is on a SD card, not the phone's internal storage. I can also reproduce this issue with a manual scan! See this video:
  8. After a cold start (app wasn't in memory or was force closed), the previous song will play for a few seconds, and then seamlessly switch into the very first song of the playlist, at the same timestamp. After that, shuffle is broken: the songs play in order (which is, in my playlist, alphabetical sorting) until you fix shuffle by picking a track manually or switch playlists back & forth. Here's a video of the issue. Note that I am not triggering the first track switch: that's the bug. The button doesn't light up and you can't see the little "touch feedback" dot, which should be proof enough I'm not messing with you
  9. It is supposed to shuffle WITHIN playlists, but not BETWEEN playlists. That's what "shuffle songs & categories" does. Imagine playlists are a letter and songs a number. "Shuffle songs" would do: A2, A8, A4, A3, A1, A7... and if you change playlists, manually, of your own volition, then it's B3, B9, B5... "Shuffle songs & categories", however, would give you A2, A4, B3, A8, C1, A7, B9... That's how it worked in in previous versions (build 701 iirc) I think the queue is irrelevant to all this.
  10. That would cause playlists themselves to be shuffled; "shuffle songs" is supposed to shuffle only within the current playlist and not jump to other ones randomly.
  11. I use "Repeat List" and "Shuffle Songs" along with playlists. Unfortunately, while in playlists, the new build plays songs in order. An odd behaviour in this case is that, even if you go select a track way down in the playlist, e.g. around the middle of the list, the next track will go back to the beginning. After I did this a few times, it started always going back to the 4th track. I have another playlist (with 315 songs) which does something even weirder: its "shuffled" order is always 1st track > a specific track close to the end > the very last track of the list > then it goes a specific track 1/3rd of the way down and starts playing everything in order. If I deviate from this, it goes back to the very last track of the list, then back to the track 1/3rd of the way down, and everything in order again. "Shuffle Songs" still works properly while in every other category as far as I can tell ("all songs", "albums", "artists", "genres", etc.) I've made a YouTube video of this Hope it helps!
×
×
  • Create New...