Jump to content
Poweramp

All Activity

This stream auto-updates     

  1. Past hour
  2. Today
  3. I would love to see support for srt files. They are lyric files that has time stamps according to the song. So when the artist says the lines the words comes up. This is the only feature i would like to see as this would make it the perfect app.
  4. VERY ODD, slightly annoying. CURRENT SPECS: Phone: Samsung Galaxy S9+ Android 9 App version: v3-Build-823-play (full version) Nothing custom other than 128gb micro sd that my music lives on. ISSUE: Occasionally / inconsistently, after 10-16 hours of continuous use (no attached audio device, just using phone speakers) songs are still playing but audio has stopped. Media volume fine. Other apps with media create sound no problem. Close and open Poweramp, still no audio. Skip to next song, previous, different playlist, still no audio. If I pull the media back (like rewind for a few seconds), audio starts. 100% consistent fix for terribly occasional bug. Issue started when v3 came out. NOTE: Not really expecting a fix - just found it really .... odd. More of an FYI.
  5. Hi all, I'm using Poweramp on a PX5 type android headunit (Xtrons branded) and really need to find an answer to this issue as Poweramp has far and away the best interface for in-car use. I'm on V3 build 823 - full version installed on an Android 8.0 custom ROM. I'm using a 128gb micro SD card to store my mp3s which is almost full. The folder structure is Audio/Artists/Artist1/Album1 etc, etc with multiple artists and albums inside the relevant directory. If I add the Audio file as a whole to the library and then scan it will take around half an hour but then either find a few random tracks, or none at all. The only workaround i have found is to add them in batches (eg Artists A-C, then D-F, etc). Is this a bug with the scanner, am I simply overloading it? Many thanks for any help.
  6. gdeff

    Fine control over seek

    Oh, it can definitely work that way, if so designed. See the Audible app for an example of a linear seek with rate that slows as you move finger away from bar.
  7. NicoleS

    Poweramp crashing with Android 9

    Same problem... CURRENT SPECS: Phone: Samsung Galaxy S9+ Android 9 App version: v3-Build-823-play (full version) Nothing custom other than 128gb micro sd that my music lives on. ISSUE: App stops and complains about being killed. (see mmhmmm.killed.jpg) Reasons this is likely incorrect: - Happens when phone is connected to charger and at 100% battery (I'm no expert, but Android app lifecycle should not end if there are plenty of resources from what I do know...) - This message is shown after it is re-launched for a SECOND time. ---- Ex: What? no music! Unlock phone. Poweramp says it was killed, and has re-launched automatically but is not playing. Click close button (see mmhmmm.killed.jpg). Poweramp IMMEDIATELY closes/crashes AGAIN, and GIVES SAME KILLED EXCUSE. - App settings are as generous as I can set them (see all.good.jpg) Even if my phone settings ARE the problem, would I have to turn off all battery saving options? I don't see how to add an exception like you suggested (see no.exceptions.jpg)
  8. andrewilley

    v3 build 823 - High Battery Consumption

    Yes, please, otherwise threads can get a bit muddled. The closing might (ironically) be caused by Android power-saving features being too aggressive. Andre
  9. Rizwan Tahir

    High res output not working after pie update

    Have done it.. Still it is the same
  10. blaubär

    High res output not working after pie update

    Try the "Restore Defaults" button.
  11. High res output stopped working for wired headset after I updated to pie.. Is it a problem with the player or the pie rom... Please fix it because that high res output was really the standout feature of our Poweramp.. My device is honor 8 pro
  12. NicoleS

    v3 build 823 - High Battery Consumption

    @maxmp Thanks for that info. I've just now re-installed and will try with the Chromecast being disabled (I'll keep my fingers crossed too...). Should I post elsewhere about constant crashing/closing and notifications about the app being killed (even when charger is in and it's at 100% battery)? After re-installing I did make sure to set it so that the app can change system settings.
  13. PAfan

    v3 build 823 - High Battery Consumption

    @maxmp, Point well taken. the excessive battery usage may be a combination of PA v3 in connection with something else &/or the interaction with the android OS. However, v3 is definitely involved one way or another. It should also be noted that I do not experience this poor battery performance with other top music players (e.g., Pi Music Player, BlackPlayer Music Player EX). Hopefully, resolution of this growing problem is nearby. FYI, my other specs... Wifi/ON, Google FI/LTE, BT/ON connected to OnePlus Bullets Wireless earbuds. P2XL, android 9
  14. maxmp

    v3 build 823 - High Battery Consumption

    @NicoleSPoweramp v3 alone is not cause of your battery issue (see my posts above with the screenshots). Yes, there can be Google services associated issues, but Poweramp itself is the most optimized Android player out there, it's even able to be better than (stock player) "hardware" optimized playback on some devices (it's actually a specialized hexagon cpu inside SOC, so it's software too) on e.g. Qualcomm platform. Google services are disabled when Chromecast Button is disabled in Poweramp Look and Feel / Player UI settings. If you feel power usage is more than expected, please do a continuous playback and post your battery stats screenshot. Thanks!
  15. I would certainly expect to see a corresponding UP event at the end of a button press. The app that I use for the exact same purpose (headset cable track changing) shows button DOWN and then UP. Andre
  16. There are no ACTION_UP events, that might be the issue.
  17. Are there corresponding ACTION_UP ending events to match each ACTION_DOWN? Andre
  18. Device: Xiaomi Mi A1 Android version: 9.0 Poweramp version: v3 Build 823 Report: The app Skip Tracks Settings and others allow long-pressing the volume buttons to skip tracks: https://forum.xda-developers.com/android/apps-games/app-skip-track-volume-keys-t3914337 It works on every music app I've tried except for Poweramp. Apparently Poweramp does catch the commands, judging by the beeps that I hear after trying to skip to the next or previous track, but doesn't actually skip tracks. The Last Processed Commands list from Poweramp has entries like the following: 09:24:56.422 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON KEYCODE_MEDIA_NEXT ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=172513786 playerState=1 09:24:58.763 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON KEYCODE_MEDIA_PREVIOUS ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=172516127 playerState=1 I tried the Single press, Double/triple press, and Long press settings in the Wired Headset section, but nothing worked. Am I doing something wrong, or is this a bug?
  19. Those songs are only missing from the playlists, they exist. Some of the remaining songs are from SD card 1 as well as 2. So it is not always just the songs from one card missing. Having just created a new playlist in PA I am beginning to doubt whether I have done that with the playlist called 'set' that has entries missing. I know I have made a number of playlists in JRiver and copied them to the DAP (after editing to create the right pointers). This was before I made my DAP my main music center. So I delete songs in PA and create/modify playlists in PA on the DAP. A few times a year I copy the whole lot to my laptop as a backup. The JRiver playlists worked for a long time without a problem. In the past months, probably after a PA update, I lost several lists enterely. Some came back after a full rescan. But I think I have had to restore several lists from my backup. I didn't keep track of what I did in order to make it work again, being happy the problem seemed solved. When I backed up the playlists from my DAP I did so my copying the lists in Windows Explorer. That seemed to be working. Songs added from within PA showed up in the playlists when I checked after copying/backing up. So restoring followed the same route. Copy paste. Not via import/export. Working on this issue, since you asked, I opened a playlist in Notepad. This list, as all others (except for the new 'test' list I just made) are sitting in the root of the internal storage. It shows about a 100 songs, but only 13 show up in PA. All the missing ones are on SD card 1. Though that is selected in music folders and I have done a full rescan. In the other case I mentioned it was less clear cut, because it still contained songs from SD card 1. In settings-music folders I first unchecked the internal storage where the playlists are located. The automatic scan followed, rendering all playlists absent (except the 'test' one I just created). And then I selected the internal storage again. After the ensuing scan it brought back the missing songs in the playlist mentioned above. But not the ones missing from 'set'. In this case are was also no difference between the list in Notepad and in PA. As music folders I have, as always, selected the entire internal storage, the entire SD card 1 and the entire SD card 2. One playlist shows yet another issue. Opening it in Notepad gives 19 songs. In PA however I count 23 songs! The difference are 4 songs at the bottom of the list in PA, all recent additions. But where are they stored? So there is a difference between what was imported/copied and what was added from within PA? But why do the recently added songs show up in one list and not in another ? Yet another playlist shows the following: I recently added 14 songs to it, from within PA. I see them on my DAP screen. When I look at the playlist in Notepad however I see only 2 recently added songs. After that there is a partial reference only: /storage/sdcard1/Hanne Hukkelberg/Rykestrasse 68/07 Break my Body.mp3 /storage/sdcard1/Hanne Hukkelberg/Rykestrasse 68/09 Pynt.mp3 /storage/sdcard2/Lonely-Drifter-Karen/Grass-Is-Singing/1_9_Lonely-Drifter-Karen_Carousel-Horses_6.flac /storage/sdcard2/Lonely-Drifter-Karen/Grass-Is-Singing/1_6_Lonely-Drifter-Karen_Casablanca_6.flac /storage The only irregular symbols in the playlists are underscores in stead of a space. In the internal storage I also have folders from Neutron and from UAPP. Could they interfere? Only 5 gb used of the 25 available on the internal storage, so that can't be it. The playlists I have are a mix of .M3U and .M3U8. Though the content seems the same to me. Could the fact that I have 2 SD cards of 400 gb play a role? Hopefully this brings you a bit further. George
  20. I know better one which worked for me it's called NavBar apps (it's free, and there is even navbar coloring feature so you can match your navbar color with app color). I was using it until Samsung let hide navbar totaly (gestures feature now in OneUI) and it worked totaly fine hope this hepls you
  21. andrewilley

    Playlist m3u detection broken since 823 update

    Do all of the 'missing' songs appear in Poweramp's main library views - e.g. All Songs, Folders, Albums. If not, then the problem could be in scanning permissions (check Settings > Library > Music Folders). No song can be shown in a Playlist in PA if that song is not present (scanned) in the main library database first. When you said you created M3U playlists within Poweramp, do you mean you first created them as internal playlists (which is the only way you can do it in PA) and then used the 'Export Poweramp Playlists' feature to create .M3U8 versions? What do the files actually look like if you open them in a text editor, do the paths and filenames match your device's file system correctly? Are there any unusual characters in any of the filenames or paths (international characters, etc)? If so, try renaming any .M3U files to .M3U8. Andre
  22. Indeed it has happened before after an update. Some playlists gone entirely, others wiped (almost) clean. This time no lists have gone but a series of entries in at least one particular list have. This is definitely recent since I often play from this list. I created the list within PA and added to it from within PA. All my lists are .M3U. In the course of the existence of this list I have copied it back and forth to my laptop. Either to make a backup or to restore it after another destruction by a PA update. Not sure if anything changes during this process, don't think it does. In any case, this time round the playlist is still there, only curtailed. Maybe there is something in the following: I also USB Audio Player PRO (UAPP). The reason for this, by the way, is the fact that Poweramp had never implemented HiRes for my Pioneer XDP-100R, though I have asked for it 3 years ago. Anyway, this player also has an issue with playlists on my DAP. It does not show them the regular way. I have to go to the root, tap on a list and watch a conversion/parsing process into something that can be read by the software. I cannot add to a playlist. This parsing has to happen every time. I noticed that one playlist has 250 songs in it in UAPP but only 69 in PA. More playlists have this discrepancy. Looking into it further I also noticed that UAPP does show songs from SD card 1 as well as SD card 2 while PA only displays songs from SD card 2 in the PA playlists with this difference in number of songs. Could that be something? Though it does not explain why one particular playlist has lost a series I have done a full rescan after the update. The cards have not left my player for a while.
  23. cal79

    No new album art only on Artists tab

    Great tip, thank you Andre. Cheers!
  24. blaubär

    Fine control over seek

    As I see it, this finer control is due to the rotary nature of the volume control : the perimeter of a circle grows with the distance from the center, so you have finer control if you move your finger away from the knob. With a linear control as the waveseek bar this won't work.
  25. NicoleS

    v3 build 823 - High Battery Consumption

    Super frustrated. I loved this app back on V2. Now it's beyond awful. Yes, I've uninstalled, restarted phone, reinstalled. CURRENT SPECS: Phone: Samsung Galaxy S9+ Android 9 App version: v3-Build-823-play (full version) Nothing custom other than 128gb micro sd that my music lives on. ISSUES: - High battery consumption. - Crashes (but claims it was killed) - Music ends up with no audio but is still playing DETAILS: Had Poweramp on last phone also, worked perfectly with S8+ and Android 8.0 - got a S9+, also Android 8.0 and things still great. Then v3 came out. I listen to music pretty much every moment I'm not at work. V3 starts crashing occasionally when left on overnight - after 10-16 hours since I start app when I clock out. And sometimes it's still playing but no audio. Media volume fine. Close and open, no audio. IF I PULL MEDIA BACK (REWIND) AUDIO STARTS AGAIN. Weird and annoying, but not worth effort to post here. Then Pie. Battery drained in less than 6 hours, even when app not in use. Google Play Services killing it. Flip out at Samsung. Safe mode has normal battery consumption. Leave safe mode, battery drained too fast again. Meanwhile app keeps crashing, and then complaining that Android is killing it and I need to enable permissions. They're already enabled, and phone is plugged into charger, and at 100%. BS. Half the time after it crashes and lies about being killed I have to start up twice because after the first time it gives killed error it crashes again immediately, and complains about being killed again. Still occasionally audio stops and I have to rewind to get it going. Sometimes I plug in headphones and it doesn't start. On lock screen, if app hasn't been running recently my phone tells me I have to set up a media player, but if it was running recently, app widget is available on lock screen. Now, both Google Play Services AND Poweramp are decimating my battery, and I'm getting complaints about Poweramp using too much cpu. More often than not when I wake up in the middle of the night there's no music. I paid for this app. Not a ton, but it wasn't free. No contact for support except here. Looks like many others have had trouble. Where is the fix at? Really frustrating. Very upset, and uninstalling. Hope this gets fixed so I can use it again.
  26. gdeff

    Fine control over seek

    I love the volume and other controls in equalizer/effects screens of Poweramp. Especially the fine control provided by moving finger farther away from center of volume knob as I'm "turning" it. Is there a skin or setting that can add this finer control to wave seek and static seek bars? That is, finer control over speed of seek the farther finger is away from bar?
  1. Load more activity
×