• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code and is taking some time to get to a beta-test stage. See the forum thread for more details and to discuss.    
maxmp

Poweramp alpha-build-703/704

645 posts in this topic

2 hours ago, djdarko said:

Was the cover art for .cue albums ever fixed in the alpha versions?

No, CUE-based playlists don't support album art at present.

Andre

Share this post


Link to post
Share on other sites

I say sorry, but I want to tell, that I've changed my primary Music Player to Neutron Music Player. I've waiting for months, but I think its enough. I won't forget Poweramp, I look to this forum weekly, but at the moment, I really think, Neutron is much much better. 

Pascal 

Share this post


Link to post
Share on other sites
34 minutes ago, Pascal1999 said:

I say sorry, but I want to tell, that I've changed my primary Music Player to Neutron Music Player. I've waiting for months, but I think its enough. I won't forget Poweramp, I look to this forum weekly, but at the moment, I really think, Neutron is much much better. 

Pascal 

Have to agree , also on neutron. No issues with playback on htc 10 like with Poweramp . 

Share this post


Link to post
Share on other sites

Here's a couple of issues I discovered while using High-Res Output that AFAIK don't happen when using Open EL.

The first is that I cannot change the volume from the device's volume buttons while the screen is off. While the screen is on (even if the device is locked) the volume buttons work just fine.

I have enabled a different number of volume steps for media in my phone's ROM (OnePlus One, Resurrection Remix 5.7.4) and it appears that when I switch playback from my Bluetooth (that uses Open EL and the ROM's media volume stepping) to my wired earphones using High-Res Output and the DVC option, the volume gets exceedingly low. Either disabling the DVC option (and thus returning to the ROM's own media volume stepping) OR rebooting the phone solves the above issue.

Share this post


Link to post
Share on other sites

Hi, excellent work so far. I own a LG G3, stock MM ROM. When I try to enable high-res output I get great sound but when the screen goes off I get frequent sound drop-outs. I played around with the settings but without success. My library consists of mp3s and flacs, both high-res and cd quality. I will keep investigating and report back.

Any suggestions perhaps?

Update 20-10-2016:

Yesterday I did some extensive testing and I found out that the sound drop-outs are indeed due to the screen going off, no matter what the high-res output settings are. I enabled permanent screen on from android settings and there were no problems at all. The same when I returned android settings to their original status and I enabled permanent screen on from Poweramp settings. As far as I can see up to now this is the only problem I have encountered so far. Yesterday with permanent screen on the app was a joy to use! But at the cost of 13% battery for approx. 45min. screen on time.

Hope it is fixed soon!

Share this post


Link to post
Share on other sites

I'm using alpha build 703 and Hi-rest output is working fine but was wondering can I enable MusicFX to use with my phone equalizer to make the audio louder?

Share this post


Link to post
Share on other sites

Samsung Galaxy S4 Mini, Lock Screen Widget: if progress bar is touched (or if you try to forward the song), song will start from beginning, no forwarding possible.

main window (app) is ok though

Share this post


Link to post
Share on other sites

On a Pioneer xdp-100r, the playback rate is halved randomly (0.5x without pitch correction), changing song solves the problem temporarily. Also some audio dropouts,  for like .1 sec.

This by using OpenSL as output, with 4 buffers of 75ms, I'll try with AudioTrack and hear if it occurs again.

Share this post


Link to post
Share on other sites

I'm tired of me without adversely post comments. but Max is now proved lazy. Even after 6 months not published a single development. Not less than 6 months. OK, I understand, it is developing a stand-alone application. but people were tired of waiting. re-create the interface was finished one month ago. but still no update. I hope that in a short time a new update is released. I do not want no more negative comments.

 

Sorry for my english

Share this post


Link to post
Share on other sites
5 hours ago, MMG said:

I do not want no more negative comments.

Jolly good, as that's all you ever seem to post.

Andre

Share this post


Link to post
Share on other sites

Well, i have to agree with MMG... There must be something going on. Either there are a lot of issues with the code or library or something, either Max isn't doing any developing work at all. Probably family/health issues, what can i think of?

He needs to give us another status update ASAP.

I mean, there are already a lot of people on 7.0 based ROM's. And the latest build, 704, is just having some changes for N preview 3, much older system base than the final Android 7.0.

And because of that, for example on my Oneplus 3, High-res audio playback isn't longer working (audio_policy is all good; was working perfectly in 6.0 ROM's). And i have a lot of interface bugs in the menu's, notification color sometimes not inverting, yeah, probably typical bugs that were already mentioned earlier.

But i can't switch to anything else. Poweramp is the best music player ever made :)

Max, please, at least hack together some buggy experimental build and release it... At least something... We need to continue being ahead of the competition, even though there's no other music player app on Android that can compare with the mighty Poweramp! However being out of date with the latest OS's and audio hardware is very bad...

Share this post


Link to post
Share on other sites

There is a lot of work in developing software, and only one of Max to do it.

In the meantime please feel free to revert to using the official release build if you prefer that to the ALPHA test version here --- or perhaps you could write something quicker yourself?

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

There is a lot of work in developing software, and only one of Max to do it.

In the meantime please feel free to revert to using the official release build if you prefer that to the ALPHA test version here --- or perhaps you could write something quicker yourself?

Andre

Why are consistently has defended? . 6 months. too much time. It must have at least minor updates. at least as active should be informed about the process. 1-2 going online except for a few months and do not inform comment.

 
I want to give an example. PlayerPro DSP programmers have renewed the entire package of 2 months. now supports high-definition audio. but I do not want to use external Poweramp other applications.

Share this post


Link to post
Share on other sites
8 hours ago, MMG said:

Why are consistently has defended? . 6 months. too much time.

As I said before, there is only one developer writing Poweramp, and if there is (for example) two man-years of work needed on something, it will take two years to complete. Unless you have a Harry Potter time-turner or a TARDIS to hand?

You are of course free to develop your own player if you feel you can do it better, otherwise I'm afraid we will all have to be patient and wait. Repeatedly posting the same comments won't change anything, and may eventually start getting your posts removed for being duplicates.

Andre

Share this post


Link to post
Share on other sites

Would be good, if a new feature is added. Like a "multiple selection" in track list, album, artist, etc. The idea is select some track or album and manage them (erase, create a new list, add a list, etc). Thanks.

Share this post


Link to post
Share on other sites

I purchased today the full version of this player after a longer test of the alpha last night. I am pretty happy already (using an ZTE Axon 7 with Hi-Res Output enabled).

It is very impressive what the developers (only one?) have accomplished already, I hope the development of this app is going good :)

Please keep up your good work *thumbsup*

Share this post


Link to post
Share on other sites
14 hours ago, Danes said:

Would be good, if a new feature is added. Like a "multiple selection" in track list, album, artist, etc. The idea is select some track or album and manage them (erase, create a new list, add a list, etc). Thanks.

This is already supported for Delete, Enqueue and Add to Playlist.

Do not select a song, but instead press Menu > Enqueue, Menu > Add to Playlist, or Menu > Delete. You can then multi-select songs (or folders) by tapping on them. When you are done, press the middle button at the bottom of the screen to perform the action (the actual text of that button will vary depending on the function you are performing).

Andre

Share this post


Link to post
Share on other sites
8 hours ago, Brainscollector said:

There is some big BS going on here. And like everyone I'm done with promises and waiting.

Did you approach Max directly by email back when you were proposing your great UI suggestions? I did pass on the details of a thread to Max myself, but I don't know whether he contacted you or not.

Andre

Share this post


Link to post
Share on other sites
3 hours ago, andrewilley said:

Did you approach Max directly by email back when you were proposing your great UI suggestions? I did pass on the details of a thread to Max myself, but I don't know whether he contacted you or not.

Andre

No, he did not contacted me and I'm checking e-mail regulary ao i would not miss it. 

Share this post


Link to post
Share on other sites
3 hours ago, Brainscollector said:

No, he did not contacted me and I'm checking e-mail regulary ao i would not miss it. 

Sorry. As I said, I forwarded the details of the conversation but I can't do much more I'm afraid.

Andre

Share this post


Link to post
Share on other sites
On 10/20/2016 at 0:35 AM, Poro said:

On a Pioneer xdp-100r, the playback rate is halved randomly (0.5x without pitch correction), changing song solves the problem temporarily. Also some audio dropouts,  for like .1 sec.

This by using OpenSL as output, with 4 buffers of 75ms, I'll try with AudioTrack and hear if it occurs again.

Well there are youtube rips copied from an old device. Kind of false alarm here. Maybe the audio stream is not really standard (aac 192/125kbps low complexity), doesn't happen on iTunes purchased songs.

Share this post


Link to post
Share on other sites

This player has not been updated for 6 months, will not be updated?
Maxmp nearly 2 months did not pay attention to their own web site

QQ截图20161031135804.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now