• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code and is taking some time to get to a beta-test stage. See the forum thread for more details and to discuss.    
maxmp

Poweramp alpha-build-700

276 posts in this topic

The grant access dialog does not show for sd card editing of tags

So you said earlier (I moved your post to a thread of its own - specific issue bug reports will tend to get lost in this general chatter new-build-upload thread)

Andre

Share this post


Link to post
Share on other sites

I can't seem to add add .milk files.

I copied them to the specified directory both in the internal storage and the external (I had to create the folder "milk_presets" as it wasn't there)

Both rescan options fail to pick up anything new.

Share this post


Link to post
Share on other sites

So far it's pretty good . I really cant complain much since it's the alpha . But since I'm a dj, I think the gapless is not good actually seems to be a bit worse on my galaxy s6. It pauses and the music transition not smooth at all. The old version is way better since some of my mixes go seamlessly. Hope it gapless does get fix for djs like me, that like to listen to our mixes with out pauses.

Share this post


Link to post
Share on other sites

Hi, Im running this alpha since yesterday on my LG G4 android 6.0. So far so good, only reservation is about visualizations which doesnt seem to be on par with music, its seems delayed or ahead (not sure). I also wish I know what is "resampler cutoff frequency" good for (97% is set as default) and what is the best dithering method and if it even should be enabled for mp3 playback.

Share this post


Link to post
Share on other sites

The grant access dialog does not show for sd card editing of tags

As a workaround, try to delete a music file from within Poweramp first and then follow the Grant Access prompts. The mode should then stick, and in future you'll be able to edit tags on SD Cards and/or delete files without further prompting.

Andre

Share this post


Link to post
Share on other sites

Please add at least 24 bit output for phones with 24 bit playback. And if possible please add 32 bit output for the LG-V10. :-) I'd like to see this app as the J.River Media Center for Android. :-)

Share this post


Link to post
Share on other sites

Seems it's working fine!

Is it possible to build on latest android api (target api v23 I think) to make use of android auto backup feature, to backup settings to drive?

Share this post


Link to post
Share on other sites

What version of OS are you running?  I noticed this behavior starting on Android 5.0.4, so I wonder if it's a Poweramp issue, or an OS issue.  If the OS is delaying signalling the unplug (or bluetooth disconnect) to the app, then this would be an OS issue.

I get the same effect if I force-disconnect bluetooth, such as when I turn my car off.  It's annoying, but not a show-stopper.

 

I have been facing this on 4.4.2, 4.4.4, 5.0.2, 5.1 and 5.1.1. It's annoying indeed, but I would love to see this fixed. 

Share this post


Link to post
Share on other sites

I have been facing this on 4.4.2, 4.4.4, 5.0.2, 5.1 and 5.1.1. It's annoying indeed, but I would love to see this fixed.

I wonder if the people who report this issue of sound not stopping immediately when you remove the headset are using the same device, or have something else in common, as it doesn't happen to me (Galaxy Note 3, 4.4.2).

Andre

Share this post


Link to post
Share on other sites

As a workaround, try to delete a music file from within Poweramp first and then follow the Grant Access prompts. The mode should then stick, and in future you'll be able to edit tags on SD Cards and/or delete files without further prompting.

Andre

 

Hi Andre,

 

this was working for me once, but now no chance to grant write access to the sd card. Even with this trick. Hope there will be a fix in the future.

 

But ether way, thanks for your support here and of course a great THANK YOU to Max. I was looking forward to this alpha version since the end of 2012 / Beginning 2013.

The release of this alpha was a nice little after christmas gift a couple of days ago. It sounds great, really enjoying the new sound engine. With my in-ears it´s also a nice improvement but especially with my over ear headphones at home the improvement in terms of the bass is fantastic!! Really nice work!!

Share this post


Link to post
Share on other sites

So far it's better good . But I really canthink complain much since it's the alpha . But since I'm a dj, I think the gapless is not good. It pauses and the music transition it's not smooth at all. The old version is way better since some of my mixes go seamlessly. Hope it gapless does get fix for djs like me to listen to our mixes with out pauses.

I don't really understand why some users have problems with gapless. I myself have always found gapless in Poweramp to be excellent.

It was literally the first thing I tried when I installed the alpha and there was absolutely no delay or artifact between songs.

It is worth mentioning that it was an in-place upgrade and that I retained my previous settings.

 

I tested it using two live albums. One I had converted from the CDs to MP3s using the usual per-track method and one where I specifically used LAME's "--nogap" command line setting per the following guide's Method 2:

http://www.rockbox.org/wiki/GaplessHowTo

i.e. I first ripped all the tracks in WAV and then converted them all to MP3 in one long command line, thus telling LAME which track would follow the one it was currently encoding.

 

In both cases there was absolutely NO gap and no audible artifact between the tracks, however, I found that the album encoded as individual MP3 files without the --nogap option for some reason overshot the track's playing time by 3 seconds i.e, if the track displayed a total playing time of 1:23, the actual playback was 1:26, after which it gaplessly switched to the next track with a 0:00 starting time.

Other media players, like Winamp for instance, display the track switch at 1:23 and start the next track's timer at -0:03. That might have been the preferable option to avoid confusion but it is purely a presentation issue and not a functional one.

 

In case it makes a difference to anyone, these are the settings I use under "Fade, Crossfade, and Gapless":

Auto-advance Fading: Disabled

Manual Track Change Fading: Short

Fade play/pause/stop & on Seek: both Disabled

Cut Silence: Enabled

Crossfade Length" 1000ms

Short manual crossfade & Play/pause/stop fade length: both 400 ms

Seek fade length 100 ms

 

Other than that, the new alpha FINALLY resolved an issue with audible artifacts on certain over-produced albums when listened to with a custom EQ (Primal Fear's New Religion being an excellent example with the rhythm guitar producing an audible wah-wah effect that isn't present in the original).

 

The Album Art issues have already been mentioned so I consider that a Known Issue, however the new audio engine is enough for this Alpha to permanently replace the previous stable version on my phone.

Share this post


Link to post
Share on other sites

So I have a problem. And that problem is that as I'm listening to songs random ones will become slow, like the pitch and bpm is lowered but I didnt change it. Like the whole song it self is playing in slow motion. If that makes sense. But that's the only thing I am seeing wrong other than that it works fine. Is there a way to fix this yet?

Share this post


Link to post
Share on other sites

4.Love the slide out drawer. Makes navigation easier.

I like this too, but I'd actually suggest going one step further for any future UI updates:

I'd suggest that rather than having a slide-out category-choice page at all, left-swipe and right-swipe could take you through the different library category views directly (effectively as tabs, for example PlayerUI -> Folders -> Albums -> Artists -> Genres -> Years -> Composers -> PlayerUI - showing whichever tabs the user has ticked within their Category Settings screen anyway). The bottom (or top?) Tab Titles bar could also be used to slide quickly across to find more tabs by name (not just the Player | Folders | Library choices we have at the moment) and ideally the order should be editable so your favourite categories appear first.

There could even be a new option at the end for creating customised tabs featuring user-defined category grouping and sorting (basically just a slight extension of the current 'List Options' system). Also, adding the facility to incorporate some simple user-defined filters within those custom categories would go a very long way towards addressing the various requests for 'smart playlists'.

These are not really major design changes, but would subtly alter the process flow to make things simpler, easier to use, and more user-intuitive.

Andre

Share this post


Link to post
Share on other sites

So I have a problem. And that problem is that as I'm listening to songs random ones will become slow, like the pitch and bpm is lowered but I didnt change it. Like the whole song it self is playing in slow motion. If that makes sense. But that's the only thing I am seeing wrong other than that it works fine. Is there a way to fix this yet?

Probably not without further information. Does it happen with specific tracks, or specific audio file formats? Is it repeatable if you go back to that same track again, and does pause/restart resolve the problem? Does playing from internal memory or SD Card made a difference?

Andre

Share this post


Link to post
Share on other sites

M4A support in the existing public release is a bit patchy at best (tag support and scrubbing could both be a bit iffy) but the new v3 release should be much better - feel free to give the alpha test version a try and see if it works for you, that's what it's for.

Andre

 

 

OK thanks Andre, just did the Download.  some things I have noticed:

 

>The app keeps playing even after I close it.  Not sure if its something in my settings, but is there a way to stop playing, and dis-allow all background running operations once I close the app?  There are times I do not want apps running in the background. 

 

 >It continues to play for at least 3-4 phone rings when I get an incoming call while listening to music.  Can playback pause be made more immediate?

 

>Default settings are pretty quiet.  I have to turn the volume up higher than I would expect.  I have the Replay Gain setting set to +10db.  Is there also audio compression if I do this?  Is it more dynamic if I leave replay gain at 0, and just crank the volume on the phone?

 

>I too need to follow up on that other thread to see if I can get it to display album artwork.

 

Setup:

LG-V10 Verizon

ESS 32Bit DAC engaged (even though 16 bit redbook CD => .m4a apple lossless is the highest I have at my disposal)

Various headphones from 30ohms - 300ohms

 

My hard drive enclosure just died and I have a new one incomming today.  Once I re-gain access to my library I will post more commentary.

 

So far playing the .m4a and 320K MP3 files I have access too sounds great.

I will also use the V10 as a source for my Darkvoice 337 tube amp and post back my findings.

 

thanks

Share this post


Link to post
Share on other sites

So you said earlier (I moved your post to a thread of its own - specific issue bug reports will tend to get lost in this general chatter new-build-upload thread)

Andre

awesome, thanks

Share this post


Link to post
Share on other sites

hi ! i thought there is  a Very heavy bass on this alpha build ...its amazing if you are listening to say stuff like Dr Dre Compton album for example,the bass is very clean  and bassy if that make sense .....but rock stuff come across as very muffed bass , even with lowering the bass nub a bit , on the normal Poweramp version , bass accommodate all styles . at least for me . i kept rolling back and forth between alpha and normal Poweramp ,trying to compare , but the song  poles apart by pink Floyd  setteld it for me i went back to normal Poweramp , now my setting are eq on treble with bass up more on the last 2 bars and lowered treble a bit on the right 2 bars , the treble and bass dialers at 50 % hope this helps a bit .. thanks .

Share this post


Link to post
Share on other sites

>The app keeps playing even after I close it.

That is by design, it's meant to be able to play in the background. Just press stop rather than closing the app while it's still playing (or you can stop it from the notification panel if you've already closed it).

Audio gain settings are in the equaliser screens (try turning DVC on and pushing the master gain up a bit if you think it's still too quiet when your Android media volume setting is already at max).

Andre

Share this post


Link to post
Share on other sites

That is by design, it's meant to be able to play in the background. Just press stop rather than closing the app while it's still playing (or you can stop it from the notification panel if you've already closed it).

Audio gain settings are in the equaliser screens (try turning DVC on and pushing the master gain up a bit if you think it's still too quiet when your Android media volume setting is already at max).

Andre

OK got it.  I turned on DVC and set all the gains to flat.  That did the trick!!

thanks, sounds great.

 

Is there a way to switch back and forth between album artwork and the animation?  There are times I want to see the album art, and yet there are other times I like the graphic animation for a little while.

Share this post


Link to post
Share on other sites

I'd suggest that rather than having a menu page at all, left-swipe and right-swipe could take you through the different library category views directly (effectively as tabs, for example PlayerUI -> Folders -> Albums -> Artists -> Genres -> Years -> Composers -> PlayerUI - showing whichever category tabs the user had ticked in the Settings screen anyway).

Andre

 

Actually, that's a much less efficient design. To go from various points in that that's multiple swipes instead of one swipe and one tap, especially as you add more tabs into the mix (for example, you don't even have playlist in there). Navitation drawers have a purpose in Android -- navigation. That's what they are good for.

Share this post


Link to post
Share on other sites

very weird , downloaded  alpha 700, tried to install ,it freeze at the installation screen , i  m with lg g pro 2 , f350, with 4.4.2 OS , any clue ???

Share this post


Link to post
Share on other sites

I don't really understand why some users have problems with gapless. I myself have always found gapless in Poweramp to be excellent.

It was literally the first thing I tried when I installed the alpha and there was absolutely no delay or artifact between songs.

It is worth mentioning that it was an in-place upgrade and that I retained my previous settings.

I tested it using two live albums. One I had converted from the CDs to MP3s using the usual per-track method and one where I specifically used LAME's "--nogap" command line setting per the following guide's Method 2:

http://www.rockbox.org/wiki/GaplessHowTo

i.e. I first ripped all the tracks in WAV and then converted them all to MP3 in one long command line, thus telling LAME which track would follow the one it was currently encoding.

In both cases there was absolutely NO gap and no audible artifact between the tracks, however, I found that the album encoded as individual MP3 files without the --nogap option for some reason overshot the track's playing time by 3 seconds i.e, if the track displayed a total playing time of 1:23, the actual playback was 1:26, after which it gaplessly switched to the next track with a 0:00 starting time.

Other media players, like Winamp for instance, display the track switch at 1:23 and start the next track's timer at -0:03. That might have been the preferable option to avoid confusion but it is purely a presentation issue and not a functional one.

In case it makes a difference to anyone, these are the settings I use under "Fade, Crossfade, and Gapless":

Auto-advance Fading: Disabled

Manual Track Change Fading: Short

Fade play/pause/stop & on Seek: both Disabled

Cut Silence: Enabled

Crossfade Length" 1000ms

Short manual crossfade & Play/pause/stop fade length: both 400 ms

Seek fade length 100 ms

Other than that, the new alpha FINALLY resolved an issue with audible artifacts on certain over-produced albums when listened to with a custom EQ (Primal Fear's New Religion being an excellent example with the rhythm guitar producing an audible wah-wah effect that isn't present in the original).

The Album Art issues have already been mentioned so I consider that a Known Issue, however the new audio engine is enough for this Alpha to permanently replace the previous stable version on my phone.

I'm curious what phone do you have? I have galaxy s6 still running lollipop. Honestly the old version runs gapless better for me . Alot of seamless play with minor hiccups here and there .This version I've tried everything including your method and it's not cutting it for me . I guess I'll go back to the old version & keep my fingers cross when the official update arrives & hope it works great for me

Share this post


Link to post
Share on other sites

Actually, that's a much less efficient design. To go from various points in that that's multiple swipes instead of one swipe and one tap, especially as you add more tabs into the mix (for example, you don't even have playlist in there). Navitation drawers have a purpose in Android -- navigation. That's what they are good for.

My thought would be that the category list would still show across the bottom of the list screen as it does now, so you could very quickly pick a category manually (currently, those bottom tab titles only show Player|Folders|Library, but that could be extended to show all of the categories as a simple sliding tab bar - especially if the ordering of those items was configurable so your favourites always displayed first).

My suggestion was mainly to avoid that one extra layer of menu selection each time, but there'd be nothing to stop a list-menu version being available too of course (the code is already there) if people prefer that way. One of the things I've always liked about Poweramp is it can be set up exactly as each user wants, with lots of interface options, rather than the Apple/Google dictatorial "this is how it is, take it or leave it". That's also why AquaMail is my email client and MX Player my video player.

Andre

Share this post


Link to post
Share on other sites

Probably not without further information. Does it happen with specific tracks, or specific audio file formats? Is it repeatable if you go back to that same track again, and does pause/restart resolve the problem? Does playing from internal memory or SD Card made a difference?

Andre

All audio formats are in either mp3 or mp4 but it seems to occur more on my tracks that are in mp4 format. And yes going back to the songs makes it do it again, play and pause do not fix it. It does it with tracks on my phone and on my sd card.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.