Jump to content
Poweramp
Sign in to follow this  
Nerdy3.14159265

Issues with Multiple Genres in tags

Recommended Posts

I'm currently having issues getting music files with multiple genres added in the tags to work correctly. I'm currently using Foobar2000 to tag all my music and a lot of my songs are tagged with multiple genres.

 

The way this is currently being handled in Poweramp, is for it to mash all the genre tags together into one large genre. This ends up making my music get split into weird groups. An example would be if I had a song tagged with House and another that also had Trance in the tag, the first would end up under House (of course) but the second would end up in House/Trance. It would be preferable that the one tagged with Trance and House be under both genres separately; this would avoid making unnecessarily obscure genres for maybe one song that crosses several genres.

Share this post


Link to post
Share on other sites

Poweramp splits Genres by ; which is a standard. If you have song which has proper Genre display in Foobar2000 but not in Poweramp - please send it to poweramp.maxmpz gmail.com for tests.

Thanks!

Share this post


Link to post
Share on other sites

All of my music is separated with ; and works completely fine in Foobar2000. However, that hasn't stopped a lot of songs being under genre/genre/genre (also some are genre:genre:genre) in Poweramp. I'll grab a song to send over and edit this post when it's sent.

EDIT: Email is sent.

Share this post


Link to post
Share on other sites

Poweramp doesn't replace ; to other chars, before build 554 it splits genres by ";",

in bulds 554+ by ";" and "/".

Thanks!

Share this post


Link to post
Share on other sites

Genres tag is just a simple string. Multiple generes are separated by some symbol. Standard is ";" (semicolon), some players also support "/" (slash). 

This way "Dance/Trance/Electrical" becomes 3 genres.

Thanks!

Share this post


Link to post
Share on other sites

Genres tag is just a simple string. Multiple generes are separated by some symbol. Standard is ";" (semicolon), some players also support "/" (slash). 

This way "Dance/Trance/Electrical" becomes 3 genres.

Thanks!

I understand that much. That is literally how all my music is tagged. What I'm saying is that in Poweramp they are displaying as genre:genre and genre/genre.

Share this post


Link to post
Share on other sites

: (colon) is not supported. None of our tracks in our 100Gb test music library has colon used for generes separation, and no such standard exists (if you know one, please give a link. Test files will be useful too).

As for /, you need to do a Full Rescan to force Poweramp to re-read tags. This is for Poweramp build-554.

Thanks!

Share this post


Link to post
Share on other sites

: (colon) is not supported. None of our tracks in our 100Gb test music library has colon used for generes separation, and no such standard exists (if you know one, please give a link. Test files will be useful too).

As for /, you need to do a Full Rescan to force Poweramp to re-read tags. This is for Poweramp build-554.

Thanks!

 

I do not use colons to separate my tags. I said that Poweramp displays my music with colons in them. All my music is separated with the supported semi-colon. Also I sent a test file that is properly tagged that is having the error as well.

 

EDIT: I did force refresh to see if that would fix it because of an update, however, that didn't completely fix the problem. There are still some songs that having been properly read by Poweramp and all the remaining songs display in Poweramp as genre:genre, despite them all being tagged with the standard semi-colon.

Share this post


Link to post
Share on other sites

Hi, This bug has already been mentioned in a post sometime ago by arniom - http://forum.powerampapp.com/index.php?/user/10872-arniom/?tab=posts 

 

I am facing the same issue on my mobile as well. At first I thought it was a problem with the way my files were tagged. I checked with the other players and they all show the genres as separated by a ; (semicolon) but when it is seen in Poweramp it is seen as a : (colon). I edited it within Poweramp to replace the : with ; for a song and then it appears properly within the genre.

Share this post


Link to post
Share on other sites

Have you tried a full-featured tag editor to see what's actually encoded within your files? (rather than just what the apps are re-displaying). Or send a sample file to poweramp.maxmpz(at)gmail.com.

Andre

Share this post


Link to post
Share on other sites

Did you send a sample of one of the files which still does not display properly to Poweramp.maxmpz(at)gmail.com ?

Andre

 

A copy of a file still having the issue of randomly having a colon combining the two genres, has been sent to that email address.

Share this post


Link to post
Share on other sites

This has been annoying me for a long time. However I think I found out what the problem is. Poweramp does not handle ID3v2 tags correctly. You will have to use ID3v1 tags for multiple genres. In foobar2000, right-click a song > Tagging > MP3 tag type and make sure just "ID3v1" is selected. Click Update Files. This will change the file tag to ID3v1. Some of the information in ID3v2 is converted to ID3v1 successfully (the artist, the title), but the genre is not copied to ID3v1, so this conversion will lose all your genre information and you have to write it again. Best thing would be to use a different tool to make the tag conversion (I don't have a suggestion for this yet).

Share this post


Link to post
Share on other sites

Still investigating this. When you add a multiple-genre tag to a file, it will create an ID3v2 tag and it will look ok in Poweramp - so Poweramp does handle ID3v2 tags correctly, but somewhere those tags are not created correctly, maybe in foobar2000 (but also Mp3Tag). Or Poweramp needs both an ID3v1 and an ID3v2 tag - the files that only have an ID3v2 tag are not handled correctly in my case.

Share this post


Link to post
Share on other sites

I confirm, I have the same issue with tags made in Musicbee. Poweramp 2.0.10. 588

UPD: After some discussion and research, I can confirm that it depends on a player, in MB, for example, it was caused by seperate fields for every genre tag, though it displayed genres as seperated by semicolon. After the update of the player, the developer disabled the button for automatic splitting of genre tags, thus the only way to split it with ; is manual one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×