• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code and is taking some time to get to a beta-test stage. See the forum thread for more details and to discuss.    
lasse

Album art not changing when changing tracks

4 posts in this topic

But only one time after opening a track with new album art (kind of). I'm on alpha build 703, on a Samsung Galaxy Note 3, Android 5.0. Bit hard to explain, but let me elaborate:

If I open a track from an album, then open a track from a different album by the same artist or any album by a different artist, the album art will be stay the same. It doesn't update from the previous track. It uses the album art from the previous track. 

However, if I open a track from the same album again first, and then open a third track from a different album by the same artist or any album by a different artist, it will change the album art correctly. 

So this is kind of like an "every other time" type thing. Because if I open 3 tracks from one album, then open a track from a different album, the album art won't change. But if I open 4 tracks from one album, then open a track from a different album, the album art will change correctly. And so on, every other track it works and doesn't work. 

And obviously if I open a track from album A, then open a track from album B, it won't change, but then it will change correctly if I open another track from album B.

Share this post


Link to post
Share on other sites

I've seen some art lag issues in the alpha-tests too, but given that the next release will have a completely new user interface I think we'll have to wait and see how that behaves.

Andre

Share this post


Link to post
Share on other sites

I guess mine is a little different on the album art.

I get this on all albums with track playing. It shows, then when phone sleeps, then I unlock the lock screen and open the app while playing and album art disappears, but skip to next song it shows again. Same process each time. If I skip to next track they all show, but only when the phone sleeps, that the album art disappears.

Also, I checked all albums scrolling down and all arts are there.

Latest Poweramp version

Samsung Galaxy J3 Luna Pro

Stock ROM

I am using Android Marshmallow 6.0.1

Edit: Apparently, it is random when it does it, on the unlock the screen and it shows player open. Actually, I think it is when the player is minimized then opened from recent opened apps and tapped to open then the art is gone.

Share this post


Link to post
Share on other sites

The whole user interface is being rebuilt for the next beta release so the code will be completely new. Hopefully minor bugs like this won't have been accidentally cloned over! :)

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now