• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code and is taking some time to get to a beta-test stage. See the forum thread for more details and to discuss.    

AkashS04

New Members
  • Content count

    3
  • Joined

  • Last visited

About AkashS04

  • Rank
    Newbie
  1. I don't listen to too loud volume. Sound is mostly between 40-53% in almost all cases and rarely I go to 59% level (it increases / decreases 6% once you increase/ decrease the volume). Pre Amo level is around 60% and Extreme Bass preset is used with 90 or 100% Bass and 90-95% treble settings.
  2. Hi, Even I have the same issue. At least 3-4 of my earbuds are broken in last 6-7 months. I use Extreme Bass Preset with 100% Bass and 90-95% Treble and with PreAmp at higher level. Stereo Wide setting is anywhere between 10-15% and I don't listen to high volume so it is mostly around 50% (53% and in extreme cases, 59%). Most of the times it is either 41% or 47% or may be 53%. Can anyone pls suggest? Do I need to use very high Impedence earbuds (I don't use in-ear ones but always use earbud like Monk+ or SHE3800 or recently Vido earbud). Recently my vido earbudis also sounding like broken membrane speaker (right side) and I feel that sooner or later it will also break. Pls help. Regards, Akash
  3. I am using Poweramp for almost 10 months. I use Extreme Bass Preset with Amp Level High (60%) and 100% Bass and Treble and I noticed that couple of my earbuds are spoiled or broken down. Either one of the speakers not working or speaker membrane spoilt and having torn sound in one speaker. Can any one pls sugggest if that could be the reason and if Developer can work on this so even extreme settings will not break down the earbuds. Or using High Impedence earbud will work?