• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It is hoped this will be ready for final beta-testing by the end of the May/early June. See forum thread for more details and to discuss.    
Eckless

Poweramp v3 not working in Android N Preview 3

29 posts in this topic

I know it's a beta, but just a heads up that I'm getting Poweramp force closes on opening with Android N preview 3, which was released today. (It worked fine on preview 2)

Share this post


Link to post
Share on other sites

On developer preview 3 which is now stable enough for daily use.

But when I open up Poweramp (latest test build) it just force closes, which is a shame since I rely on this app every day.

Any notice when it will be supported?

Share this post


Link to post
Share on other sites

The same as me. And I tried to reinstall it. Still not working with crash. Please fix this.

Share this post


Link to post
Share on other sites
6 hours ago, Eckless said:

I know it's a beta, but just a heads up that I'm getting Poweramp force closes on opening with Android N preview 3, which was released today. (It worked fine on preview 2)

Me too...

Then tuning DVC doesn't solve issue about clipping sounds

Share this post


Link to post
Share on other sites

Just installed the new beta for N on my Nexus 5X and the latest alpha wont work on it.

I sent several bug reports.

Share this post


Link to post
Share on other sites

Poweramp will definitely be set up to work with Android N by the time of the proper releases (as both Poweramp and Android are still very early test copies). Thanks for the reports.

Andre

Share this post


Link to post
Share on other sites
8 minutes ago, andrewilley said:

Poweramp will definitely be set up to work with Android N by the time of the proper releases (as both Poweramp and Android are still very early test copies). Thanks for the reports.

Andre

Cool.

Share this post


Link to post
Share on other sites

I've commented elsewhere that I'm sure Max will address this at some point before the official releases, but both Poweramp v3 and Android N are still in early testing stages at the moment.

Andre

Share this post


Link to post
Share on other sites
15 hours ago, Fetiz said:

The same as me. And I tried to reinstall it. Still not working with crash. Please fix this.

I found that using the stable build (588 i think) still works on Android N.... sometimes crashes but it works.

 

 

Share this post


Link to post
Share on other sites
8 hours ago, verycoolalan said:

I found that using the stable build (588 i think) still works on Android N.... sometimes crashes but it works.

 

 

But it still occurs that lib errors.

Share this post


Link to post
Share on other sites

Hello dear community!

I would tell,that all the Poweramp Alpha build won't work with the latest beta of Android N(NPD35K).The V2 work properly.Only the alpha builds will crash at Poweramp start screen.

Can anyone help me?

Share this post


Link to post
Share on other sites

Sorry, but at present the answer is not to use alpha test apps with alpha test operating systems (well, semi-beta now in the case of Android-N) unless you are prepared for some issues. There will be a fix before the final release builds of course.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, perettigiuliano said:

Poweramp doesn't work anymore on Android n preview 3. I know it is a preview, do you plan to do something about?

No, I think the plan is for it to only ever work with older versions of Android..... ;)

But seriously, as you say, you are running an alpha test app on a alpha/beta test OS. Once they both get a bit closer to release versions, I'm sure it will be fine.

Andre

Share this post


Link to post
Share on other sites
Just now, andrewilley said:

No, I think the plan is for it to only ever work with older versions of Android..... ;)

... As you say, you are running an alpha test app on a alpha/beta test OS. Once they both get a bit closer to release versions, I'm sure it will be fine.

Andre

got it... as developer i understand your thoughts:D

Share this post


Link to post
Share on other sites
9 hours ago, perettigiuliano said:

Poweramp doesn't work anymore on Android n preview 3. I know it is a preview, do you plan to do something about?

10x

If he has to take away time from the rest of us Android 4, 5 and 6 users, then I hope he plans to do NOTHING about N until N is finalised and in production. Given that he took more than 4 years to add support for the niche but important Opus codec, he better treat N with the same level of priority because there's plenty more bugs with Poweramp in 4, 5 and 6 to resolve.

Share this post


Link to post
Share on other sites

Just had some feedback from Max on this one.

Apparently for the recent preview release of Android N, Google seem to have broken OpenSL, which is used for the default audio driver. Ironically, Poweramp's own driver would work fine, but you can't get as far as selecting it as the app is crashing as soon as it initially tries to start OpenSL. Hopefully Google will fix this problem on the next Android N preview/test release, and Max says he does not plan to spend time trying to create a workaround at this stage - unless it's still broken in the next release.

The release version of Poweramp (build 588) does not trigger this problem incidentally, and it should work fine apart from a small popup about libraries which can be ignored for now until another build is required.

(I've merged all the other discussions on this subject into this thread to make it easier to follow)

Andre

Share this post


Link to post
Share on other sites
2 hours ago, andrewilley said:

Just had some feedback from Max on this one.

Apparently for the recent preview release of Android N, Google seem to have broken OpenSL, which is used for the default audio driver. Ironically, Poweramp's own driver would work fine, but you can't get as far as selecting it as the app is crashing as soon as it initially tries to start OpenSL. Hopefully Google will fix this problem on the next Android N preview/test release, and Max says he does not plan to spend time trying to create a workaround at this stage - unless it's still broken in the next release.

The release version of Poweramp (build 588) does not trigger this problem incidentally, and it should work fine apart from a small popup about libraries which can be ignored for now until another build is required.

(I've merged all the other discussions on this subject into this thread to make it easier to follow)

Andre

Great and fresh news, 10x

Share this post


Link to post
Share on other sites

So, if I read this correctly (and it's just speculation on my part as I don't run N) installing 588, changing the default audio driver from OpenSL to Poweramp's own and then updating to the 703 alpha while retaining the previous settings should solve the problem, right?

Share this post


Link to post
Share on other sites

No, 588 can't change the necessary settings anyway.

As far as I know, 703 will not work at all with the current preview of Android N, and that's unlikely to change soon until Google release a fixed version (or it becomes obvious they aren't going to, and a long-term workaround needs to be found).

So for now you need to choose whether testing the preview of Android or testing the alpha of Poweramp v3 is more important to you.

 Andre

Share this post


Link to post
Share on other sites

Then the only other way I can think of is to:

A) Revert to preview 2, choose the driver setting and then upgrade back to preview 3

or

B ) Create a Titanium Backup with the appropriate settings and distribute it here.

Share this post


Link to post
Share on other sites

As I said before, as far as I'm aware that won't work. The initialisation of OpenSL, which happens upon app startup, is what is causing the crash (before PA has determined what it wants to do next as far as audio drivers are concerned). But you are welcome to try, and report back if it works.

Andre

Share this post


Link to post
Share on other sites

Quick fix (build-704) is available here (same link as 703, it will suggest 704 for you): 

Please note, that this build hasn't been tested on non N devices. Also, N preview 3 (on some devices, like Nexus 5X) introduced issues with OpenGL driver, causing Poweramp visualization become black sometimes.

As UI (and album art/visualization area, specifically) is changed in development UI builds anyway, so no point to fix that for Poweramp Alpha + N preview 3.

 

Share this post


Link to post
Share on other sites

Thank you!!! I can confirm that this build 704 works with N preview 3.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now