• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It is hoped this will be ready for final beta-testing by the end of the May. See forum thread for more details and to discuss.    
maxmp

Poweramp alpha-build-703/704

563 posts in this topic

17 hours ago, KPOCAB4EG said:

Where a new design? And Cloud Support.

There will be interface updates in the first proper Beta test release (this is just an alpha-test, for the new audio engine mainly). Some streaming output options are planned to be added in the second beta release (DLNA, Chromecast for example) but 'cloud support' is a rather vague and nebulous description - I don't think Poweramp is likely to become a major player in the Spotify etc internet-streamed music scene any time soon, and even less so with more regional services.

Andre

Share this post


Link to post
Share on other sites

@phobos24

 

hey phobos sir, still got your v10? the new update appears to have fixed the earlier concern we had.. I'm now using the experimental hi-def output with no issues (so far)....

Share this post


Link to post
Share on other sites

I am on a LG G3,  5.0.1 stock rooted rom. 

The hi-res output works all fine on mp3 320kbps but as soon as i switch to FLAC, it occasionally makes a scratched cd kind of noise while playing, the noise shows up on the visualization bars as well. 

 

I've confirmed the device memory and earphone jack to be okay, so the issue might be in Poweramp. 

QuickMemo+_2016-04-20-10-35-59.png

Share this post


Link to post
Share on other sites

First of all i love the new UI, the visualization is nice and the sound quality got better.

I've only one issue since the update to 703, when i'm listening to music while using another app, changing the volume is not possible.

Using Poweramp on LG G4

 

Kevin

Share this post


Link to post
Share on other sites

Still loving the new updates, sounds fantastic on my S6 - however 703 still has no album art in album artist for me.  Also the list sort in the normal albums view seems to keep resetting to year?

Share this post


Link to post
Share on other sites
13 hours ago, Nathanix said:

First of all i love the new UI, the visualization is nice and the sound quality got better.

I've only one issue since the update to 703, when i'm listening to music while using another app, changing the volume is not possible.

Using Poweramp on LG G4

 

Kevin

Have you tried toggling DVC on and off? I noticed the same thing on my Galaxy S6 Active when I turned on Hi-Res and enabling DVC solved it. 

Share this post


Link to post
Share on other sites

I installed alpha 3 over alpha 1 and now when I go to genres, I see albums instead of artists.

It used to be Genre/Artist/Album/Song. 

Now it's Genre/Album/Artist/Song.

Please advice.

Share this post


Link to post
Share on other sites

hi, using 703 for a couple of days now without issues on my htc m9.
i also managed to get musicFX working with some edits in htc_audio_effects.conf which are also needed to get viper4android to work.
using viper in compatibility mode i can enable it with the musicfx button :)

however it doesnt work in hi-res mode... it either has no effect or it kills the sound (comes back after toggling hi-res off and on)

cheers

Share this post


Link to post
Share on other sites
55 minutes ago, fichl said:

hi, using 703 for a couple of days now without issues on my htc m9.
i also managed to get musicFX working with some edits in htc_audio_effects.conf which are also needed to get viper4android to work.
using viper in compatibility mode i can enable it with the musicfx button :)

however it doesnt work in hi-res mode... it either has no effect or it kills the sound (comes back after toggling hi-res off and on)

cheers

That's because Viper doesn't support native processing of 96khz tracks. It will downsample your hi-res tracks back to 48/44.1 kHz. That's why I ditched Viper after v3 alpha. No plugin required whatsoever.

Share this post


Link to post
Share on other sites
46 minutes ago, whiplash1 said:

That's because Viper doesn't support native processing of 96khz tracks. It will downsample your hi-res tracks back to 48/44.1 kHz. That's why I ditched Viper after v3 alpha. No plugin required whatsoever.

thanks, the same happens with boomsound... not available in hi-res mode.. probably the same issue...
have to admit with good headphones the sound of Poweramp is just perfect...

with my cheap earplugs the viper sound is a little better with convolver and the right ir´s.

read somewhere musicfx should work on hi-res but what effects / plugins support it then ?

Share this post


Link to post
Share on other sites

I just wanted to say that before installing 3.0 on my HTC One M8, I always had some weird electronic static in the background that was particularly obvious at the ends of tracks. Now, it's gone and crystal clear, so 3.0 gets a big  thumbs up from me for that reason alone. Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, fichl said:

thanks, the same happens with boomsound... not available in hi-res mode.. probably the same issue...
have to admit with good headphones the sound of Poweramp is just perfect...

with my cheap earplugs the viper sound is a little better with convolver and the right ir´s.

read somewhere musicfx should work on hi-res but what effects / plugins support it then ?

AudioFX has more or less negligible effect. Use the stereo expand option and you won't need anything else :)

Share this post


Link to post
Share on other sites

Scrobbling to lastfm (via simple last fm) is completely broken when using hi res output on LG v10 :(

Problem not occurs when playing via integrated snapdragon audio (without connected headphones). 

I don't know if problem existed before, I just bought V10. 

 

Rest is working, there is even no need to use 'hifi dac enabler' 

Share this post


Link to post
Share on other sites

Might anyone be able to explain what "Resampler Cutoff Frequency Ratio" is, and how to use it ? ... It's listed under Settings>Audio>Resampler ... Thanks for the help --- also, is there any word on an automatic native sampling rate option in the works ?

Share this post


Link to post
Share on other sites
On 20.4.2016 at 1:10 AM, SpiderNhan said:

Have you tried toggling DVC on and off? I noticed the same thing on my Galaxy S6 Active when I turned on Hi-Res and enabling DVC solved it. 

Didn't work for me but disabling Hi-Res output solved the problem

I'll give Hi-Res output another shot with alpha 704

Share this post


Link to post
Share on other sites

So far, love the latest alpha release. Album art issue has been fixed. And thank you adding the ability to have visuals change based on elapsed time.

Keep up the great work! Poweramp is my #1 choice and has been since I purchased it years ago.

 

Share this post


Link to post
Share on other sites

Is it possible to add back the overflow options? My case makes it hard to swipe from the edge and I'm already very used to using the overflow button to get into the settings menu. If there could be something under Look & Feel that lets you edit what shows up on the overflow menu, or even just use the overflow button for the menu you swipe from the left, that'd be ideal.

Share this post


Link to post
Share on other sites

Anybody having issues with bluetooth skipping on this version?

Used to have no issues. Now I get little "micro-skips", usually 1-3, about every 20-30 seconds. I do not have this issue with aux out (so it's a bluetooth issue), and I don't have the issue with other apps.

I am running on a Nexus 6P with Android N preview (which may be a culprit). It didn't help to change the buffer settings for bluetooth.

It may be just me. :)

Thanks!

Eckless

Share this post


Link to post
Share on other sites
1 hour ago, Eckless said:

Anybody having issues with bluetooth skipping on this version?

Used to have no issues. Now I get little "micro-skips", usually 1-3, about every 20-30 seconds. I do not have this issue with aux out (so it's a bluetooth issue), and I don't have the issue with other apps.

I am running on a Nexus 6P with Android N preview (which may be a culprit). It didn't help to change the buffer settings for bluetooth.

It may be just me. :)

Thanks!

Eckless

Came here hoping I wasn't the only one. I'm having the exact same issue on an LG V10.

Share this post


Link to post
Share on other sites
17 hours ago, aidane154 said:

Is it possible to add back the overflow options? My case makes it hard to swipe from the edge and I'm already very used to using the overflow button to get into the settings menu. If there could be something under Look & Feel that lets you edit what shows up on the overflow menu, or even just use the overflow button for the menu you swipe from the left, that'd be ideal.

There are two menu icons on the player screen, the 'three lines' menu on the left, which takes you to the list which includes Library views and Settings, and the 'three dots' one on the right for local options relevant to the current screen (current song actions, etc). Max says he has done this to fit in with Google's guidelines for how such buttons should work, but personally I just find it more messy and convoluted - but then I find that of a lot of Google's design ideas (Menus have worked just fine since the dawn of graphical interfaces, what on earth possessed them to suddenly declare that they shall henceforce be known as 'overflow lists' ???).

Andre

Share this post


Link to post
Share on other sites
On 4/16/2016 at 6:16 AM, maxmp said:

Please also see small alpha FAQ here:

Check also (growing) list of supported Hi-Res output Android devices:

Request Hi-Res support if your device supports it, but Poweramp doesn't:

I just want to ask if there would be support for Edge screen devices like the Note Edge. I really appreciate the extra screen real estate usage. It makes my life easier and is the main reason why I opted out of the beta. It didn't support the Edge screen on my Note Edge

Secondly, will the new Poweramp be able to play music from cloud sources like One Drive. I have a lot of my songs there and some playlists. It would be nice to be able to use the same playlist if I uninstall Poweramp or reset my phone. I hate having to redo my playlists after I uninstall Poweramp

Share this post


Link to post
Share on other sites

Make sure you export your playlists before uninstalling, then they are there as file-based playlists when you need them.

Andre

Share this post


Link to post
Share on other sites

The Poweramp buttons on the Android lockscreen doesn't work with my zenfone 5  [LP]. They're there, but don't do anything.

Share this post


Link to post
Share on other sites

scrobbling seems very broken with this build

I look at last.fm and there's a lot of tracks missing and there's tracks I definitely haven't played, I started playing one album and drove for 45 minutes, last.fm only shows the second track and everything after it isn't even the same artist

simple last.fm shows the last now playing notification was submitted 20 minutes ago even though I'm still playing music and that wasn't even what I'm playing

 

edit: just disabled simple last.fm and enabled it for the official app in both apps, let several tracks play, no scrobbles.

Share this post


Link to post
Share on other sites
On 4/17/2016 at 3:25 PM, staticx said:

1. Music doesn't pause when a call enter, It's muted but the song is I have progress.... So when I finish the call, it's already the next song... 

 

2. Whatsapp notifications causing the music to pause when connected to android hear unit that is running Poweramp. 

problems still exists. also when a phone is connected via bluetooth to another device that is running Poweramp, music always stops and resume when notification enters or on dialer screen. I had to turn off the "Bluetooth Media" and use the phone only for calls and not for streaming music.

also I add no. 3 - 

Music doesn't resume when opening Poweramp again, it starts the song again. - now picture that: Poweramp is running at my android head unit, and I was stopping my car about 10 times for some arrangements (shopping, fueling etc.) and every time, I've heard the same song from the beginning !

please try to fix those issues on next release...

thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now