• Announcements

    • andrewilley

      Poweramp v3 Project Update   03/22/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It's not quite ready for open testing yet, and although he would like to be able to get it out by the end of the March it may just drop over into April. See forum thread for more details and to discuss.    
abenson

Poweramp refuses to read certain ID3 tags

4 posts in this topic

I'm presently using Poweramp build 581 on an LG G4, but I had the exact same problem on my previous phone, a Samsung S4, and have had the same issue with all builds of the program that I've used.

I'm a bit of a nitpicker when it comes to artists and albums all being tagged properly and organized nicely, and I've noticed that there are a few albums that Poweramp consistently refuses to recognize the ID3 tags for, and dumps them all into "Unknown album" by "Unknown artist".  I know for an absolute fact that these files are properly tagged, because I've manually entered them on PC, and if I plug my phone into a PC and look at the files on the phone all the tags are present and correct, but on Poweramp all the tags show up blank.

 

The stock music player on my new phone properly reads all the artists and albums, so I tried out a few other android music players, and all of them also have no problem reading all the tags, but none of them are as good as Poweramp otherwise.

 

I know I can manually enter tags in Poweramp, but that's massive pain, especially when I've already entered the tags on PC, and no other program has trouble reading them.

What up with that?


If it matters, one album in particular that Poweramp steadfastly refuses to recognize is Prologue by The Milk Carton Kids, and it also doesn't want to read the tags on a great deal of music by Art Blakey and the Jazz Messengers, can't recall which albums in particular.

Share this post


Link to post
Share on other sites

So, I've just re-re-re-edited the tags on that MKC album on my computer and re-added it to my phone, and as if to spite me, NOW Poweramp sees it. 

 

 

Still don't get it.

Share this post


Link to post
Share on other sites

I have seen this happen a few times before, sometimes it has something to do with the files tag formattings and version, I have found that one trick is to open the files in a program called "mp3tag" and resave (re-embed) the tags into them.

 

I also use this program to remove accidentally embedded artwork from my music files.

 

Note: The program works for basically any music format, not just MP3.

 

I hope that helps.

Share this post


Link to post
Share on other sites

If you have a specific file or files with bad tags that always cause this issue, please forward examples to poweramp.maxmpz@gmail.com for testing.

In the meantime, try using a batch tag editor on a PC to see if that resolves the problem by rewriting the problem tags more correctly. I use TagScanner, but there are lots out there.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now